FP4 Root Access is possible, maybe a bit risky

It feels more safe to always possible to go back and reflash te device. I manged to root my device and it works great. I had to fight a little with magisk, i first installed version 24.1 removed that because i couldnt pass cts profile. On magisk 23 it works and i can install for me the nessary apps. Many thanks for your discription of the steps. very good!

2 Likes

Hi, I’ve alreaady installed e/OS/ on FF4 and tried following all the steps to root with magisk. I used the boot.img from the the /e/ folder but magisk crashes every time I try to patch. So I used the pre-patched /e/ boot.img from this thread, that worked but when I need to direct install with magisk which still crashes everytime I try.

Are you running the latest /e/ version? :thinking:
That sounds like the problems the first /e/ release had where they set the jvm heapsize too low…

Oh and welcome to the forum :wave:

I rooted my device with this , what’s the best way to update ? I am very happy with the way root works without any issues.

One way would be:

  1. In the Magisk app choose UninstallRestore images
  2. Reboot
  3. Perform OTA update
  4. Reroot

Just checked, worked fine :smiley:
You can of course also flash the original boot.img instead.

Be careful: If you made modifications to your system apart from (or even with) Magisk modules, removing Magisk might break your system, make a backup first!!!

Oké that’s not difficult. I will wait till I get the OTA update I just checked but it’s not available in my region yet.

It’s not needed to relock the bootloader?

Did you lock the bootloader after rooting? :thinking:
I generally don’t on a Magisk-modified phone. If something breaks and I need to flash the original boot.img back that wouldn’t be possible anymore.

While you absolutely should re-lock your bootloader from a security perspective, I personally have no experience with a locked bootloader combined with Magisk (and I don’t intend to try it), so someone else will have to chime in here.

No I leave it unlocked, I mean do I have to relock for to get the OTA update? For example on Samsung you cannot install OTA updates on an unlocked device.

Aaah, that’s what you meant :see_no_evil:
No, you don’t have to re-lock it to get the OTA, the update showed up without problems on the two unlocked FP4s I have access to :slightly_smiling_face:

1 Like

Ok then I wait for the update, uninstall magisk and re root afterwards. Many thanks for the answers.

1 Like

I can confirm! I run a unlocked FP4 not rooted (I have no frequent need of root so when I need it, I just fastboot boot :slight_smile: ) and I receive the OTA updates.

Keep in mind that if you re-lock the bootloader it’ll factory reset your phone!

1 Like

Oké i installed magisk and installed the update. For to reroot do I have to have the .103 boot image? And where to find it?

I got the new boot.img with TWRP:

  • update to A.0103
  • fastboot boot twrp.img
  • Backup > boot partition (on external SD card, as TWRP cannot decrypt internal memory)
  • then reboot to system, and open the TWRP directory: the file is there :slight_smile:

And it’s needed for to reroot the device?

You use the boot.img in magisk as described in this post:

Thanks I just did it with the new boot image and it works very well. Even all apps where present and the device was as it was. A very easy method…

1 Like

For future reference: You don’t need a new boot.img to fastboot boot from, any of the old Magisk patched ones should do. Just make sure it’s from the same “distribution”, so no /e/ images on a device running vanilla FPOS. At the moment booting images from other ROMs still works, but that might change if they make significant changes to the boot.img.

Since everyone seems to want new and shiny, here are boot images from FPOS-A.103, e-0.22 and iode-2.3 patched with Magisk v.24.2.

The current stock boot images for FPOS can always be found on the kernel page, the /e/ ones can be taken from their released zips and the iode ones can be extracted from their ota.zips using payload-dumper-go.

If you absolutely need the version from your phone and don’t have TWRP handy, as @oli.sax suggested (or need a partition not accessible to it), there’s always dd:

1 Like

I was unable to boot on A.099-boot-patched.img with my OS on A.103, but perhaps it’s just me? That’s why I went to A.0103-boot-patched.img :slight_smile:

TBH I tried only once, if it works for you I can give it another try :wink:

Just tested it again and works for me (takes some time to boot).
My A.067 one still boots fine as well (but takes even longer) :smiley: