FP4 Root Access is possible, maybe a bit risky

So i found something i guess maybe:

When im opening the old “Settings”-App (which was my magisk) it says: “Magisk-App wiederherstellen. App kann im versteckten Zustand nicht weiter funktionierne, da Root verloren gegangen ist. Ursprüngliche APK bitte wiederherstellen.” When i try to press install it tries to install the apk which fails (i guess since i already updatex to the new magisk version). Maybe its an option to deinstall magisk manager AND the “Settings”-App and reinstall the newest version of magsik-manager as recommended here: 2 Solutions! Problem w/ MagiskHide being disabled after reboot/closing MagiskManager. | XDA Forums.

When i run su in termux on my regular os it says su ist not installed, but when i open it on the patched version i can grant superuser permission

When i now pressed magisk (while running the patched version), it was hidden again, but i could open it via (hidden) Settings app. I chose “magisk app wiederherstellen”. The app now shows that im on version 25.2.

i disabled universal safety net, and installed magisk to slot a (after OTA). after that i still get bootloops.

i then went back on my common os (slot b). Settings app was not visible anymore. I updated to version magisk manager to magisk 26.1.

I booted back on the patched img via fastboot, here magisk app is on 26.1 and it says magisk is installed on 25.2, it gives me the option to Update to second slot after OTA.
Still gettin bootloops.

next i first disabled and second time removed universal safety net. still gettin bootloops.

Then i tried to disable zygisk. it says new start is necessary so changes take effects.
After a new start zygisk (with fastboot into the patched img) is disabled. I tried another patch after OTA. Still bootloops.

After another boot to the patched os, magisk says Dein Gerät benötigt ein Reflash von Magisk, um richtig zu funktionieren. Bitte Magisk innerhalb der App neu installieren, der Widerherstellungsmodus kann keine korrekten Geräteinformationen abrufen.

I then activated Zygsik again, deactived denylist, and then deactivated Zygysk, installed with OTA. Still bootloops.

I then activated Zygsik and denylist, then unchecked every app from the denylist and deactives both again, installed OTA. still bootloops.

after another installed to second slot-> bootloops

Is there a risk of deinstalling the magisk manager app and reinstalling it and then trying it again?

If this doesnt help, whats the best way to get a working system on my slot a?

Sounds to me like you have 2 Magisk apps installed at the same time. I’d uninstall the newer one, unhide the old one, update it and see if that improves things.

So it works :metal:

Are you booting the image you patched yourself? Mine should be on 26.1 :thinking:

You can absolutely try that.

Once you get bored figuring this out, Magisk app → :wastebasket: Uninstall Magisk → Complete Uninstall.
Then fastboot flash boot_a the …

… switch to slot a and it should hopefully boot :crossed_fingers:

1 Like

Id had two apps. I deinstalled both and then reinstalled the newer one.

This is not working. Still getting bootloops on boot_a :frowning:

If the stock boot.img doesn’t work, I suspect something else might be broken.

You can try intalling the …

… from the recovery in slot b, to see if you can get the OTA update going again, personally I’d consider reflashing the system to factory images at this point.

Hey everyone, I follow this guide to root my fairphone4,
but the device does not boot when I want to relock the bootloader.
(I do a manual install with fastboot to reinstall fairphone os and it work again.)

So is it possible to lock bootloader after install magisk?

No its not possible…


Thank. I ask because my previous android phone can relock after install magisk, and I believe many its user do so.
Therefore I tried to relock bootloader after root with magisk.

Did google change the policy?
Isn’t it dangerous to keep the bootloader unlocked?

I’m just complaining.
I read a post explain the relationship about unlock and security:

It seem we still had data partition encrypted before one unlock his android after boot.

Unless you build your own ROM and can sign the patched boot.img yourself you won’t be able to lock your bootloader on a rooted phone.

This has nothing to do with Google changing a policy, but everything with how Android Verified Boot works.
Locking the bootloader enables AVB, so the system checks your /boot partition (and others) against a known list of partitions. When you patch the image with Magisk it doesn’t match that expectation any more and the system doesn’t boot.

If you had a phone before that let you lock the bootloader regardless, it’s very likely AVB wasn’t active, which severely undermines the whole security concept …

Anyways, if you insist on trying this again (not that it would change the outcome), always check fastboot flashing get_unlock_ability and never lock it if it returns 0.
It’s quite easy to brick the FP4 when locking the bootloader, consider yourself lucky.


I tried today to disable Safetynet Fix and unhide Magisk prior to run the OTA. It did not help and I ran again into a boot loop

1 Like

can i ask where youre getting these boot images? since you said the ones on the official site are outdated, where do we actually find them? im curious since i cant get ota updates to work with magisk alpha

I dd them from a running system, or take them from the factory images (if available), but you don’t have to (at least for now) :point_down:

1 Like

im running into a weird issue, i completely unrooted my phone from magisk alpha through the in app uninstall and rebooted. now even after unrooting i am running into the issue where my ota updates fail with the message “Installation problem” anyone know why this could be?

edit: oh boy i think theres more issues, when i try to boot an other patched image from fastboot with “fastboot boot boot.img” i get “FAILED (remote: ‘Unrecognized command boot’)”

I also tried disabling Zygisk and Safetynet Fix (app wasn’t hidden), and got bootloops.
I then updated without root and rerooted.


Sounds like you are in fastbootd instead of regular fastboot.

As to why your OTA update still fails, my guess would be Magisk wasn’t able to restore the stock boot.img. Did you notice any errors during uninstall? :thinking:

i just tried a full system reset to make sure. even after the full restore to factory im still running into the same issues

A factory reset doesn’t restore any partitions, if you didn’t flash factory images your system partitions are the same as before.

1 Like

i was indeed in fastbootd. the reason i tried that is when i try to use the command in fastboot, i get the message “waiting for any device”

edit: usb debugging is enabled and i ticked the always allow from this computer before i rebooted to fastboot

Sounds like the usual fastboot USB issue, try different ports / cables until it shows up. It’s a bit anoying to get it working sometimes.

To solve your overall problem, check which slot you are in adb shell 'getprop | grep slot', download the right boot.img (Settings → About phone → Android-Version) from here, and use fastboot flash boot_{your slot} boot.img.
That should hopefully get your OTA to work. If it doesn’t, one of the other partitions has been altered and we would need to have a look at the logs in that case.

tried all of my cables and ports for over 30 minutes now with no success. im pretty sure i have the correct drivers installed with the google usb driver

I mean you rooted your phone at some point, so it has to have worked sometime in the past :thinking: