FP4 Root Access is possible, maybe a bit risky

I just followed exactly the perfect few steps specified by @hirnsushi
So now I can enjoy adaway without the need for vpn feature activated, was able to debloat my phone from all the crap my carrier provider Orange put on my phone, and that’s just the beggining :smiley:

1 Like

…and Google Pay with NFC works?


Absolutely not.
Seems like safetynet is broken

Edit: got it working, answer is right under. sorry for the messy posts mods :frowning:

1 Like


So in the end, I followed a long XDA thread and now I got everything google pay related in order. SafetyNet pass + certified device.

You will need:

  1. Magisk with:
  1. Enable Magisk hide and hide Magisk from the following packages:
  • Google Play Store
  • Google Pay
  • Google Play Services
  1. Now the part that is very important to follow otherwise it will not work :
    . Put your phone in Airplane mode
    . Clear all data from:
    • Google Play
    • Google Pay
    • Google Play Service: remember, clear ALL data, not just cache even for this one
    • Reboot
    • Toggle Airplane mode off

Everything should be in order.

----------------- under this line is outdated content -----------------

Alright, so I finally got google Pay to work:

Had to:

  1. download Riru module in Magisk
  2. download and install Riru’s universal SafetyNet’s fix 2.1.2 in Magisk

Enable both modules, restart, enjoy :wink:

EDIT: I’m really sorry but I have spoken too fast; although I can pass SafetyNet and add credit cards, NFC paiements attempts actually do… nothing.
Will investigate further…


It’s a really interesting option, but I will wait for the moment the the stockroom is available. So when something went wrong I can reflash te device.

1 Like

Could you share stock boot_a.img and boot_b.img for A.091 version?
I accidentally flashed boot.img meant for A.067 version and i am stuck with broken wifi

Sure, here you go: Fairphone 4 stock boot images.
boot_a.img is patch level September and boot_b.img November, not sure this will get you WiFi back though. It didn’t work for me when i booted them from RAM, so you probably will still have to enable it manually from the command line. But maybe things are different if you actually flash them.
I must really make this clear, at no point did I flash a boot.img to my device, so you are entering uncharted territory here.


Thank you, I flashed these and it works now

1 Like

Great news! :+1: There’s hope if something goes wrong.
Did you have to mess with kernel parameters or did wifi just work™? :thinking:

Great! I tried rooting my new FP4 the way Hirnsushi said and it worked! Thanks so much! Was a bit worried some things stopped working (WiFi, SD card) after the first reboot :sweat_smile:

Now that Magisk is working, has anyone tried installing Xposed (LSposed module) yet?
I’m reluctant to be the first to try, when there is no easy way yet to unbrick if necessary… :sweat_smile:

I am not going to try it unless there is an unbrick method. I really like an rooted device I always did it with all my mobile phones but I have to be patient…

I am stuck and can not move forward
After point 3: adb reboot bootloader I was in bootloader mode.
After that I entered the command “fastboot boot /path/to/patched_boot.img” got the message:
“< waiting for device >”

Here I did not know what to select on the smartphone with the volume keys?

You need to make sure your computer can see your phone by “fastboot devices” command
If it doesnt, then u may need to install adb/fastboot drivers

@hirnsushi it just worked™ without additional tinkering

1 Like

Ok, my phone is shown as “Android” in the device manager at this moment. But there is no driver installed. Where can I download the driver for it?

Download “ADB composite driver” (quick search on google should do), manually install driver from device manager using downloaded driver, choose “Android ADB Interface” and device should be visible.

(also you might have to tell your device to trust your computer, a popup should appear when plugging cable)

Ok thanks, already again a piece further.
But already the next problem…

C:\ADB>fastboot boot boot1.img
Sending ‘boot.img’ (98304 KB) OKAY [ 2.165s]
Booting FAILED (remote: ‘Fastboot boot command is not available in locked device’)
fastboot: error: Command failed

Bootloader is already unlocked…

You did enable USB debogging + toggled OEM Unlock on in developper settings right ?

Edit: my bad, didn’t read carefully thought you were trying to unlock bootloader. Message seems to say bootloader is not unlocked. Do you get the warning about having an unlocked bootlaoder when starting device ?

Please check the output of $ fastboot getvar unlocked :thinking:

Edit: On a second thought did you maybe accidentally boot into fastbootd instead of fastboot? Make sure you use $ adb reboot bootloader not $ adb reboot fastboot.


Yes both are enabled in Developer Options.

C:\ADB>fastboot getvar unlocked
unlocked: no
Finished. Total time: 0.003s

Yep, so there’s your problem, the bootloader isn’t unlocked.

Edit: Use $ fastboot flashing unlock again, but remember this will wipe your phone.