FP4 Root Access is possible, maybe a bit risky

No its not possible…


Thank. I ask because my previous android phone can relock after install magisk, and I believe many its user do so.
Therefore I tried to relock bootloader after root with magisk.

Did google change the policy?
Isn’t it dangerous to keep the bootloader unlocked?

I’m just complaining.
I read a post explain the relationship about unlock and security:

It seem we still had data partition encrypted before one unlock his android after boot.

Unless you build your own ROM and can sign the patched boot.img yourself you won’t be able to lock your bootloader on a rooted phone.

This has nothing to do with Google changing a policy, but everything with how Android Verified Boot works.
Locking the bootloader enables AVB, so the system checks your /boot partition (and others) against a known list of partitions. When you patch the image with Magisk it doesn’t match that expectation any more and the system doesn’t boot.

If you had a phone before that let you lock the bootloader regardless, it’s very likely AVB wasn’t active, which severely undermines the whole security concept …

Anyways, if you insist on trying this again (not that it would change the outcome), always check fastboot flashing get_unlock_ability and never lock it if it returns 0.
It’s quite easy to brick the FP4 when locking the bootloader, consider yourself lucky.


I tried today to disable Safetynet Fix and unhide Magisk prior to run the OTA. It did not help and I ran again into a boot loop

1 Like

can i ask where youre getting these boot images? since you said the ones on the official site are outdated, where do we actually find them? im curious since i cant get ota updates to work with magisk alpha

I dd them from a running system, or take them from the factory images (if available), but you don’t have to (at least for now) :point_down:

1 Like

im running into a weird issue, i completely unrooted my phone from magisk alpha through the in app uninstall and rebooted. now even after unrooting i am running into the issue where my ota updates fail with the message “Installation problem” anyone know why this could be?

edit: oh boy i think theres more issues, when i try to boot an other patched image from fastboot with “fastboot boot boot.img” i get “FAILED (remote: ‘Unrecognized command boot’)”

I also tried disabling Zygisk and Safetynet Fix (app wasn’t hidden), and got bootloops.
I then updated without root and rerooted.


Sounds like you are in fastbootd instead of regular fastboot.

As to why your OTA update still fails, my guess would be Magisk wasn’t able to restore the stock boot.img. Did you notice any errors during uninstall? :thinking:

i just tried a full system reset to make sure. even after the full restore to factory im still running into the same issues

A factory reset doesn’t restore any partitions, if you didn’t flash factory images your system partitions are the same as before.

1 Like

i was indeed in fastbootd. the reason i tried that is when i try to use the command in fastboot, i get the message “waiting for any device”

edit: usb debugging is enabled and i ticked the always allow from this computer before i rebooted to fastboot

Sounds like the usual fastboot USB issue, try different ports / cables until it shows up. It’s a bit anoying to get it working sometimes.

To solve your overall problem, check which slot you are in adb shell 'getprop | grep slot', download the right boot.img (Settings → About phone → Android-Version) from here, and use fastboot flash boot_{your slot} boot.img.
That should hopefully get your OTA to work. If it doesn’t, one of the other partitions has been altered and we would need to have a look at the logs in that case.

tried all of my cables and ports for over 30 minutes now with no success. im pretty sure i have the correct drivers installed with the google usb driver

I mean you rooted your phone at some point, so it has to have worked sometime in the past :thinking:

Did you reboot the phone before installing the OTA, did it boot properly then? :thinking:

This issue is still completely baffling to me, it has to be one of the modules, but I can’t figure out why…
Could you boot your phone into Safe Mode next time before the OTA. That will disable all modules at once and should at least tell us if those are really the issue.

I just did the update for my family member, again absolutely no issues, this is infuriating :see_no_evil:

Yes, I did and it booted normally before the OTA

Then it has to be one of the other modules, or we are completely missing something here :thinking:

The problem is that testing is only possible when a new update is available, And with the update frequency of FP…

update, tried the linux version of adb and that let me connect the device to fastboot on the first try and flash the boot image, youre an absolute legend hirnsushi.