FP4 Root Access is possible, maybe a bit risky

If I would decide to update to Android 12…
The way to do it would be

  • uninstall Magisk (therefore remove root access)
  • update to Android 12
  • re-root with your patched FPOS-A12-magisk-boot.img

I am cautious when I think about my last update attempts. :face_with_raised_eyebrow:

If you don’t intend to perform a factory reset you don’t need that boot.img, you can just follow the usual process:

I’ve had no issues upgrading my family members phone to A12 that way, but as always, YMMV … :upside_down_face:

Yes, it seems to. :wink:

1 Like

Hmm, weirdly enough I’ve been able to update LOS official without restoring the original boot.img.

I basically let the update process go through, then flash patched boot to the alternative slot through magisk and reboot.

I wonder if this somehow means my updates are not “full” ie I’d be sticking with the same boot.img while the rest of the system is updated? If that’s even possible…

If the update you are installing is a full update, unlike the usual (at least for FPOS, CalyxOS) delta updates, the hashes of your current partition aren’t necessarily checked, because the update already contains the new partitions and doesn’t rely on the existing ones to be cleanly patchable.

I haven’t played around with Lineage on the FP4 yet, so not sure if that’s the case there. Do you have a OTA link handy? :thinking:
On CalyxOS there sometimes are full OTAs (always available) and those install fine without restoring /boot as well.

Again my FP4 ran into a boot loop after disabling Magisk, updating OTA und trying to install Magisk in the inactive slot. It seems to me as if the a slot is somehow corrupted and cannot boot.
I sticked to the description here OTA Upgrade Guides | Magisk

Does anyone of you know how to fix a corrupted slot?

Strange that that keeps happening to some people. I just updated the FP4 of my family member to the latest release, no issues (as always) and Magisk works as expected.

Could you walk me through the steps you followed to update your system, did you get any error messages at some point? What version of Magisk are you using?

The most likely reason is that there’s something going wrong during the Magisk patching process, the OTA update should generally not produce unbootable slots (unless there’s an hardware issue somewhere) :thinking:

Hi, I followed exactly the procedure in the link above and I got no error message. I use Magisk 25.2 (hidden).

After having the boot loop I started in fastboot and switched the the other slot (in my case b) and restarted successfully without root and without the OTA installed. So I ran the update again and rebooted after that unlike in the original instructions. The I boot via fastboot into some recovery (LOS or TWRP), run dd to get the boot.img and re-root from scratch (first patch the extracted image, boot it via fastboot and the install Magisk directly.

Is there a way to check the two slots for inconsistencies? A hardware issue should produce other problems, too IMHO. And after the second OTA run a is active (before it was b) and it booted successfully so I doubt that there is a hardware problem

I agree, a hardware problem is very unlikely.

Not really, you can check if the partitions match the expected hash, but in the case of /boot that’s not really helpful since you modified it by patching it with Magisk.

Hmm, maybe the issues has something to do with Magisk hide. Never used it and it’s not active on my family members phone either.
Which modules are you using? Anything that could modify the system partition? Maybe we aren’t looking at a Magisk issue here, maybe one of the modules doesn’t properly survive the update :thinking:

OK, maybe next time I try to unhide Magisk before the OTA.

The modules on my phone are:

  • 3C Magisk Helper (but that was not present on the first OTA to A12)
  • ACC
  • Audio misc. settings
  • Busybox for Android NDK
  • DJS
  • ExtSDCard Access Enabler
  • F-Droid privileged Extension
  • MagiskHide Props Config
  • Systemless Hosts
  • Universal SafetyNet Fix
  • Wifi Bonding (Qcom)

Hmm, that’s a lot of variables :thinking:

Let’s postpone this until the next update, maybe we can capture some helpful logs then :crossed_fingers:

Anything else would have been far too easy :stuck_out_tongue_winking_eye:

1 Like

For what it’s worth my Magisk is also hidden and I didn’t encounter a single issue while applying OTA.
As a matter of fact I don’t even need to uninstall magisk before installing OTA. Just installing Magisk on alternate slot before rebooting does the trick.

Feels like there are some modules messing up stuff here

1 Like

I think I have the same problem as @Lars_Hennig since a couple of OTAs. When I go to Settings/System/Updates, I can see the animation running for a second or two and then it returns to the home screen. With Magisk hidden I uninstalled it (reinstalled the original images) successfully, but still can’t access the update.
After unhide Magisk the uninstallation does not work at all and I have the same behaviour acceding to OTA. The only way to do the OTA is to uninstall Magisk, reboot, do the OTA and reinstall Magisk from scratch.
My installed Magisk’s modules :

  • Advanced Charging Controller
  • F-Droid privileged Extension
  • Font Manager
  • Shamiko
  • Systemless hosts
  • Universal Safetynet Fix
  • Webview manager
  • Zygisk -LSPosed

Some ideas ?

Well, in my case everything worked fine with my hidden Magisk until it finally came to the final reboot after patching the inactive boot image.

This time I was able to make it even worse myself: Just before the OTA procedure Magisk installed the beta update 26 (I had activated the beta upgrade path) and after that it was not able to find the stock image backup.

So I uninsttalled Magisk completely and started rooting from scratch this time

Could you capture a logcat please :pray:

  • adb logcat -c && adb logcat > logcat.txt
  • Press the update button and wait for it to fail
  • Stop the logcat

Had the same problem (on Calyx), which I kind of expected to happen. I ended up just downloading the factory images to the phone and dding the boot.img via Termux before starting the OTA update, worked fine :slightly_smiling_face:

1 Like

Thank you @hirnsushi . I saw your answer after I completed the upgrade and reinstalled Magisk from scratch. At the next OTA I will capture a logcat. But I couldn’t even get to the OTA startup screen, because after a second I was back on the home screen

1 Like

Hi every one,

I tried to root my FP4 but after this, my phone have been blocked in a bootloop.
I’m a bit lost and I tried to check every bootloop issue and there is always an other problem with mine.

Also I tried to follow these step (https://support.fairphone.com/hc/en-us/articles/4433978210833) but it’s blocking me at the 14 step because there is no “git-bash.exe” in this folder “bin-msys”.

Or may I need to update the firmware but I don’t know how to do this.

Someone can help me please ?

Welcome to the community :wave:

What steps did you follow to root your phone and at what point did it fail? :thinking:

Can you also boot the phone into fastboot and check the output of fastboot oem device-info please :pray:

Don’t reinstall the system for now, and whatever you do, don’t lock the bootloader!!!

Hi thanks for your quick response :smiley:

I followed these step on youtube (How To Root (Almost) Any Phone in 2020! - YouTube), the help of this forum and this (Fairphone 4 - Root | XDA Forums) with the .img for magisk
The only point who fails is for the reboot, so the last step

Here is the response of my console (I think that my computer don’t detect it in fastboot mode but in recovery the devices shows “unauthorised”) :

My phone shows actualy :
Fatsboot mode

device state : unlocked

Thank you !