FP4 Root Access is possible, maybe a bit risky

I used the boot.img in the CalyxOS installation file (FP4-factory-22307020.zip). That zip includes a image-FP4-sq3a.220705.003.a1.zip, which contains the stock boot.img. I patched that one, booted from it and was able to direct install via Magisk app. Thanks!


Thanks for reminding me, I should probably change the wording of those instructions to be a bit more general. And that link to the boot.img still points to the oldest one available :see_no_evil:

Glad everything worked fine for you :+1:

Edit: Updated :slightly_smiling_face:


I’ve uploaded a new FPOS-A.163-magisk-boot.img, patched with Magisk v25.2, for people who want to skip patching the boot.img.


Patched FPOS-A.170-magisk-boot.img, in case someone needs it :slightly_smiling_face:

1 Like

Where did you find A.170?
On Fairphone 4 Kernel Source Code — FAIRPHONE open source documentation are only up to build A.142.

Thankfully there are at least updated factory images available (but I just pulled the patched image directly from the phone in this case :nerd_face:)

Thank you.
If I want to use the A.170 patched by you I think I have to “direct install” that file with Magisk.
Magisk 25.1 (or 25.2) does not offer that, There is only one option available “Install” → “Select and Patch a File”. If I understand you that’s already done with the file from FP4 Root Access is possible, maybe a bit risky - #236 by hirnsushi

Now I’m stuck.

Are you following the instructions above? :thinking:

You only need to download the patched boot.img and start with the 3rd step in the instructions.
If you don’t have direct install available, have you fastboot booted a patched image?

Yes, I am at point 5.

But there is no “direct install and reboot”.
In Magisk I selected “Install” (upper right corner).
Install shows
(-) Method
( ) Select and Patch a File

That’s all. Nothing like “direct install and reboot”.
It’s Magisk v25.1 (2022.6.19).

What shall I do?

If you don’t have direct install available, have you fastboot booted a patched image?

Yes, that’s what I have done.

Sounds like you aren’t booted into a rooted enviroment … :thinking:
I’ll have to check if everything’s fine with the image I uploaded, give me a second.

The only reason for that was, that I could not find the boot.img for A.170.

Now I downloaded the huge FP4-FP4G-factory.zip.
The unpatched boot.img is images/boot.img, right?

Can I repeat fastboot boot boot.img with that file or does that cause damages?

I just checked the boot.img I uploaded, and that’s working just fine. Any particular reason you are using Magisk 25.1 instead of .2? Maybe that’s causing issues, since it’s been patched with the newer version :thinking:

You can absolutely boot the stock boot.img, but if you don’t patch it beforehand, all you get is the same experience as if you would have booted into your normal system.

You wrote that you patched the A.170 you provided with Magisk 25.1. That’s the only reason.
25.2 makes no difference.

I did, where? :thinking: Last 25.1 image was A.142.

Allright, sounds like a fastboot issue then, you almost certainly don’t end up in a rooted userland for some reason.
What output do you get when you fastboot boot any of those images? Have you tried different USB-cables / -ports? fastboot can be a bit particular when it comes to USB connections …

Meanwhile I successfully rooted the phone using the boot.img from the factory image patched myself.

Thank you for your assistance,

You did not, I have read wrong. Everything o.k.

Great you managed to make it work :metal:

Out of curiosity, did you change anything else, apart from patching it yourself? I’m not sure what went wrong here :thinking:

1 Like

No. Mainly I processed along Fairphone 4 – Root -December 2021 – Stijn D'haese the 2nd time. Since it’s the first time I’m doing it with a new phone, it’s better to have it described in more detail.

1 Like

I just installed the .175 update. After point 3. the phone seemed to be stuck in a boot loop (repeating display of the warning re. unlocked boot loader). After a few minutes the phone started to normal operation. But “About–>Build number” says: FP4.FP4G.A.170.20220920
Therefore I assume the update has not been applied. What shall I do?

Sounds like failed attempts to start the active slot and after defined number of failed attempts the system fell back to the backup (previous) slot.
So I think there’s a problem with the updated slot.

1 Like