FP4 Root Access is possible, maybe a bit risky

That should match the boot_a I uploaded. What happens if you flash that?
If it doesn’t work, make sure it actually gets flashed to the right slot (the slot might be chosen based on suffix :thinking: ) either rename it to your current slot or in fastboot do:

$ fastboot getvar current-slot
$ fastboot flash boot_[your_slot] path/to/boot_a.img

I cant believe it! it worked! I did it the same way yesterday…
oh thank you so much!!!
sound works, wifi works, it believe the rest of it, too!


Nicely done :metal: :smiley:
Now you just have to wait for the update again… :smirk:


Maybe you can sync your Slots…

I used it on a OPO6T, but the script is manufacturer independent

Pre-install instructions

In some cases slot b can be unpopulated or contain much older firmware than slot a, leading to various issues including a potential hard-brick. We can ensure none of that will happen by copying the contents of slot a to slot b. This step is NOT optional.

To do this, sideload the copy-partitions-20210323_1922.zip package by doing the following:

    Download the copy-partitions-20210323_1922.zip file from here.
    Sideload the copy-partitions-20210323_1922.zip package:
        On the device, select “Apply Update”, then “Apply from ADB” to begin sideload.
        On the host machine, sideload the package using: adb sideload copy-partitions-20210323_1922.zip
    Note: The copy-partitions script was created by LineageOS developer erfanoabdi and filipepferraz, but isn’t signed with LineageOS’s official key, and therefore when it is sideloaded, Lineage Recovery will present a screen that says Signature verification failed, this is expected, please click Continue.
    Now reboot to recovery by tapping “Advanced”, then “Reboot to recovery”


Good work folks !

I tried that, didn’t work. It is flashable from the OEM recovery and the script will execute just fine, but the other slot won’t be bootable.
Probably something to do with hashes still wrong for Verified Boot, but I really don’t know anything about how that works exactly.

As this is turning waaay OT here, could someone with privileges move the last 10 posts or so over to the FP4 Root Access is possible, maybe a bit risky topic maybe :thinking: :pray:


Unfortunately update again didn’t work. But, naaaa, I won‘t try it again today. I wanna enjoy my working phone for a while. Maybe I just wait for twrp and e-rom.

Once again, thanks folks!

Didn’t you get a update notification or did it fail during the update process and if so at what point?
Have you rerooted your phone before updating?
There has to be a way to get this working, what are we missing here :thinking:

1 Like

No, not yet rooted.
build no. still the same A.081…
all google apps activated
download: ok
installation Error

Huh, interesting… is that the same error you had before?
Maybe there’s still some modification to system files left somehow. I wouldn’t now how, but who knows :thinking:
OK, here’s a crazy idea:

  • Install the Magisk app
  • Boot (not flash) your prerooted boot.img
  • Perform a Magisk uninstall in the Magisk app

That shouldn’t work, a factory reset should have purged all the remnants of Magisk off of /data, but hey, worth a shot.

Apart from that, could Titanium Backup have messed this up somehow, I don’t really know how it works these days, haven’t used it in almost a decade…

Third option, your other boot slot could be tainted, maybe because you flashed a wrong boot.img to it at some point. The updater usually flashes to the unused slot, maybe then, the failure gets triggered.
So try flashing that boot_a.img you used to get your phone working again to the other slot.

1 Like

Have moved several posts here as proposed.


I tried it with the latest boot.img avaliable here ('cause I have the A.094 ROM version on my phone)



And that works perfectly, that’s my daily driving phone, and no problems :wink:


I tried to root my FP4 on /e/os using Magisk.
It worked using the default stock rom on FP4, so rooting the device works.
However, using /e/os Magisk just crashes when I try to modify the boot.img using the install button in Magisk.

This happens with v23 and the canary build. Does anyone have an idea how to fix it? Could it be any permission issue?


I just uploaded a Magisk patched version of the /e/ boot.img here.

Could you please try to flash that in fastboot

$ fastboot flash boot_a boot_magisk_e.img
$ fastboot flash boot_b boot_magisk_e.img

I hope you have your important stuff backed up from your phone, hic sunt dracones :smirk:


How did u manage to patch it?

Yes. That works. However, a direct install using the app still doesnt work, after the flash.
Another user reported that he didnt have any issues with it.
I guess you also didnt have any issues with it.
I mentioned you in the ticket.

You shouldn’t have to install it again after you flashed the boot.img.
I patched the image on a phone running vanilla FPOS, so your problems with Magisk might well be connected to /e/.
If you want to figure this out, it would be really helpful if you could post your Magisk installation log, see here:

Installation log from the Magisk app (press “Save log” after installing Magisk or a module). If you experience errors when installing Magisk or modules in the Magisk app.

If that doesn’t tell us anything useful, a logcat would be the next logical step.

the problem is that the entire Magisk app crashes, so there’s no logs anywhere to be found.

Could you try running logcat :pray: maybe that’s revealing something useful :thinking:

  • $ adb shell "logcat -c && logcat > /sdcard/logcat.txt"
  • Open Magisk, make it crash
  • Press Ctrl+C in the terminal you have adb running
  • $ adb pull /sdcard/logcat.txt
1 Like

this did the trick for me. thanks.
had the same problem as @noodlejetski .