FP4 Root Access is possible, maybe a bit risky

I am familiar with Linux and commandlines input but not an expert in it. I guess I wait some more. It should be possible soon to reflash everything when things go wrong. Many thanks for the information and giving root as an option.

1 Like

I can confirm root works with A94.
As for the update not showing up you might have the same issue I had, rooting and messing with gapps basically seemed to prevent the update to show up.
I wiped my phone (after breaking too many things by trying to get Google maps to work with microG) and the second my freshly wiped device grabbed an internet connection, the update showed up…

1 Like

Yeah, I suspected that might be the case. But I’m in no rush to update, so I’ll first mess up my install enough to actually warrant a factory reset :smirk:

I have written down this procedure in some more steps as it took some tail-and-error. Feel free to provide feedback: Fairphone 4 – Root -December 2021 – Stijn D'haese

Also, any spelling errors are free of charge. :sweat_smile:

8 Likes

Very clean tutorial :grinning_face_with_smiling_eyes:
Thank you for your work :stuck_out_tongue:

1 Like

thank you very much!
however unfortunately it didn´t work out for me.

previously on FP4:
I was rootet on magisk for 2 weeks with A.067 image and everything was nice with lawnchair etc.
I used Titanium Backup and it looked like it worked. Except MiXplorer - search didnt work
Deactivated majority of google apps - no MicroG

for the update:
first: I tried factory reset only. Update failed.
second: I returned to stock boot.img (my build no. is quite strange: A.081) according to your prescription.
no wifi, no sound any more.
first notice after reboot always: UI crashed (but it works fortunately)

third:
I tried to switch to slot b
after reboot its again in slot a

fourth/fifth… etc…
tried different boot images: A.091, A.094 that you posted
and from Hirnsushi´s post here
FP4 Root Access is possible, maybe a bit risky - #43 by hirnsushi)

now I am back on patched A067 Image from my first root.
still no sound and no wifi:(
And just noticed: no calls. Incoming and outgoing aaarg!

anyone has a clue?
I tried to enable WiFi with adb and the command??? lines from there:
https://code.fairphone.com/projects/fairphone-4-kernel.html

OK, let’s try to figure this out:

  • If you do a factory reset, do you have working wifi?
  • Did you flash the A.067 boot instead of booting from it? (don’t!)
  • Are you still on A.081?

Without any more information, I would suggest:

  • Do another factory reset
  • Got wifi? Stop there for now
  • If not and your build number matches with one on the kernel page flash that img.
  • Otherwise try one of the stock images I uploaded, A.081 could be boot_a :thinking:

Good luck :crossed_fingers:

Oh and changing the boot slot if you booted the other one successfully won’t work, probably Rollback-Protection

2 Likes

Thanks, Hirnsushi!
I just did again a factory reset.

Still no wifi, no sound, no phonecalls

Yes, according to rar0 instructions I flashed the image. After I renamed it to A.081…
I remember your root post of warning not to flash, but I thought, rar0‘s image was different and ok to flash.
I think I flashed all three images from FP homepage:(

Still build A.081

Have you tried flashing one of the images I uploaded?
Those are the boot_a and boot_b my device shipped with and at least one of them is a build between A.067 and A.091, so may well be your A.081.

Or you can tell me the security patch level of your A.081 build (Settings->About phone->Android version->Android security update) and I can tell you which one it should be.

yes, I did. I am trying again. I used 067 for root with Magisk

Please try boot_a from my upload, that’s patch level September.

A.067 shouldn’t be used for anything apart from temporarily booting and using that to install Magisk. That build is ancient, patch level July, I’m pretty sure no device shipped with that.
When I wrote my initial instructions, that was the only image Fairphone had made available.

Android Update 5.th September
Build Fp4.FP3I.A.081.20211026

That should match the boot_a I uploaded. What happens if you flash that?
If it doesn’t work, make sure it actually gets flashed to the right slot (the slot might be chosen based on suffix :thinking: ) either rename it to your current slot or in fastboot do:

$ fastboot getvar current-slot
$ fastboot flash boot_[your_slot] path/to/boot_a.img
4 Likes

I cant believe it! it worked! I did it the same way yesterday…
oh thank you so much!!!
sound works, wifi works, it believe the rest of it, too!

5 Likes

:tada:
Nicely done :metal: :smiley:
Now you just have to wait for the update again… :smirk:

4 Likes

Maybe you can sync your Slots…

I used it on a OPO6T, but the script is manufacturer independent

Pre-install instructions

In some cases slot b can be unpopulated or contain much older firmware than slot a, leading to various issues including a potential hard-brick. We can ensure none of that will happen by copying the contents of slot a to slot b. This step is NOT optional.

To do this, sideload the copy-partitions-20210323_1922.zip package by doing the following:

    Download the copy-partitions-20210323_1922.zip file from here.
    Sideload the copy-partitions-20210323_1922.zip package:
        On the device, select “Apply Update”, then “Apply from ADB” to begin sideload.
        On the host machine, sideload the package using: adb sideload copy-partitions-20210323_1922.zip
    info_outline
    Note: The copy-partitions script was created by LineageOS developer erfanoabdi and filipepferraz, but isn’t signed with LineageOS’s official key, and therefore when it is sideloaded, Lineage Recovery will present a screen that says Signature verification failed, this is expected, please click Continue.
    Now reboot to recovery by tapping “Advanced”, then “Reboot to recovery”

https://wiki.lineageos.org/devices/fajita/install#pre-install-instructions

Good work folks !
:sunglasses:

I tried that, didn’t work. It is flashable from the OEM recovery and the script will execute just fine, but the other slot won’t be bootable.
Probably something to do with hashes still wrong for Verified Boot, but I really don’t know anything about how that works exactly.

As this is turning waaay OT here, could someone with privileges move the last 10 posts or so over to the FP4 Root Access is possible, maybe a bit risky topic maybe :thinking: :pray:

2 Likes

Unfortunately update again didn’t work. But, naaaa, I won‘t try it again today. I wanna enjoy my working phone for a while. Maybe I just wait for twrp and e-rom.

Once again, thanks folks!

Didn’t you get a update notification or did it fail during the update process and if so at what point?
Have you rerooted your phone before updating?
There has to be a way to get this working, what are we missing here :thinking:

1 Like