FP4 reluctant to use WiFi on Android 12


So I just got the Android 12 update yesterday. Ever since, my FP4 has been reluctant to use my home WiFi, and will often prefer using the available mobile network (4G/5G).

My home WiFi does have pretty bad coverage in some areas of the house, but when I was on Android 11 the phone would usually stay connected - or at least reconnect pretty quickly if the connected was lost. On Android 12, it seems much more likely to switch over to mobile data. When I open the internet menu (why did the separate WiFi and Mobile Data quick buttons disappear? ugh) it says it is connected to WiFi, but the connected is unable to provide internet. And apparently, all internet traffic is automatically routed via mobile data instead.

I have a smart home setup partially controlled from my phone which requires it to be connected to the local WiFi to work, so this is a very annoying issue. And besides, I only have limited mobile data available, so prefer to use WiFi when at all available.

Any tips or similar experiences?


  • With the router maybe you can set different SSIDs for the 2.4Ghz and 5GHz bands
  • On the phone you will then have two options to connect to.

Although 5GHz can pass more data, unless you want to watch multiple videos on the same SSID then 2.4 should be fine.

On the phone disable automatic connect for both and then manually connect to the one that works best, after some trial and error.

And when at home use in Flight/Aeroplane mode, which will disable the network.

This how I run my FP3 out in countryside where I do have fibre network but no signal.

Once you have it working you can enable auto-connect on the specific SSID you are using, but I don’t, which means I have to manually reconnect if I go out of range of my 5GHz and of course disable Flight mode when I go to town.

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.