FP4 - gcam-port

Yes, what specifc setting is it? Then I could play with it myself.

Hello. I have a problem with basically any gcam mod when I want to access the front camera in the video mode. Wichaya’s mod doesn’t seem to be able to access the front camera at all. It just gets stuck or crashes. (I’ve tried both v1.4 and v1.5.) Nikita’s mod sometimes works, but it randomly crashes. It feels to me like the camera2 implementation is a bit wonky when it comes to the front camera. I cannot access it in any other app like IP Webcam. Does anybody experience the same behavior?

Edit: Clarified this is about the video mode.

I can switch to the front cam using Wichaya’s mod just fine by tapping the button in the bottom left corner.

1 Like

Even in the video mode? Sorry, I should have been more specific. The camera (photo) mode works fine.

1 Like

just tried recording a short video with the selfie cam and it worked fine.

1 Like

For me it only works with 1.4x zoom. 1x zoom stays black or freezes.

3 Likes

Yeah, you’re right, 1.4x zoom works. Pretty damn weird. I’ve contacted support, I have problems with the front cam using the Camera2 API in other apps too. For example IP Webcam (https://play.google.com/store/apps/details?id=com.pas.webcam) cannot access it at all. But when using the old camera API, it works just fine.

2 Likes

that’s weird, I’m not having any issues with 1x.

It is definitely weird. Can I ask what version of FP4 do you have and when was it delivered? It is possible that there are slight hardware differences between batches and the software doesn’t account for them.

Btw, I tried it with IP Webcam, which allows manual zoom setting, and it works with basically any zoom, even 1.07x. Just not 1.0x.

it’s the fancy green speckled one, arrived in the first week of December 2021.

Mine is grey (8GB) and was delivered on 21st of December. So there could be differences. I’m really curious what could cause this.

Camera app freeze, when i go from camera → video → slowmotion.
Is that only for me that way?

Wichaya V1.5

Steven

It is the same for me.

I have a different question: Is it possible to use top shot without using Google Photos? I couldn’t find the folder where the individual frames are stored.

Same for me. Also the full 48MP picture quality and the ultra-wide lense are inaccessible. This is a problem of the Camera2 API implementation. The reply from support is that this is not intentional and it will be addressed in the future. I didn’t discuss this particular problem (slow motion) with support though, so feel free to open a new ticket.

8 Likes

Where can I create a ticket? Can’t find a link to the issue tracker and so on. The question would be, since there is no official port for the FP, is it even possible?

You can create a ticket here: https://support.fairphone.com/hc/en-us/requests/new

The thing is it’s not really a problem of GCam itself. It’s a problem of accessing certain camera features by 3rd party apps. In other words, the slowmotion would fail in any app (except the stock camera app), simply because the API doesn’t allow you to use it.

6 Likes

Just for general clarification: for FP3 and FP4 there is no public bug tracker as for the FP2, so a user must always #contactsupport who would then handle it internally, still you get a support ticket number for your request.

2 Likes

Simple but efficient Camera app based on Android’s modern CameraX library
GrapheneOS camera.
Works well on FP4 (in my case with iodeOS)

Pictures have the same quality then with Wichaya Gcam.

+ Works with ThirdParty Gallery (instead of any Gcam port)
+ Possibility to change the storage path
- No wide angle lens support

Maybe you will give it a try. I like it very much because of the simplicity.

5 Likes

Hi Hulk,

Interesting, I’ve been looking for a decent alternative to GCam (mostly for the third party gallery thing).

I’m not exactly convinced by the shots I took. Pictures seem to lack sharpness and there’s something a bit off with exposure, maybe the lack of HDR feature ?

GCam

GrapheneOS Cam


GCam

GrapheneOS Cam

2 Likes

Gcam


GrapheneOS


2 Likes