FP4 fingerprint sensor makes multiple attempts without lifting finger

Have you tried to re-enroll your fingers? Because this issue is not occurring on my phone. When my fingers are wet or the scanner is dirty I get the message that the scanner is dirty. It doesn’t try many attempts at all. When I enroll my fingers I scan multiple parts of my finger. Not the same finger position every time. Maybe that will improve it?

I’m using the official phone case as well. Which may also make a difference, since the slit for the scanner is rissen. That may force different behavior when scanning fingers.

I scanned the whole thing rather obsessively. Maybe if I was less obsessive? I’ll give it a re-enroll and see.

Maybe not using a case is part of it (I eschew cases so the thing fits in my belt phone holder).


Did it help? If so, please let us know :slight_smile:

It seems to have stopped happening. I have no idea why, but then I have no idea why it was happening in the first place.

I have adjusted things from “fingerprint turns on and unlocks” to “fingerprint unlocks, but only if already on”: this is no harder with the fingerprint sensor where it is, and makes it easier to do a firm press (it’s easy to accidentally brush it when it’s in a belt holder). Maybe that was enough to fix things?


Hey everyone, I would like to pitch in my two cents here. I got a brand new FP4 three days ago and faced the problem with the fingerprint sensor right from the start, even before I installed any apps. I even opened a support ticket two days ago., but haven’t had any response till now.

Anyway, it occurred to me yesterday that the problem might also be partially due to the (official) Fairphone protective case that I am using (but only partially though) as it creates a fairly deep recess around the fingerprint sensor. So I decided to re-enroll the fingerprints, this time with the case on the phone. Doing this has greatly improved the problem. Now, I can unlock the phone roughly 8 times out of 10 (don’t quote me on these numbers).

I can still sense multiple haptic feedbacks from the sensor even when it manages to unlock the phone, which I guess is not how a fingerprint unlock should work ideally. And on the failed attempts, I get the “Too many attempts, try again later” message.

For the record, I have tried all the steps mentioned by @mosley above [1], barring the factory reset.

TL; DR: I have the same problem but probably largely due to the official FP4 protective case since re-enrolling fingerprints with the case on alleviates the problem but does not remove it entirely

[1] FP4 fingerprint sensor makes multiple attempts without lifting finger - #11 by mosley


Hej Community!

I just installed my first Android phone (new FP4 with max specs) during the last week. Had been using iPhone since a decade.

I encounters the same issue from the start.
Sensor inactive, too many attempts.

So I assume that while I try to get my new phone into correct position of my right hand (have only reg my right thumb) it starts to scan before I reached the position where I can actually reach the sensor with my thumb.
I use even my left hand to hold it, as I sometimes read push notifications.

So in my eyes this is a handling/software issue and most certainly not hardware, as it works well the other times.
Now I know at least that I need to try to avoid coming across the sensor, prior to opening, which decreases the intuitiveness of use.

Will now change settings to the above mentioned, unlock only on active press.


P.S.: I have now disabled the “Fingerprint Unlock Behavior”.


@Tannfee thanks for the suggestion. I diabled the “Fingerprint unlock behaviour” as well now and the problem has gotten better somewhat. I get less failed attempts.
I really hope that they fix this in a future software update.

1 Like

After 5 days I can resonate it works well for me.
I have had the error “too many attempts” only once since.

I saw in the statistics that I unlock my phone around 50 times per day. So hardly a hardware issue.


I suddenly have problems with fingerprint access on my FP4. Half the time I have to use my password. Is there a fix? Otherwise, it has worked perfectly.

Have you tried rescanning your fingers?


Hi all,

I’ve received my Fairphone 4 yesterday and have encountered a similar problem. While I don’t seem to have issues with recognising my finger/thumbprint when I’m doing it as intended, the sensor can go crazy and try and process several unlock attempts in a fraction of a second.

This means that, if I mistakenly brush the scanner with a non-fingerprint part of my finger when I pick it up, the sensor is sometimes already ‘timed out’ from too many wrong attempts.

It’s behaved this way out of the box - surely there could be some software fix which just limits attempts within rapid succession. I’m not sure what the sensible limit would be but 5 registered attempts in half a second or so is quite a lot!

EDIT: just to clarify, the above is in reference to the phone when “Fingerprint Unlock Behaviour” is switched on, meaning you don’t press the power button first to unlock the phone. The solution is pretty much just to turn that function off at the moment, so that you have to press the power button first, meaning your finger is likely to be in the right place for the scanner. But this is just an extra step to solve a problem I haven’t had on other phones.

1 Like

I thought this is laready fixed since the second or third update of FPOS for FP4?!

And it is already implemented yet in LOS.

To enable fingerprint only when display is on. And problem with multiple attemps is gone

In LOS/iode 3.0
can be found in settings/security → settings of screen lock (gear icon) → Screen off fingerprint

Cannot remember anymore where it is in FPOS settings…

Here: Found the Thread.

The approach in FPOS and LOS is exactly the opposite, but with the same result and technical implementation

1 Like

I am on the latest update and yes - it has been fixed. I just tried it and the phone makes just a single attempt when I place a finger or a finger part. And makes a second attempt only after I lift my finger and place it back on the sensor. Nice!
Really glad to see that the community voice has been heard :slight_smile:


@xenotaph - I have the same issue also. Not all the time, but sometimes a light touch will trigger a burst of ‘attempts’ which will then cause the phone to say ‘too many attempts’ and require the password to unlock.

Latest OS update applied, etc. Still does it.

Did you check the status of the finger unlock behavior linked two posts above?

Just as I was super excited this got fixed and today the old behavior (with the multiple unlock attempts) is back. I will test a bit more in the coming days and post again here in the thread.
Sorry for getting people’s hopes up prematurely.


Did the new update that was released yesterday improve anything for you? I find it odd that people still have this issue. It works perfectly fine for me. Have you tried to re-enroll your fingers? Maybe you didn’t scan them properly and thus it doesn’t work reliable? Just a guess.

1 Like

Perhaps you could try to put a clear tape over the fingerprint snesor and registering the finger multiple times,

If I put the correct part of my registered finger the scanner works really well. It’s recognized almost all of the time.
The issue is not unreliability in recognizing the registered fingers. The issue is that if you touch the sensor with anything else (a non-registered finger, the wrong part of your registered finger, or perhaps a non-finger, like your palm) it makes very fast consecutive readings, which locks the scanner before you have the chance to realise what happens.

Scenario 1: I pick up my phone with my left arm, click the lock button with any non-registered finger to wake the screen, only to check the time. At this point the scanner will start to scan this finger and it will do 5 readings very fast and lock the fingerprint although I didn’t have the intention to unlock my phone. But if I decide to unlock it now, I have to wait for the timeout.

Scenario 2: I pick the phone try to unlock it using my registered finger. By my mistake I put the wrong part of the finger, the scanner makes several readings, so quickly, that I cannot react to correct the finger position and I end up with a locked fingerprint and I need to wait for the timeout.


To fix this issue the scanner need to make only 1 reading while my finger is pressed down. It needs to wait for me to lift my finger and put it back down, before it makes a second reding. OR it needs to have some timout period before it makes a second reading.
So far both of these are not present in the last updates.