FP4 and (unofficial) LineageOS

This is fixed in iode

I recently built lineageos 18.1 for FP4 and installed it on my device. I tested it several weeks and can say that it works just fine. I would like to participate your team to make official lineageos builds for FP4 available!



Any plans to share your build? I am always interested in new roms for to try.

I recently built lineageos 18.1 for FP4 and installed it on my device. I tested it several weeks and can say that it works just fine. I would like to participate your team to make official lineageos builds for FP4 available! @samwein @dk1978

1 Like

I like to hear that there is already interest! ^^ I will push a fresh unofficial build to my cloud or github account today, if everything works fine and then post the link to it on this chanel.

1 Like

So there is hope that there will be an official LineageOS for the FP4. Great :smiley:!

1 Like

Keep in mind there is a lineage 19 build being developed as the current official builds for lineageos are now version 19.


Are there any official LOS 19 build for FP4 ?
The official download platform doesn’t show it anyway

No, not yet. If you scroll up mmustermann has been releasing unofficial monthly builds. FP4 and LineageOS - #282 by mmustermann

Development is being made on fairphone’s repo: GitHub - WeAreFairphone/android_device_fairphone_FP4

1 Like

Hehe I know I know, I’m using mmustermann’s build actually, and can’t wait for his July monthly build :smiley:
I was just making sure I didn’t miss something like there’d be an official build somewhere that I would not have known of.

It seems you are right ^^


Here is my fresh Lineageos 18.1 build for Fairphone 4: Dropbox - lineage-18.1-20220710-UNOFFICIAL-FP4-userdebug - Simplify your life
Warning: This is an unsigned userdebug build only for test purposes. Don’t use it in everyday life to prevent loss of sensitive/important data. I am not responsible for any issues. There is no guarantee for anything! Use it at own risk!

You can sideload it in recovery mode via “adb sideload lineage-[…].zip”
I recommend the usage of USB 2.0 [just connect your FP4 to an USB 2.0 port or extension cable], because I experienced some problems with USB 3.0)

Happy testing :wink:

1 Like

@mmustermann Do you have any plans to release official lineageos builds for FP4? I would like to participate your team!


By the way, I’m having a media volume issue with LOS 19 on some apps.
For example using Plex, volume seems stuck to max no matter what position the media volume slider is set to. It occurs with headset and speaker.
On the other hand, no issue with Youtube…

Anyone experiencing this would have a fix ?

@typh00n Sry for the late answer. I’ve been busy and somehow missed the notifications.
I don’t think there is a team right now for FP4 lineageos development. @dk1978 and @TeamB58 seem to be focused on FP3 development only and @samwein doesn’t seem to be active anymore. The only one who commits from time to time to the github repo is mikeNG but he doesn’t seem to be a member of this forum. I believe he works at CalyxOS and drops us sometimes a few patches: Meet the Team.
All I’ve been doing so far was compiling my own builds and publishing them. I haven’t contributed any patches yet, nor do I have much experience in android development . So any help is very welcome. Fell free to PM me if you want to discuss some details of what we can do.

For anyone else interested this is how I currently compile my builds:

Build Details

My .repo/local_manifests/roomservice.xml currently looks like this

<?xml version="1.0" encoding="UTF-8"?>
  <!-- Grab device and kernel trees from WeAreFairphone -->
  <project name="WeAreFairphone/android_device_fairphone_FP4" path="device/fairphone/FP4" revision="staging/lineage-19.1" remote="github" />
  <project name="WeAreFairphone/android_kernel_fairphone_sm7225" path="kernel/fairphone/sm7225" revision="staging/lineage-19.1" remote="github" />
  <!-- unsure if/why we need this one -->
  <project name="LineageOS/android_external_bson" path="external/bson" remote="github" />
  <!-- grab the modified blobs from Fairblobs, note that extracting blobs from an Android 11 image doesnt work -->
  <project name="xblax/android_vendor_fairphone_FP4" path="vendor/fairphone/FP4" revision="lineage-18.1" remote="github" />
  <!-- mods for the display need to be grabbed -->
  <remove-project name="LineageOS/android_hardware_qcom_display"/>
  <project name="LineageOS/android_hardware_qcom_display" path="hardware/qcom-caf/sm8250/display" remote="github" revision="lineage-19.1-caf-sm8250"/>

and these are my build steps:

#!/usr/bin/env bash
set -e

source build/envsetup.sh
repo sync -j 16 --force-sync
breakfast lineage_FP4-userdebug
mka target-files-package otatools

sign_target_files_apks -o -d ~/.android-certs \
    $OUT/obj/PACKAGING/target_files_intermediates/*-target_files-*.zip \

ota_from_target_files -k ~/.android-certs/releasekey \
    --block --backup=true \
    signed-target_files.zip \

New build for July is up:


Downloads for : Fairphone Fairphone 4 | AndroidFileHost.com | Download GApps, Roms, Kernels, Themes, Firmware and more. Free file hosting for all Android developers.

sha256sum lineage-19.1-20220712-UNOFFICIAL-FP4.zip recovery-19.1-20220712-UNOFFICIAL-FP4.img 
d42c7825ef03ac4d3ed1ee08e2e0a03cf5debdbfd2eb836b5ed3972f1c62af6e  lineage-19.1-20220712-UNOFFICIAL-FP4.zip
957f075768b4ec9624cbe1a664ae2f8718c2069ce37001f529e324af338e9614  recovery-19.1-20220712-UNOFFICIAL-FP4.img

Doesn’t seem to work, just causes boot loops. Tried re-flashing a few times, made sure the latest recovery was installed. Also it doesn’t seem like the latest official fp4 update is on their website yet as I’m guessing it’s firmware issues.

Hey all,

Thanks @mmustermann for tagging me.
That’s right, I am currently actively involved in stabilizing FP3 with respect to the sources and I would be spending at least another 3-4 weeks before I switch my focus to FP4.

That said, I shall check with the team as to what the status of FP4 LineageOS is and will be able to update you all on that.



Hmmm. I could actually flash it without troubles and its up-and-running.

The upgrade worked for me too, otherwise I wouldn’t have published it. Please check that your download didn’t get corrupted by verifying the sha256 hashes.