FP4 and (unofficial) LineageOS

If you wouldn’t see any notification dots at all, I’d recommend to check “Settings > Apps and notifications > Special app access > Notification access > Trebuchet: Allowed”. I noticed some update/backup restore situations which somehow disabled this access for the standard LOS launcher …

1 Like

Hi @Error ! Was wondering if you updated your build recently ?
Is it safe to assume that syncing repo before building will get you the latest LOS updates/bugfixes/features ?
Or is it pointless as most updates involve device specific code (which would mean that most of the relevant stuff happens on wearefairphone repo) ?

@LeSteff in case you’d be struggling with LOS, it seems the official Fairphone OS ROM has been released

1 Like

Yeah - because in lack of powerful hardware I gave up to create my own LOS with MindTheGapps and restored the official Fairphone OS Rom… after installation, I stuck now in Fastboot mode… and nothings seems to be working anymore… every action takes me back to the booloader… :frowning:

Ok, this solution seems to be working for me… Fairphone 4 “locked in fastboot mode” - Help / Fairphone 4 - Fairphone Community Forum

finally got it working, and GCam doesn’t complain anymore! thanks @Aaanze + @Error for the tips :grin:

for anyone interested, I’ve finally created an androidfilehost dev account and uploaded my build with microg preinstalled here: lineage-18.1-20220206-UNOFFICIAL-FP4.zip | by g4b for Fairphone 4 (md5 8d810026d4a470eaefc56e544f014dc3)


Nice, thank you, this is to my mind the most interesting setup (LOS+microG).

I tried to install your build using TWRP from here
Link: TWRP for Fairphone 4

However when I try to flash it from TWRP, but ran into ERROR 1.

  • check md5 of build
  • Boot into TWRP (note: as it is experimental, I only booting into TWRP from with “fastboot boot” command from bootloader, not having TWRP as recovery installed)
  • Wipe/Factory reset
  • could not mount /data so formated it (solved the error)
  • try to install LOS-build
    Output see below:
Installing zip file 'path/to/file/lineage-18.1-20220206-UNOFFICIAL-FP4.zip'
Flashing A/B zip to inactive slot: A
Updater process ended with ERROR: 1
To flash additional zips, please reboot recovery to swith updater slot.
Error installing zip file 'path/to/file/lineage-18.1-20220206-UNOFFICIAL-FP4.zip'
Updating partition details...

→ is the thing large enough to open a new Topic?

Unfortunately I could not figure out what ERROR 1 tries to tell me.
Anybody with same experience? Do you have an idea?

Note: Tried adb sideload first but had no luck (same ERROR 1) → tried TWRP flash/install
Note: it is my third phone flashing LOS, so I hope not to be too fresh; Cannot compile my own build do to lack of HW.


I actually never tested this with TWRP, and I’m afraid it’s not supposed to work with it…

you should use lineageos recovery instead, as explained in this post


Yeah, I just saw that. Apparently I have to wait a few days for apps to start sending notifications. At this point every app I had problems with are working as they should but an app I installed later still isn’t sending notifications. But at this point I’d rather just wait for official LOS releases instead of going back to the stock OS and having to reinstall everything again

1 Like

Thank you @g4b. It worked :slight_smile: ! Amazing!
Two notes from my side:

  1. First sideload did not work (but did not throw an error) due to outdated adb. Link to current version.
  2. In the end, to reboot into bootloader and erase metadata, I had to enable adb in recovery again to reboot comfortably into bootloader again.

Overall thank you for the amazing work and great support, especially @g4b and @Aaanze.


I just got my FP4 today. First of all thank you @g4b and the other ones involved!
I’ve been reading through all the posts here, but I seem to have missed the reason why these
are just shared here and there: Downloads for : Fairphone Fairphone 4 | AndroidFileHost.com | Download GApps, Roms, Kernels, Themes, Firmware and more. Free file hosting for all Android developers., but not on the LoS website? https://download.lineageos.org
Is it just because these are still experimental, or are there any blockers before adding FP4 there?

unfortunately (but this is for the better!) official support for a device in lineageos requires a stricter process (see also here) and more manpower than what anyone here can afford at this moment.

hopefully someone with enough resources/time/motivation will pick this up soon. in the meantime we need to live with unofficial builds.


No, there’s no official release yet

Thanks for the explanation. Indeed, those requirements seem to be quite demanding (though understandable). I recently moved my fp4 to LOS and it works pretty well :slight_smile:
The phone quality seems to be sometimes quite bad, but I will investigate that further (also didn’t tested it with the stock os first).
Another thing I noticed is that there keep updates showing up which should be available. Once I click on them nothing happens and also in the settings I can’t find any updates.
I guess I would need to update them via usb / adb either way?

Just noticed that the “call” word got lost, the phone quality itself seem to be quite nice.
Talking with multiple persons seem to verify that for my case, unfortunately.
I have a slight feeling that activating the loud-speakers often worsens the situation,
but not sure about that yet.
Using my old phone, LG G6 with the same sim at the same location worked with less issues.
Too bad that I didn’t tried that before flashing, maybe I’ll compare it to the Stock OS when I have some free time.

1 Like

So… should my phone be telling me that I will be forced to install the latest Fairphone OS update in 19 days? Because that sounds like a pretty bad idea


I have my FP4 already. I have read the thread and try to summarize:

I am not yet using the phone as

  • I definitive want LOS on it
  • I don’t use Google apps or Playstore (only Fdroid)

I am wondering the following on what I need to do:

  • Should I wait for a official LOS release? Because this would overwrite my data or can I just update when it will be released?
  • If updating works, should I now just build myself from [1, 2, 3, 4, 5] repository and install with recovery manager?
  • Shall I use TWRP or Magisk? (ref. TWRP: [6])
    – I answered this myself (I need both I think): [9]
  • I read here about rooting and locked bootloader. Now I’m scared I will do something stupid - can you clarify here? Is this the explanation? [7]
  • Do I need to root? I wanna use AFWall+ firewall and AdAway apps
  • I did not understood what it is with this “proprietary files”: [8]

@Aaanze, @dk1978

[1] GitHub - WeAreFairphone/android_kernel_fairphone_sm7225 at staging/11/fp4
[2] Get proprietary vendor files for FP4 - #26 by Error
[3] Building LineageOS for FP4 - #5 by Error
[4] Building LineageOS for FP4 - #47 by hirnsushi
[5] Post from Aaanze: FP4 and LineageOS - #81 by Aaanze
[6] TWRP for Fairphone 4
[7] FP4 and LineageOS - #127 by Aaanze
[8] github.com/SyberHexen/android_device_motorola_kiev/blob/lineage-18.1/proprietary-files.txt#L398
[9] https://www.quora.com/Whats-the-difference-between-TWRP-and-Magisk

That’s a lot of questions :smiley:

There is no way to tell as of now since official development doesn’t seem to be moving at all as we speak.
However, it appears that for the FP3 the unofficial builds were compatible with official release without a wipe. We can assume it may follow the same path for the FP4 but we can’t be sure.

You can either download a build from the main thread or build it yourself from source by following the instructions.

  • You do not need Magisk. Magisk provides root, root is not mandatory for installing nor using LOS.
  • You should not (and probably would have trouble ?) install LOS with TWRP. Lineage OS provides its own recovery that has been proven more reliable for installing LOS than TWRP.

I’m no expert on the matter, but all I know is the risk of bricking your device when relocking your bootloader while running a rooted custom ROM is higher, as if everything goes wrong, it becomes much more complicated to restore your device to it’s original state. By nature, unnoficial custom ROMs cannot be presumed as stable. I know however that someone locked his bootloader successfully after installing LOS on his FP4.
I would advise to let the bootloader unlocked for good measure. Again rooting is only necessary if you’re counting on installing apps that make use of root permissions, otherwise you’ll be fine without it.

Adaway indeed requires root. Not sure about AFWall+.

Proprietary blobs are the devices drivers that are not open source and therefore cannot be compiled in the process of building the ROM, therefore we have to extract them as binary files from an existing ROM to be able to “integrate” them with your own build.


Unlocking bootloader will wipe your data (factory reset), but then you’ll be able to install any custom OS :smiley: .
Re-locking bootloader, as already mentioned, could brick your device in a non-booting state, the only solution then is to send it to Fairphone that will reset is for approx 30€ + shipping.

Keep in mind that you can one-time-only root your device with fastboot boot boot-patched.img (and not fastboot flash), it is useful if you don’t need permanent root but just time to time :slight_smile:

1 Like

oli, where can i find this statement?
That you can get it reset for 30,-€ if you send it in?
There was once something in the forum, I remember, but can no longer find it.


Found it.

1 Like