FP4 and LineageOS

Hmmm.
Unfortunately mindthegapps as any other gapps suite cannot be flashed after first boot.
Best bet would be to rebuild a new image with it :-/

OK… Is that sth. that I can do easily by my self?

Well it depends. “easily” is a very subjective word, if you know the basics linux commands, have a decent computer and are ready to spend several hours on it, it is definitely possible.

  1. You’ll need to follow the steps as described by @Error :
    Building LineageOS for FP4 - #5 by Error

  2. As for including mindthegapps I wouldn’t know exactly but chances are that the steps are similar to the one I followed for :
    https://github.com/opengapps/aosp_build

Good luck and do not hesitate to share your achievements :slight_smile:

2 Likes

Thanks a lot for information sharing. I’ve followed your links and got a lot of helpful guidelines. But in fact, I do not have Linux experiences and environment. The last one can be easliy fixed with a vm, I know. But this will not heal the gap of missing linux skills. However, I would say it is also for me doable… I’m still unsure about the possible negative consequences to my phone…
Maybe I would better wait for a complete factory image by fairphone itself (like this one for FP3: FP3(+). Install Fairphone OS offline – Support)

Does anyone else have problems with some apps not sending notifications? I’ve disabled battery optimisation and checked that they have notification access but that didn’t fix anything. Even more confusing is that today, for the first time since I installed LOS, my mail app did send me a notification. I can’t figure out why and why it’s not working consistently. It seems like it doesn’t even update anything until I open it (it only checks for mails after I open it)

I didn’t have that problem with the stock OS and to be honest I’ve never had it on any phone.

No, I cannot say that I have those issues. But to be honest, I’ve turned off a lot of annoying notifications :wink:

Nope, no issue so far, but like the previous answer, I tend to limit the notifications to the bare minimum : WhatsApp, messages and phone only.

That’s what makes it even more annoying tbh. I barely even want notifications but only half of the ones I really need work. Whatsapp, Signal, my calendar, and my tv show tracker app work but both of my mail apps, my song release tracker, and twitch don’t. I already almost missed two new albums and an important email and twitch has a habit of not sending email notifications for every stream

Isn’t it the fault of missing Google Services @LeSteff ?

1 Like

No, the last OS flash fixed that. One email app and twitch randomly started sending notifications this morning, though. Guess I’ll just keep observing and hope that it doesn’t break again

1 Like

If you wouldn’t see any notification dots at all, I’d recommend to check “Settings > Apps and notifications > Special app access > Notification access > Trebuchet: Allowed”. I noticed some update/backup restore situations which somehow disabled this access for the standard LOS launcher …

1 Like

Hi @Error ! Was wondering if you updated your build recently ?
Is it safe to assume that syncing repo before building will get you the latest LOS updates/bugfixes/features ?
Or is it pointless as most updates involve device specific code (which would mean that most of the relevant stuff happens on wearefairphone repo) ?

@LeSteff in case you’d be struggling with LOS, it seems the official Fairphone OS ROM has been released

1 Like

Yeah - because in lack of powerful hardware I gave up to create my own LOS with MindTheGapps and restored the official Fairphone OS Rom… after installation, I stuck now in Fastboot mode… and nothings seems to be working anymore… every action takes me back to the booloader… :frowning:

Ok, this solution seems to be working for me… Fairphone 4 “locked in fastboot mode” - Help / Fairphone 4 - Fairphone Community Forum

finally got it working, and GCam doesn’t complain anymore! thanks @Aaanze + @Error for the tips :grin:

for anyone interested, I’ve finally created an androidfilehost dev account and uploaded my build with microg preinstalled here: lineage-18.1-20220206-UNOFFICIAL-FP4.zip | by g4b for Fairphone 4 (md5 8d810026d4a470eaefc56e544f014dc3)

6 Likes

Nice, thank you, this is to my mind the most interesting setup (LOS+microG).

I tried to install your build using TWRP from here
Link: TWRP for Fairphone 4

However when I try to flash it from TWRP, but ran into ERROR 1.
Procedure:

  • check md5 of build
  • Boot into TWRP (note: as it is experimental, I only booting into TWRP from with “fastboot boot” command from bootloader, not having TWRP as recovery installed)
  • Wipe/Factory reset
  • could not mount /data so formated it (solved the error)
  • try to install LOS-build
    Output see below:
Installing zip file 'path/to/file/lineage-18.1-20220206-UNOFFICIAL-FP4.zip'
Flashing A/B zip to inactive slot: A
Updater process ended with ERROR: 1
To flash additional zips, please reboot recovery to swith updater slot.
Error installing zip file 'path/to/file/lineage-18.1-20220206-UNOFFICIAL-FP4.zip'
Updating partition details...
...done

→ is the thing large enough to open a new Topic?

Unfortunately I could not figure out what ERROR 1 tries to tell me.
Anybody with same experience? Do you have an idea?

Note: Tried adb sideload first but had no luck (same ERROR 1) → tried TWRP flash/install
Note: it is my third phone flashing LOS, so I hope not to be too fresh; Cannot compile my own build do to lack of HW.

Best
Pete

I actually never tested this with TWRP, and I’m afraid it’s not supposed to work with it…

you should use lineageos recovery instead, as explained in this post

2 Likes

Yeah, I just saw that. Apparently I have to wait a few days for apps to start sending notifications. At this point every app I had problems with are working as they should but an app I installed later still isn’t sending notifications. But at this point I’d rather just wait for official LOS releases instead of going back to the stock OS and having to reinstall everything again

1 Like

Thank you @g4b. It worked :slight_smile: ! Amazing!
Two notes from my side:

  1. First sideload did not work (but did not throw an error) due to outdated adb. Link to current version.
  2. In the end, to reboot into bootloader and erase metadata, I had to enable adb in recovery again to reboot comfortably into bootloader again.

Overall thank you for the amazing work and great support, especially @g4b and @Aaanze.
Best
Pete

2 Likes