FP4 and LineageOS

Yeah… I don’t really have any other options in mind appart from a new clean flash…

Either way thanks for your help. At this point I’m actually considering sending the phone back to have them reinstall the original os… I also don’t get why that hasn’t been released yet

1 Like

I’m sorry I wasn’t of more help. But I really think you should reflash just to be sure. I mean I can’t explain it but bad install happen…

I already did but it didn’t change anything :confused:

If I find the time before I go to vacation I’ll try to make another build with a bigger gapps suite… this one came with the strict minimum… who knows ?

Thank you so much!
I spent my evening yesterday flashing your ROM and moving my apps over. So far everything went flawlessly, except for the small problem that I couldn’t find a way to get out of the camera app with no pictures in my gallery. For some reason, when using the camera app, the interface buttons on the bottom aren’t there. Took a quick, random picture, then tapped it on the bottom left to switch into the gallery, and was able to get back to the home screen from there. Still kinda odd (but I’m not ruling out that I just missed the obvious way how to quit the camera app) .
Aside from that little hickup, everything was smooth sailing so far.
Again, thank you a lot. Now I can finally use my new FP4.

Edit: One more question: In the excitement of LOS running on my phone, I forgot to root it before I locked the bootloader again. Does your root instruction with magisk work with a locked bootloader, or will I simply have to suck it up and set up all my apps again after unlocking/locking the bootloader to root?

2 Likes

Glad to hear it works well for you ! It does for me too.
As for the camera I immediately removed it and replaced with Wichaya’s Gcam mod. Also I’m using gestures :slight_smile:

Regarding root it won’t be possible with a locked bootloader indeed… so yeah, if you want it you will have to unlock it again and therefore lose your data.
I’m surprised you dared to lock the bootloader on an unofficial LOS ROM, I wouldn’t have tried this myself as the risk of bricking sounds high ! Good news that it worked for you though !

1 Like

@LeSteff I’m currently building a ROM with stock Gapps suite (aka the one you receive on most stock roms). As I’m doing it on a VM it takes about 4 hours to build but as soon as it’s done I’ll upload it and poke you. Could fix your issues.

3 Likes

Awesome, thanks for that

The big baby (1.8GB with stock gapps suite) is here. I hope it’ll fix your issues.

Don’t forget to wipe of course and also right after wiping, so before flashing the ROM, go back to bootloader and run

fastboot erase metadata

Then flash.
Let me know how it went.

3 Likes

Good job @Aaanze :+1:

1 Like

\Android Debug Bridge>adb sideload lineage1.zip
serving: ‘lineage1.zip’ (~47%) adb: failed to read command: No error

Trying to add a google account results in a black screen that forces you to restart the phone. Tried flashing it twice now, same error both times

Yeah this is fine, this is basically an error message saying that no error occured, it’s mentionned in LOS official docs.

Now that is weird… Do you try to set it after initial setup or is it during the first setup steps ?

I tried both. I couldn’t set up the phone because of that so I set it up offline and tried to add an account afterwards

Damn… I’m starting to run out of solutions right here… Maybe I should try building with another “race” of Gapps, mindtheGAPPS for example ? If I get some time I’ll dig into it

I think I’ll take it. I just flashed the pico version for the sixth time or so and it works. I have no idea why but I’m not going to complain. Thanks for being so helpful and eager to help!

2 Likes

As in google drive features in other app works ?

Yeah. The first thing I did after the latest flash was install the app and try connecting to drive and it worked. I’ll finish setting up my apps and stuff and see how it goes but I haven’t gotten this far until now

There’s some magic at work here… I wonder if the fact you’re coming for /e/ could have messed up “something” ?
Well if it works, it works haha. I hope it’ll last and you’ll start enjoying the device as you should !

Yeah I was wondering about that as well but there was nothing I could’ve done about it.

It’s also a great timing for everything to work since my previous phone has finally died yesterday lol