FP4 and LineageOS

Most likely not. The patch basically bypasses the system camera permission check. But it seems that it’s still capped at 12MP (and even below 12MP in Camera2 mode). See:


No, it has only 12MP

1 Like

wideangle lense yes, 48MP no

1 Like

Can’t tell for sure as I use Linux, but when I connect my phone and choose File Transfer for the USB connection, lsusb shows it as

ID 18d1:4ee2 Google Inc. Nexus/Pixel Device (MTP + debug)

That suggests the Google drivers might work. Look for any Pixel device or the Nexus 5 (the Nexus 4 and earlier devices used different device IDs).

Which version of Magisk do you use? Do you have a link as isn’t John’s being depricated? Or did I hear that wrong? Where’s the safest site to download the modules?

im using john wu’s git to download magisk, the git hub is still active, so i hope it continues, works perfect.

1 Like

Found it thanks I’ve started it and added to my list in Git. Been out of the custom ROMs game for a while and now I’m back in IT I bought the FP4 specifically to tweak :grin:

First, Thank you to everybody who has worked to help make LOS available for the FP4! This thread is incredibly informative and helpful.

I’m preparing to install LOS20 on a FP4 and am trying to understand the different options for having access to the Google apps with LineageOS… Ultimately, I need the phone to have functional GMail and Google Maps.

I think the two main options are:

  • install an Open GApps or MindtheGapps package immediately after installing LOS
  • install LineageOS for microG (for which a build for FP4 is not available yet, but expected soon)

is that accurate? Will GMail and Google Maps both be installed or readily available with both of these options?

Also, I see from the LineageOS for microG FAQ that the Open GApps use more storage and drain the battery faster than the microG package. Also, more of the microG package is free (libre) software. Are there other differences that are noteworthy?

Thanks in advance

I have the official LineageOS + MindThe Gapps on my FP4. Works great here :smiley:. There is no Open GApps yet for Android 13 / LineageOS 20. You have to take MindTheGapps. And yes, you have to install it immediately after installing LOS. With MindTheGapps you get the Google Services and the Google Play Store. GMail and Google Maps are not included, but you can install both easily through the Play Store.

I haven’t tried LineageOS for microG (yet).


Has anyone noticed reduced battery life after updating to the official LineageOS version? Mine barely holds a day now, even with light use.

Here FOS → official LineageOS + MindTheGapps: battery live is the same.

I find it the same or slightly better. On mindthegapps with seedvault backup and both nextcloud and syncthing running in the background.

Does anybody have Ghost touches on Linage OS?

I haven’t got them anymore, like I wrote in the other thread, but they happened to me on LineageOS and iodéOS, both with Android 12.

Getting better had them on first build

In case anyone was interested, I’ll answer my own questions:

→ I used the traditional method to keep root after an ota, except I didnt need to restore the stock image first. I just ran the update, wait for reboot prompt and then proceeded to install magisk to OTA slot before rebooting.

→ no need to reflash Gapps, they are maintained after OTA install.

1 Like

Hey all, I have a problem (with a workaround) and another question after installing LOS yesterday…

The problem: Since installing LOS I’m experiencing a problem with the outgoing sound not working during calls. The person on the other end can not hear anything – no sound at all (but I can hear them fine). This is consistent for every call. I have also found a workaround, which is toggling speakerphone on and off: upon turning on speakerphone they can start to hear me, and then after switching speakerphone off the they can continue to hear me. The sound then continues to work on subsequent calls without having to toggle speakerphone on/off, and will continue to work until the phone is rebooted. After a reboot the problem returns and I need to toggle speakerphone on/off again. I also tried fixing the sound by muting and then unmuting, but that does not have any effect. Has anybody else run into the same problem? Does anyone know of (or have ideas for) a permanent solution that doesn’t require toggling speakerphone on the first call after a reboot?

For reference,I installed the 20230115 nightly build of LOS 20 (using the corresponding 20230115 recovery image) along with MindTheGapps-13.0.0-arm64-20221025. I followed the instructions from Fairphone for unlocking the bootloader, and then the rest of the installation instructions from LineageOS, and did not run into any issues during that process. I did not root the phone, or re-lock the bootloader, and I have not installed any other apps. Initially “4G Calling” was off, and the APN settings were not quite what I expected, but the audio problem persisted after turning on 4G Calling (and adding/selecting an APN entry with the carrier’s recommended settings).

Also, at times I will see “5G” appear with the other icons in the status bar at the top of the screen, but when “5G” isn’t showing I don’t see “LTE” or “4G-LTE” or similar. Do other people see any sort of a LTE/4G icon?

While I’m still testing out functionality, I haven’t run into any other obvious problems yet…


This is indeed a weird issue, I’ve never heard of it before.

Did you try to make whatsapp (or any other voice over internet app) calls to see if this is a general mic activation issue of more something linked to the phone calls in particular ?

You could also try a voice recorder app, or simply record a video to exclude/confirm the lead on mic enabling issue.

Enabling logcat during a defective phone call might provide some explicit error message (with a bit of luck).


I tried rebooting and using the “stock” sound recorder app and it recorded with no problem. Then I made a phone call and experienced the same problem described previously (and resolved it by toggling speakerphone on/off).

I’ll follow up separately re: logcat

I had a weird bug that got fixed by turning on and off a permission, have you tried to go into app info for the phone app and turning on and off the phone permission? Might be worth trying