FP4 and LineageOS

Hey both,

  • no, I used the recovery from mmustermann (now I also understand why there is a recover) and I have dobe the steps till no. 5 as I posted. And yes, it looks like the one on your image. before each retry, I wiped again.

  • @mmustermann now you suggest to boot instead of flashing?

In general, I will not be able to update the next LOS version from mmustermann like this? Still I have a running instance. Maybe I can use it for some month and hopefully there will be an official release in the mean time…

What else can I do?

@Aaanze @mmustermann


So if you ignore the wrong signature and say yes to “install anyway?”, did you try to boot to the normal system afterwards? Does LOS work or does it hang in a bootloop?
If it ends in a bootloop, please check a few things:

  1. Ensure that the files you downloaded have not been corrupted. Do so by checking if the sha256 hashes match.
  2. Are you absolutely sure that you use the 20220511 recovery for sideloading? It didn’t complain about the wrong signature for me.

Doesn’t matter as long as it worked and you booted or flashed the 20220511 recovery.

You will be able to sideload the next update. You might just loose your root access after the update, because the update usually overwrites the boot partition. So any modifications you do to the boot partition might get lost and you probably have to patch the boot.img again to reinstall Magisk.

Many thanks. Yes it is running fine (so far) and it booted normally.

One last question: The rooting process will wipe my data?

PS: If one of you guys ever visit Hamburg - ping me, now I owe you a dinner + drinks for this support!


Usually not, because your data is stored on a seperate parition. Modifying the boot partition leaves the data partition untouched. But it is always a good idea to have a working backup!

1 Like

Thanks, trying to patch you .zip tells me that something failed. Then I realized I need the boot.img. but where do I find yours? it’s neither the .zip and the recovery.img from you right?

You can use a tool like payload-dumper-go to extraxt the partitions (including boot) from the files in lineage-19.1-20220511-UNOFFICIAL-FP4.zip.
I’ve uploaded you a patched boot.img, just install the Magisk app and follow the usual instructions:


Thanks! Would you mind to explain the steps, how to run the tool. The read me does not explain. I know how to clone and that I need to install Go.

Sure :slightly_smiling_face: You can download prebuilt binaries for your architecture from the github releases, no need to install Go. If you are on an Arch based distro, it’s also in the AUR (but then what isn’t :smirk:).

Extract lineage-19.1-20220511-UNOFFICIAL-FP4.zip first, you’ll find the payload.bin file in there we’re interested in.
If you’ve downloaded payload-dumper-go manually, just extract, it open your terminal where you extracted it to and run it with ./payload-dumper-go path/to/payload.bin and it will create an folder extracted_$date_$time in the current directory.


If you struggle with the payload-dumper I’d suggest you go with the first suggestion from @hirnsushi as it doesn’t require you to run any kind of tool:

  1. Install Magisk app on your device

  2. Download the LOS patched boot.img

  3. Follow these instructions:


Just to mention an alternative method I successfully used to have boot.img, is to (one-time-) boot to TWRP and backup the boot partition on the external SD card.

Internal memory is not currently available with TWRP-for-FP4 because of decryption incompatibilities, but boot partition is not encrypted so can be backed up :slight_smile:

1 Like

Is the way back to original also possible?

Back to original FPOS? → https://support.fairphone.com/hc/en-us/articles/4405858261777
Back to an unrooted phone? Just press :wastebasket: Uninstall Magisk in the Magisk app.


I updated my description with you points @hirnsushi

However, I delete the last point fastboot erase metadata. After that the LOS was corrupted :confused: I will not do it with the new attempt. So is it badly required?

Would be great if you give my summary another review. FP4 and LineageOS - #255 by echo1


CC: @Aaanze @mmustermann

1 Like

That sounds about correct :slight_smile:
Did you manage to successfully root your device ?

Yes - AFWall+, XPrivacy, AdAway work like a charme. After 7 years a new phone with LineageOS <3 - another 7 and more on the road :slight_smile:
I owe you folks, let me know how if applicable. My offer is still valid! :smiley:


New build with security patches of June is up.


Downloads for : Fairphone Fairphone 4 | AndroidFileHost.com | Download GApps, Roms, Kernels, Themes, Firmware and more. Free file hosting for all Android developers.

363cc765fd069e149e8f618b98796c79a1b014ab13c95bfad7fa04cfd1ad846f  recovery-19.1-20220611-UNOFFICIAL-FP4.img
8a7f04657b5e52c054fbe3b093ffaf8140b03eb5c4786005bcd3675697b5991f  lineage-19.1-20220611-UNOFFICIAL-FP4.zip

Please let us know if your root survives the update.


Install went great, no root also installed MindTheGApps and that worked fine. Just had to make sure I was in Lineageos Recovery. Nothing wrong so far.

1 Like

Everything works? And if not there is a way back right? I want to try…

I really want to try but step 4 scares me a little. Is there no way back to stock os? Or I don’t understand it well?

It was not possible at the time of writing those instructions (I guess), now it’s definitively possible to revert to stock OS :slight_smile:

General advice if you try other OS: just be careful with relocking bootloader (don’t relock it OR check before that get_unlock_ability = 1 )

1 Like