FP3 + Usb-C Lan adaptor

Dear FairPhoneFans,

trying hard to connect my oob FairPhone3 with LAN via different Usb-C adaptors I nothing but failed. The FairPhone Support confirmed that this should in theory work. They also confirmed that they failed to get it running theirselves. Has anyone of you had any luck with this? Which adaptors to use? Do I need any additional software or drivers?

The adaptors I tried so far were

Thanks for any help and suggestions

I had success with a USB-C to USB-A converter plus USB-A Logitech G933 dongle. AFAIK I don’t have a USB-C to ethernet dongle (will have to verify), but I do have various USB-A to ethernet. On macOS, these require a driver. On Linux, not AFAIK. I can give that a whirl ~next weekend.

Thank you Jeroen, very much appreciated.

What exactlyis a Logitech G933 dongle? Logitech G933 seem to be headphones right? Tried to get a hand on this dongle on the web but couldn’t find anything.

Would be great to know if LAN works with any USB-A-to-LAN dongle on the FP3.

Yeah it is. It basically becomes a sound output device on the OS, so it always works. So what I’d do is search specifically for an ethernet device which is advertised as working with Android (including Android 9 Pi). As an alternative, you could can also use ethernet over USB. I can verify this works (although I did use USB-C -> USB-A -> USB OTG -> USB-A.

I did now buy and try the following setup

  • USB-C -> USB-A -> USB OTG -> LAN

without success. The devices used were:

  • JSAUX USB C to USB 3.1 Adapter OTG
  • Rankie USB network adapter, USB 3,0 to RJ45

Did you have any success with the logitech dongle?

There have been some attempts to get LAN working on a Fairphone 2, see for instance here. It looks like the dongle was detected but there was a software issue with the network configuration on the FP2.

Sorry I was a little bit busy with the holidays and work, and I forgot testing it in the evening.

The Logitech dongle is just USB-A audio to proprietary 2.4 GHz protocol. So whatever supports USB-A and audio in/out via USB, is going to work with that. I mean, sure I prefer open specified protocols, but this works rather well (Windows, Linux, macOS, Android, …).

I just was able to give it a whirl and I got it to work without any hassle.

Before I started: I have Developer Mode enabled and I search for USB. Then I get like 3 or 4 times the same options (about who and what configures USB). Then I made sure it was set to USB Tethering.

I used USB-C -> USB-A -> USB-A OTG cable -> USB-A -> LAN.

It worked plug and play.

However if I don’t use the USB-OTG cable I only can charge!

Let me know if you have any more questions. I got another USB-A -> LAN cable I can try later on to see if it also works. I wanna see if it works with airplane mode just for the heck of it.

That’s interesting, so there is an issue negotiating host/client mode on the USB-C port (and an OTG cable forces the FP3 to become a host rather than a client).

Well, I suppose that issue is there with the USB-A <-> Ethernet adapter. IIRC I have been able to use USB-C <-> USB-A to get USB networking this way. But I’ll have to confirm.

PS: It works even with airplane mode. Gonna do more tests later today.

PPS: The other LAN adapter (ASIX) also works (and does not work without USB-OTG). USB3 to 1 gbit. Other one is USB2 to 100 mbit (not sure brand, says Sanyo MAC).

PPPS: My bad, it turns out both work without USB-OTG cable as well. However, the bumper causes the USB-C to USB-A adapter to not fit well. Need to be careful to ensure it is and remains plugged. Why didn’t it work before? Because I was unable to change USB mode to that the FP decides the mode. I’m done with testing, for now.

I just tested mine 3 USB to Ethernet Adapters (with an USB-C OTG Cable), here you can find the result and the chip sets in the adapters:

  • Tecknet TK-UL688G (works well on FP3)
    [ 4615.647406] usb 1-6: New USB device found, idVendor=1199, idProduct=9079
    [ 4615.647409] usb 1-6: Product: Sierra Wireless EM7455 Qualcomm Snapdragon X7 LTE-A
    [ 4615.647410] usb 1-6: Manufacturer: Sierra Wireless, Incorporated

  • Asus ASIX AX88772B (works well on FP3)
    [ 4853.738964] usb 1-1: New USB device found, idVendor=0b95, idProduct=7e2b
    [ 4853.738977] usb 1-1: Product: AX88772B
    [ 4853.738980] usb 1-1: Manufacturer: ASIX Elec. Corp.

  • Orico UTJ-U3 (is not working on FP3, but well on FP2)
    [ 4881.886958] usb 2-1: New USB device found, idVendor=0bda, idProduct=8153
    [ 4881.886979] usb 2-1: Product: USB 10/100/1000 LAN
    [ 4881.886985] usb 2-1: Manufacturer: Realtek

gruss ivo


Thanks a lot, I’ve just ordered an UTJ-U3 for my fairphone2 !

Hi Ivo,

thanks a lot for your testing :love_you_gesture:

Based on that I also got myself a Tecknet TK-UL688G for my FP3. However, couldn’t get it to work with it using the USB-C OTG Cable I had at hand. Would you be so kind and let me know which one you used?

Thanks in advance

Dear Ivo,

still can’t get it to work. It would really be helpful to know which USB-C OTG cable you used. Even more so because fairphone product team verified to me that they couldn’t get it to work either and it’s not official requirement nor certified to work with fp3.

So I’m positively excited on your success report and have everything ready to reproduce it on your reply.


Sorry, I was not at home and can’t have a look. Now, here you are:




Holy guacamole! It works! Kudos to you. Thank you so much.

Would be really interesting to understand why/how after even the fairphone support said it wouldn’t work.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.