English

FP3: touchscreen over-sensitive

FP2 had some setting in the accessibility menu called “touch & hold delay”.
This could take influence in the behavior of the display.

Isn’t there something similar available for the FP3 / Android 9?

2 Likes

Thanks for the hint, just tried it with setting “long”, still same behaviour though.

Same problem with my fp3… i have left a message on support team today. I hope for a quick answear… i hope it s not a hardware pb !

So far, Fairphone support has requested additional information from me (results of the touchscreen service test and a video where the finger’s touch input is visible).

Here’s a sample video showing a pinch to zoom problem (Google Drive) that I also experience and that might well be related: pinch to zoom sometimes only works at 2nd, 3rd or 4th try.

At the moment, Fairphone is still investigating on this issue.

Thanks for your reply. Do you also have problems with keyboard sensitivity? Once in a while i get multiples instances of one letter when i press a Key. For exemple : “eeexxxxxeemmppplleeee” :roll_eyes:

Here is thé Message i have sent to thé support center :
Very often, the tactil screen is is not responding correctly: it is very sensitive, when i touch a key for a letter it writes 3 or 4 of this letter instead of just one, or i can not scroll it press immediately the link under my finger. The becomes unuseful. Please help quickly i m very disappointed with this

1 Like

I don’t experience the keyboard-issue you described.

(A few times I think the keyboard-swiping was interpreted as “interrupted” (as if I had lifted my finger from the screen to start with a new word, though I didn’t lift it). But then again, it’s really only been a few times, so I don’t mind - and I’m not too sure about the exact behavior in this case anyway. :slight_smile: …)

Update: Fairphone support asked me to return the phone to their repair center.

Dear community,

I am traveling and all of a sudden my fairphone 3 has started registering some of my clicks as double or triple clicks. This makes it nearly impossible to use (this message for example took a long time to write, and on most websites it randomly clicks on things). Anyone else experiencing this issue? How can it be solved? I need a quick solution as I’m traveling internationally for a couple of weeks and have no backup…

Yes, I have tried turning it off and on again

Thanks in advance,
Lonneke

2 Likes

Hi Lonneke,

I’ve been experiencing the same problem for a few days now.
The problem occured very occasionally at first, but it’s been occuring occur more and more lately.

I’ve had black screen issues before. I deassembled/reassembled the screen and it solved my problem. I believe that the problems I’m having now might be linked with that process (maybe some dust on the connectors?).

Anyway I plan on deassembling/cleaning/reassembling the display and connectors once again and see if this solves it. Have you already tried that yourself?

I also sometimes have this issue. I had trouble typing anything yesterday. iitt wwoouulldd aall llookk lliikkee tthhiiss…
Not sure if it is related to charging my phone, or just the touch screen module malfunctioning

2 Likes

I recently noticed this behaviour while the phone was connected to a charger. Things opened when I just wanted to scroll over them. There also was a “nervous” (double) vibration when touching the screen instead of the “usual” one. It reacted “as usual” when I switched off the power.

Maybe I did not really notice this within months becaue I hardly ever use it activley while charging.

1 Like

Hello

I’m currently experiencing the same issue.
Today my FP3 display began blinking. I had the same problem several months ago, and solved it then by disassembling and reassembling the display in order to ensure good contact of the connectors.

The operation was successful for the blinking, but led to this issue of over-sensitivity of the touchscreen.
I re-disassembled the display, carefully cleaned the parts and the contacts with a clean and soft brush. After reassembly, the issue was still here.

It is now impossible to enter PIN code in one time like before. Text entry is also more difficult, and swipe is also difficult and leads often to wrong commands, making the phone hardly usable.

I guess the problem isn’t in the contact. Maybe a component is failing, or some internal setting is maladjusted following first reassembly…

Is there a way to calibrate the touchscreen? Would this help? Or any other suggestion?

Thanks for your interest!!

Rémi

Hi,
I have been having the same issues for a while, apparently at random (over sensitivity: 2 or 3 clicks per touch, random scrolling web pages, impossibility to swipe the keyboard, impossible to unlock by swiping my pattern…)
Reading these posts, I did the test of connecting/disconnecting the charger and it is obvious.
In the screenshot below, typed under Signal, I tried twice to swype the (french) word ‘Absolument’:

  • first time unplugged: perfect on line 1,
  • second time plugged with cable into PC: see line 2!
    Have done the same test 4 - 5 times, plugged/unplugged: it goes wrong every time it is plugged, works fine when unplugged.

Screen test (*#*#66#*#*) is fine. Will send this to support asap.

1 Like

Of course, this happens with a lot of phones.
The “charger” is a switching power supply with several kilohertz switching frequency. If these spikes are not completely filtered out it will have an impact on capacitive touchscreens (and other devices).

You can try to switch to a newer / better charger without worn-out filtering capacitors, for example.
But I would not blame the phone if the charger delivers insufficient filtered current :wink:

3 Likes

Some posts here may be related to the ghost-touching issue. If you have issues similar to those in that thread, please reach out to support ASAP!

1 Like

@DonQuiche

In some cases of sensitivity issues, changing the time it takes for the pointer to react to movement can be effective.

Settings >System > Languages and input > Advanced > Pointer speed

Thanks for this quick reply, and you are probably right: I had actually plugged the phone via USB onto my PC.
I just tried again with my Samsung charger, and nothing went wrong. Then again with the PC: same problem!
I will keep looking, to check it does not occur in other circumstances, but will stay away from the PC :face_with_thermometer:
Still, this is weird. Never occurred with any previous phone?

@amoun
Thanks for your help. Tried form lowest to fastest: same. The problem comes when plugged to the PC only, and is independent of that pointer speed.

1 Like

Lucky you, then :wink:

1 Like

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.