FP3 Stuck in Fastboot Mode after OEM re-Lock

Dear Community,

To prevent data loss I decided to root my phone right when it came out of the box, which worked well.
After editing and reflashing the boot.img I re-locked the bootloader. Big mistake.

After one boot into recovery mode the phone offered me a factory reset, which I ran.
Now it only boots into fastboot mode.

I tried to perform the usual fastboot commands as mentioned in this case:

fastboot oem 8901-unlock



Allows me to boot into a different screen telling me my device has been corrupted and will not boot.

I am currently looking into the /e/ easy installer source code to understand the command chains it performs.
I do not have to enable oem unlock in the menu if I use easy installer.
Is this correct?

Is there any way to flash a factory image or revert to it?

Thanks for your help!!

Does it tell you your bootloader is locked or unlocked?
If it’s unlocked, easy peasy, just reinstall FPOS.

This command doesn’t work anymore.
You can try to unlock the bootloader again without OEM Unlock with this method


Hi Alex, thank you so much for the well written reply. Indeed, the bootloader shows “Locked” so required is a method to unlock the bootloader when in Fastboot mode.

Unfortunately I cannot try out this resolution, because I have sent the phone in for repairs.

Who as a side note ask a whopping 200€ to replace the only part that is not available as a spare - The motherboard.

1 Like

Ah, well, sorry that my reply came too late. It is indeed very expensive for a rooting experiment that went bad…

I am in Contact with the repairs Subcontractor and hope to convince them this is indeed a software issue.

Thanks for replying to he issue, I am sure, this will help future users not to do the same mistakes all over again.

1 Like

While that’s true according to Fairphone 3 Repair price list and FAQ - Cordon – Support … did they actually tell you they would replace the Core Module for this, or is this “just” the worst case scenario if they don’t get it fixed by other means?

I would think if the module isn’t damaged it would “only” need someone qualified to go through a (non-public) procedure to unlock the phone from this state. This should be possible.


The repair assessment was relatively tight-lipped. They just wrote it would not turn on, which depending on (bad) definition might be true.

It boots into fastboot only and if forced to boot with fastboot commands, informs the user, that the boot partition was tampered with.
Which is exactly what happened.

I opened a support ticket to request more information on the reasoning behind this assessment.


Hi Alex, big thank you for the solution provided. Love this community. I am however very disappointed by the repair service offered by fairphone/cordon. ripping out the core module because of a software error solvable in 7 minutes (Arch linux machine, including download of required files / software not including duration of flashing) is not sustainable repair practice. I assume this could be treated with better training of the engineers on site but this is not the place to complain about these issues. :wink:


Well maybe not the place to complain but definitely a place to voice your concerns.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.