FP3 stays black (dead?)

Hi there!

I have a problem with my FP3.
Yesterday I got a trusted mail with a doodle link.
I followed it and wanted to talk with my wife about a holiday appointment.

So I locked the phone and walked to her.
When I tried to unlock it my FP3 stayed black.
I tried charging it (nothing happened, not even the loading LED appeared), tried another akku (my wife has a FP3+) but nothing happened.
When trying to turn it on nothing happens, it stays black and not even the vibration comes.
It is as if the phone has no power.

I also dis- and reassambled everything I found screws on with no effect.

Has anybody a tip?

1 Like

this sounds uncomfortably familiar:

I’ll try a friend’s battery later today. :crossed_fingers:

I just sent it in for repair.
Luckily my guarantee hasn’t expired for 4 days :smiley:


I have exactly the same problem. No reaction of the FP3.

Allready tried different chargers and cables.
Allready tried another akku.

Nothing is working anymore.

Really frustrated with my FP3.

See this post

With the battery out and then connecting do you get a flash screen, vibrate then a battery icon?

If not then the bottom module may be faulty, the USB port may be damaged or dirty or worse the core module may be duff.

1 Like

Update: I got it back some days ago.
They had to replace the main board, I had to reinstall everything from a fresh install.

Now everything works again and I’m happy with it.


Phone was working last night, with around 80% battery. As I woke up today, it was powered off. I tried charging it in case the battery had drained during the night. No response when I connect the power cord. No success removing the battery and reinstalling it. Nothing seems to make it power on again.

I already submitted a support ticket, but since I have no phone, I want to see if someone else has any suggestions.

The battery is not bloated (did the spin test), and nothing seems to be broken. I left my phone working on my bedside table, and it doesn’t work this morning. I live by myself, and have no pets, hehe.


Hi and welcome to the community, I moved your post to an existing one, as it seems to be a similar issue, above are further links to similar problems


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.