FP3 rooted (Magisk) - recommended modules/apps?


I managed to root my phone without major headaches (btw., is there really no way to flash TWRP, or did I miss something?), mostly because I wanted to use Titanium Backup and AdAway.

But since I’m now able to enjoy other perks of it, I’d like to know if you could recommend any modules or apps that work fine (or even only) on the FP3.
Does Xposed work, and if so, how to install?

Some things I’d like to do, if possible:

  • lock single apps
  • reassign the long press on the home button (and/or other buttons)
  • change notification LED color/brightness, esp. while charging (I’d prefer it a bit darker…)
  • finger print sensor gestures would be nice, but I don’t have much hope there (on my old Samsung, I could open/close the notifications by swiping up/down)

But I’m also curious what else could be done.

Welcome to the community forum.

You did perhaps miss that you can install TWRP on the Fairphone 3 as documented at twrp.me.

But usually you would just boot it with fastboot when needed, because installing TWRP on the Fairphone 3 alters the boot partition, and that has further implications depending on your OS setup. (Breaks Fairphone OS OTA updates, gets overwritten with /e/ stock recovery by /e/ OTA updates.)


Ah, I did overlook that. With all the other instructions I found before, using only fastboot boot, I stopped reading after “fastboot boot …”. :roll_eyes:
But keeping OTA updates working seems like a good reason to avoid installation. Ususally you don’t use it that often anyway.

1 Like

Very convenient addition IMO: F-Droid Privileged Extension. Allows the apps from F-Droid to be updated without user interaction (just like those from Play Store).
BTW: Should you not yet use F-Droid – chop chop! :wink:


Yes, through EdXPosed. See here:


  • Install Magisk v19+ (for Huawei/Honor or OnePlus 7T/7TPro device, need Magisk v20.2+)
  • Install Riru-Core v19+ from Magisk repo.
  • Download and install EdXposed in Magisk Manager or recovery mode.
  • Install companion application.
  • Reboot.
  • Have fun! :slight_smile:

or here:

Could you be more precise about “locking”? Under LOS 17.1 (android 10 as well), I thought I had in the settings the ability to lock apps so that they demand the device’s credentials when you start them, but I can’t find the setting anymore.

I have this in the settings as well, under Settings→System→Buttons.



With my last phone, EdXposed was a reliable way to get a boot loop, so I was a bit hesitant to simply try it. Do I need YAHFA or SandHook? Or do even both work?

Yes, that’s the kind of locking I meant. I know this feature from Custom ROMs or some vendors, but it doesn’t seem to be included in AOSP or the stock ROM. I love that FP3 offers an easily rootable, (quite) unbloated stock ROM with realiable updates, so I’d like to stick to it (at least for now).

I can’t find that button setting, only an option to switch between gestures and 2- or 3-button navigation.

On my FP2 LOS17.1 both worked without any problem, but I can’t tell for the FP3.

The two other features I found in the settings may be LOS specific, and you might not have them…

Otherwise, I have just shortly tested ACC as magisk module, seems to offer plenty of options for battery management, but honestly I don’t need that many, other simpler apps do that quite good as well.

But as my brother said, the less you’ll fiddle with magisk and Xposed, the less problems you’ll get, so just leave it aside if you don’t need it :wink:

Sounds promising. I’ll wait a bit if someone else knows more for the FP3, otherwise I’ll just try it tonight or tomorrow.

Interesting project, but I guess I rather stick with the default, which doesn’t seem so bad as well. Except being a bit picky with quick charge (with my previous default charger, my old phone was charged in 15 minutes, while the FP3 charged a whopping 5% the entire night, so I ordered a Qualcomm compatible…), but I guess this module wouldn’t help there as well…

True. :slight_smile: And as written before, I made the experience that some modules can cause major inconvenience, which was one of the reasons I started this thread. The other major one was the sheer number of modules (often with somewhat poor descriptions as well) - which is a bit worse with Xposed where there are lots of modules which only work on very specific environments (like, a lot of outdated Android versions, ROMs, and devices).

1 Like

EdXposed worked fine. I used the SandHook version.
For app locking, I use MaxLock. It’s not perfect for privacy, as you can see the app for a split second before the lock screen shows up, but that’s OK for me.
Update: GravityBox allowed me to reassign the long press of the Home button. It also allows assignments for single and double taps, and for the back button as well. The settings for the task button don’t seem to work; changes of the navigation bar (button order, additional button, cursor buttons) also didn’t work for me. But it did allow some other nice options I knew from custom ROMs, like other battery icons, hiding the alarm clock icon, disabling the vibration for camera start with power button double click, …
So far, GravityBox for Android 10 (Q) is beta and not included in the Xposed app’s downloads, so it must be downloaded and installed via the XDA-Dev thread or github.

1 Like

I did not install TWRP, but I can’t install the current update. It only shows “installation issue” (“Installationsproblem”), no further explanation.
Do I have to lock the bootloader, temporarily unroot (is that even possible?) or something else?

Hey @Mirko,

I had the same issue with the August update. Once there is a current OS download available you can apply it following these instructions:

Do not miss the very first step (Manually install Fairphone OS on FP3/FP3+)! Finally, you need to reinstall Magisk.

Do you have Netguard activated? If yes, did you try disabling it before the update?

Thanks. I’ll try that once it’s available.
And future updates will probably work afterwards? (I.e., this one worked without issues for you?)

@Alex.A: No, I didn’t even install Netguard. I do use AdAway, but disabling it didn’t change anything. I also have the impression the download works fine. The progress bar moves until a bit over the middle until it stops with the error message.

1 Like

No, unfortunately not. My OTA update does not work as well and I am also waiting for that download to be released. My assumption is that you will have to follow this procedure for every future update.

1 Like

Is there a way to decouple ring and notifications volume using some root app? I’ve only found an old magisk module that doesn’t seem to work on Android 10.
And about this: does Los have this implemented?

Oh, OK… So maybe flashing TWRP and hoping for flashable ZIPs, like it’s common with Custom ROMs, might become an option after all. At least there are frequent and fast updates, so even if I’d skip every other update I’d be more up to date than most other Android users.

GravityBox has an option for that (and several related, like which volume sliders to show), but I didn’t test if it works. It’s an Xposed module. The options are in “media settings”. Btw., there’s also an option for more steps.
See https://github.com/GravityBox/GravityBox/releases/ for download (open the “assets” for the apk) and https://forum.xda-developers.com/xposed/modules/app-gravitybox-v10-0-0-beta-1-android-10-t3974497 for more information.

1 Like

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.