FP3: Rooted, formatted userdata, now it won't boot

Hey guys, I made a mistake after rooting and am now having some trouble.

I recieved my new FP3 today, I ran the OTA update, and then proceeded to unlock and root according to sm01man’s guide. It worked, but I wanted to ensure a fresh OS, so I formatted userdata using fastboot.

This turned out to be a huge mistake, as my phone now does not boot anymore. TWRP is also gone, though I can flash it (temporarily) by flashing the .img via fastboot.

Is there any way to download and flash the stock rom via fastboot or TWRP? So far I only managed to find k4y0z’s stock image with TWRP. Right now I’m very unsure to continue on my own, seeing that I did such a huge mistake, so I’m asking for advice here.

No need to flash it, just fastboot boot the TWRP image in Fastboot Mode.

Make sure you use the latest TWRP version.

That’s the one there is right now.
There’s no official image from Fairphone yet.

1 Like

Thank you very much for your answer.

I suspect that after flashing k4y0z’s images, I will permanently have TWRP, but no root, so I still need to redo the whole rooting procedure?

The stock partition images include the stock boot.img with the stock recovery, so you will not have TWRP installed.

Having TWRP installed breaks OTA updates for the stock OS, by the way, because it changes the boot partition compared to stock to have TWRP in it, and the OTA updater checks for modified partitions and denies updating in this case.

Just fastboot boot TWRP.

And you will need to reroot, too, and this, too, will break OTA updates.

1 Like

Thank you very much.

I just flashed k4y0z’s 8901.2.A.0110 image via TWRP, yet the phone still does not boot. During the flashing process, TWRP was also unable to mount /data and /storage.

Do you have any idea how to fix that problem?

Edit: Nevermind, apparently it’s necessary to flash the stock 0105 image, not the 0110 image.

This shouldn’t matter to the OS.
I’ve seen this on my phone, too. TWRP would be able to access data later when I set up my screenlock method again in the OS’s initial setup, which would then be the decryption password TWRP needs to access data.
Internal Storage is just a directory in data, so that comes with it.

Boot into the stock recovery and do a factory reset from there …

Else …

Which command did you run exactly?

1 Like

Booting into stock recovery does not work, it just goes straight to reboot. I’m downloading the stock 0105 image right now, apparently many users had similar problems with the newer image.

I used “fastboot erase userdata”. That was a stupid mistake, I guess it should’ve been “format”.

If that’s the problem, then just “Format Data” in TWRP (it’s in the Wipe menu).


Thank you, thank you, thank you. Formatting Data enabled the phone to do a proper stock recovery factory reset. It now booted up.

I guess I won’t root now anymore - ad-less youtube is not worth all that trouble.

If you want adblocking at system level, but without root, there are various options, including:

  • Netguard installed from Github. Not compatible with a VPN.
  • Using a VPN that provides adblocking.
  • Using a DNS-server that provides adblocking. From Android 9 onwards search settings for Private DNS (and the internet for a reliable DNS provider that offers filtering). For older versions of Android, there’s (for example) Intra.

If it’s just YouTube that you’re worried about, there’s NewPipe via F-Droid or GitHub (I personally prefer the latter, as it is faster to update when changes in YouTube break NewPipe).


To wipe userdata in fastboot, you have to do fastboot -w.
You should do the following to check that both slots have a bootloader :

fastboot --set-active=a
fastboot reboot bootloader
fastboot getvar current-slot # THIS SHOULD BE a
fastboot --set-active=b
fastboot reboot bootloader
fastboot getvar current-slot # THIS SHOULD BE b

Then you’ll need to see if both slots are in success state with fastboot getvar all and check the var slot-success:a and slot-success:b

What can I do, if slot-success:a and :b says “no”?

Check -> To get a slot-success=Yes

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.