FP3+ - "Recent Apps" not working anymore

Hi!
So I have a FP3+, installed /e/OS + Trebuchet Launcher and was happy so far.

Since fingerprint scanners just freak me out I don’t want it to be disabled just by software. I wanted to remove it from the phone. I found out it’s one of the few parts that are glued to the case so I just tried it by taping over the pins.

So far so good. Fingerprint is not an option anymore for lockscreen. But now my “recent apps” button does not work anymore :smiley:

I just don’t get it why this is happing. Surely it seems obvious why since the bug occured after “killing” a whole module but for me it’s kinda odd and I can’t really believe that the fingerprint scanner not beeing available to the system anymore causes this problem so someone here might have an idea how to fix it.

What I tried so far:

  • using apps like “Switchr” or “Simple Control” to gain access to recent apps again → nope :frowning:
  • tried to get some gesture module working via magisk → nope :frowning:
  • tried different launchers: Bliss, Trebuchet, Nova → nope :frowning:
  • installed different “taskmanager” apps → Only showing themselves but no other apps

So before I give up, disassemble the phone again (sure, it’s easy, I love it but booooy that’s a lot of screws…), I’d like to ask you, the community, if there’s anything else I can try to fix that problem.

Thanks in advance!

Sacer

HI @sacer Welcome to the forum

You seem to have gone to a lot of trouble over the fingerprint sensor.

I would suggest you set the phone back as it was to see if the phone functions properly and then just lay some black or coloured silicon mastic over the sensor.

You may have voided the warranty by digging into the phone so much, the fingerprint sensor is not a user repairable part :frowning:

1 Like

I agree with @amoun.
To check if the modifications are causing the troubles, I would try to undo them.

And scratching the sensor with a screwdriver/key/… might work as well for rendering it a piece of useless junk; shouldn’t it?

1 Like

A bit irreversible though :rofl:

Hi @amoun and @BertG and thanks for your suggestions!

I just undid the changes (removed the tape from the pins of the FPC) to check if it’s really causing the problem and voila: It doesn’t. The bug is still present so my guess is a problem with /e/OS that might have been “triggered” wether by opening the FP at all or it’s just a huge coincidence the bug appeared first after the operation.

Also a small update on the taskmanager approach: I just used “Taskmanager” from the /e/OS appstore and when it got root rights I can suddenly see all “active” apps besides just the manager itself.

I guess I’ll try to reinstall /e/OS (might even try android R beta) and check if the error still occurs.

PS: I don’t care about warranty :smiley: But thank’s for the warning!

2 Likes

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.