FP3: Pixel camera app / Google Camera Port

Do you use the config file? And the snap version or not?

The straight apk and no config :slight_smile:

1 Like

It is working BUT, it does not work with Simple Gallery Pro, like it used to work, even with “using other gallery app” enable. Anyway, I start to have something functional, thanks a lot!

Mine works with Simple Gallery as a stand alone but not in the Camera app that keeps asking for Google Photos. I didn’t realise as I don’t use the in-app option :slight_smile:
Makes sense as it is a Google port

Yes! [Use a third-party gallery] doesn’t alter in app option, as if there is anyway of selecting an alternative ‘gallery’. ???

So, the 7.4 v2.0 from here works perfectly so far, I can use Simple Gallery Pro and the app is working well.
Good to know: NGCam 8.2 requires 2 galleries to be installed — Google photos and third-party (Memoria, Gallery GO or any that worked in past versions).

This is not a bug. But Google prefer to change things. That’s why it is still recommended to use Google Photos instead of third-party gallery.

Thanks a lot for the help! :slight_smile:

3 Likes

Ah! Thanks for that, saves me struggling to get it to work given I’ve unistalled Google photos :slight_smile:

Having recently installed Nikita GCam version 1.7 (based on Google Camera 8.2.300.368894857.16) on my FP3+ running /e/OS 0.23 Q (24 March 2022, the next /e/OS update only arrived later today), I took a nice stroll towards the three country forest this afternoon, lured by the bright sunshine. So admittedly very favourable light was a given, and I have to say that the photos turned out very much to my liking. I had previously often been disappointed with nature photos taken with my FP3+. If anyone wants to see a bunch of the photos I took today, here’s a (warning!) Facebook album link that you should be able to access even without a FB account.

Technical feedback that I don’t want to leave out either is that running the app seemed to take quite a toll on the processor, especially when I was listening to music via the TWS earphones at the same time. Playback kept getting interrupted, stalled and at times only resumed for a fraction of a second every 20-30 seconds when the app was dealing the pictures right after having been taken (I think an HDR processing is involved). At one point, this resulted in the screen remaining black as well as the power button unresponsive for 1-2 minutes, until I forced a reboot. Also, when I had just stopped the app, re-launching it sometimes only resulted in the app menu being shown, but no picture shown and the trigger button or the switch to a different mode uneffective.

While it might sound like a slightly disturbing experience, I very much think I simply need to bear in mind to let this camera app work on its own and give it time to process a picture before continuing shooting. And well, let’s see if /e/OS can speed up a bit as well, it had gotten a tad bit laggier since the 0.23 update recently – as I said, I only installed the very latest update after this afternoon’s photo walk.

Which HDR mode do you use, HDR+ +? This def needs more time to process but I see a note on the screen then. The “normal” HDR + is working fast for me (but I use NGCam Port 7.4) and think quality of the pictures is really good

Maybe this causes issues as well, as with e/OS you dont have Google Photos?

I actually see a note on the gallery icon (blue circle like a notification symbol) when the processing seems to take place, so this probably helps to determine how long to wait. And as I said, I find the pictures very good, too.

As long as you are patient to wait and you dont want to take a few pictures in a row you are fine then. Would drive me nuts :wink:
just wanted to say that normal HDR+ mode already makes good pictures, so you could try if its less disturbing/slow/interrupting music (in case you use the super HDR ++ mode instead)

I checked and I apparently left the HDR+ status as it was – I guess same as yours.

After the 2nd /e/OS 0.23 update tonight, the screen generally seems to turn on much quicker again than after the 1st, maybe that comes with general performance improvement, too.

1 Like

By the way, i have had one longer and a shorter photo walk after the most recent /e/OS update, and the problems have been nowhere as severe as described (on 11 April) then. For the time being, I think it was a temporary /e/ issue.
Still quite happy with going GCam, although I have started to wonder if the better results might simply be down to HDR being default on GCam. :thinking:

1 Like

You should be able to deactivate to test?

1 Like

Comparison (on my FP3+)
GCam Port (default: HDR+) [left] vs. /e/OS Camera app (Open Camera) set on HDR [right]

  

  

  

7 Likes

I have now reached a point where for the first time ever since using a smartphone, I feel like I can leave my trusty old digital camera (from the year 2005, 5.1 MP) behind. Until now, nature photos were always what made me unhappy with smartphone cameras. The only thing still missing for me is a real (“optical”) zoom. But even in this respect, the resolution actually allows some acceptable cropped image details.

  

I have become much happier recently with my FP3+ camera since switching to the GCAm port. No feeling of needing any hardware upgrade at all. :slight_smile:

11 Likes

Seems very good, given that an optical zoom is indeed missing.

Do you recommend by the way using ‘Videostabilisation’? Is there also a quality improvement regarding the videos in the latest version you are using?

1 Like

Sorry, I cannot provide any experience there, I’ve never used really used video with any of the camera apps.

1 Like

Admittedly, I selected the best of 7 butterfly shots I took in the late afternoon today, but there were at least 3 more out of these which looked quite crisp and 99% equally presentably, too. Of the other three, some blurring on parts of the animal was visible on really close viewing – there was a gentle breeze that kept blowing against the plants from time to time. Fortunately the butterfly wasn’t shy at all and let me get like 15 cm (or less) close-up to her or him. Second picture is an exact 1/9 detail from the first (first picture automatically reduced in size from 4000x3000 when uploading, second picture not reduced).

 

8 Likes

thanks to @hirnsushi I found Gcam Photos Preview and installed this and now also preview works. I switched now from 7.4 to 8.2 as 7.4 started to be a bit sluggish after some time with Iode 3 (Android12) will see if 8.2 is better.

2 Likes

Dear everyone, I need your help: I cannot install some of the above APK apps.
When I got my Fairphone 3 two years ago, I managed to install MGC_6.2.030_RazerPhone2_V5.apk.
But recently I was very unhappy with photos against the light, so I tried installing several Nikita’s GCam APKs, unsuccessfully: after a few seconds, I systematically get “App not installed”.
The only APK I could install is PXv4.3_GoogleCamera_7.2.014.apk.
Even more disturbing: I thought it came from my old APK camera app, so I uninstalled it, and impossible to install it back.

I tried all the tips found on the internet associated to “App not installed”…
Could it come from the different updates of Android (current version: Android 11) I made since I have the phone ?