FP3: Pixel camera app / Google Camera Port

Same with GCam_8.1.101_Wichaya_V1.5 on FP4.

1 Like

Thanks for the inputs! Yes actually I came to the same conclusion after digging into it a bit. It is (at least for now) not possible. If I’m correct the main reason for this is the fact that the Pixel phones does not support an SD-card and therefore there is no option to choose between the storage locations.


Hi, I’m reporting I’ve been using Nikita: NGCam_8.2.300-v1.6 happily for roughly a month now. Most stable one I tried until now.


Any advantages compared to Wichaya?

i treid both, too a while ago, and didn’t find any advantage or disadvantages.
in wichaya you have a little bit more settings and more or other setting i want to have…thats all

Just remind, this topic was opened for FP3 a long time ago and I think Nikita Version was found to be the best for the FP3

Updated the title to avoid further confusion for FP4 please follow-up here


Hello, I’m using an FP3+ running the latest Android 10 /e/OS.

I installed both NGCam_7.4.104-v2.0_cam.apk and NGCam_8.2.300-v1.7.apk. Both installed fine, don’t crash and seem to work, although it takes like 10 seconds to launch them and I vaguely seem to find them heating up the FP3+ more.

However, I find that although I have set both resolution and jpeg compression settings to the most demanding maximum (full resolution / 100%), the resulting selfie pictures max out at just 4 MP / 2302 x 1726, far below what the hardware should allow. In contrast, OpenCamera produces a 15.9 MP / 3456 x 4608 selfie picture. This remains unchanged after a reboot of the FP3+.

I also tried to install NGCam_7.4.104-v2.0_eng.apk, NGCam_8.2.300-v1.7_snap.apk and NGCam_8.2.300-v1.6_snap.apk, but their installations all failed.

Any ideas how to rectify the resolution limit? Should I change these settings:

1 Like

My selfies have 8MP what is the max for FP3 correct? I selected Pixal 3a as I think I read somewhere here the FP3 cam is the same as the Pixel 3a. However if its the solution…

1 Like

On the gcam port website is written:

ATTENTION! DO NOT USE Google Pixel toggle if you don’t have that device from Google even if it doesn’t crash on your OnePlus, Xiaomi, Redmi, Realme etc. This toggle disables some changes especially for Google Pixel 2/3/4/5

So don’t use the toggle.
For the other settings, I used for surface: Pixel or Pixel 2, and as @yvmuell said, Pixel 3 for the cameras. Works fine so far!

Since last version of /e/, this app is not working well. Do you have the same problem on FPOS ?
I tried the latest update, no luck.

Which port in which version exactly are you using? With Nikita Version 7.4 and FPOS I dont have any issues.

Similar to yvmuell on my FP3+(FOS A10.0136) using Nikita 8.2.3 No problem, but I don’t enable Google Pixel :slight_smile:

I was using this one: https://f.celsoazevedo.com/file/cfiles/gcm1/PXv4.3_GoogleCamera_7.2.014.apk from cstark27

Now, I am trying many different ones, nothing works so far, I will try Nikita 7.4 and 8.2 then, thanks!

Yes the version I’m using is may be found at


Do you use the config file? And the snap version or not?

The straight apk and no config :slight_smile:

1 Like

It is working BUT, it does not work with Simple Gallery Pro, like it used to work, even with “using other gallery app” enable. Anyway, I start to have something functional, thanks a lot!

Mine works with Simple Gallery as a stand alone but not in the Camera app that keeps asking for Google Photos. I didn’t realise as I don’t use the in-app option :slight_smile:
Makes sense as it is a Google port

Yes! [Use a third-party gallery] doesn’t alter in app option, as if there is anyway of selecting an alternative ‘gallery’. ???

So, the 7.4 v2.0 from here works perfectly so far, I can use Simple Gallery Pro and the app is working well.
Good to know: NGCam 8.2 requires 2 galleries to be installed — Google photos and third-party (Memoria, Gallery GO or any that worked in past versions).

This is not a bug. But Google prefer to change things. That’s why it is still recommended to use Google Photos instead of third-party gallery.

Thanks a lot for the help! :slight_smile:


Ah! Thanks for that, saves me struggling to get it to work given I’ve unistalled Google photos :slight_smile: