FP3: Pixel camera app / Google Camera Port

I installed this one as well and it worked fine. I upgraded my camera to the FP3+ version and the app stopped working :frowning:

Well, I tried it and it didn’t work for me, maybe I should give it a second chance.

I have the same problem :frowning:

For me, the app still works after upgrading the modules. Maybe you could try to reinstall the app or possibly upgrade to the latest version?

1 Like

That’s very cool! Can you share your xml config here in the forum?

I am interested too

Ps, for fp3+ user a new version is available
Nikita: NGCam_7.4.104-v1.8-fix.apk:


Please find my current settings as Github gist https://gist.github.com/raprism/1d1f023d1b3782c2e9aa95063a60fbdb . Note that this is used with release 7.4.104-v1.7, and note that they are likely not optimum settings, but working.


I also have the android Camera GO port on Fairphone. It works well, zero problems except occasional slow focus. If you google “android camera Go for any android phone” you can find the link to the port.
Camera GO is a version of google camera for phones with little RAM (currently Nokia 1.3 has it). It’s less CPU-intensive than the gcam app and works OK, also has a portrait mode

1 Like

Hello, I just wanted to stress out that the latest stable cstark27’s Pixel Google Camera mod seems to work flawlessly with the FP3 hardware. Colorimetry and brightness appear to be well-balanced in any environment and you can also save a RAW version of the photos in a separated folder !


Could you try to install the new 8.1 version (and see if your settings still work)? Thx

Sorry, the newest version crashes at startup. I’m using the newest camera modules from FP3+. Maybe someone else with the original FP3 camera has more luck.

I tried the Urnyx05 and the Arnova8G2 port.

One was not installable on FP3 (or I took some wrong version from Urnyx) and the Arnova8G2 was hanging on start (only black window).

Does not work for me. Crashes chen opening

Do you have the FP3 (not the FP3+), right ? And which version of Android do you use ?

I have a FP3 upgraded with + photo modules, and under Android 10.
I just tried last version of Nikita NG Cam, it seems to work, even if I didn’t have time yet to try it very long : NGCam_7.4.104-v2.0 (Nikita, 2020-12-06, configs)


Nice find ! The cstark27’s Pixel Google Camera mod is not supposed to work with the new FP3+ hardware since it was developed for phones with similar specs as the Google’s Pixel.

The new Samsung S5KGM1SP03-FGX9 photo module seems quite particular.

I have been using it for a month now. NGCam_7.4.104-v2.0
I am very happy with the results.
The only thing that does not work perfectly: timelapse videos. Tried it twice. It looks like it records well till the end, but when you replay the video, only a few seconds of the recording is replayed, not the timelapsed version of the entire recording. What a pity.
Edit: FP3 with upgraded camera modules

1 Like

Do you use the Google photo viewer ? It could resolve the issue.

In slow motion mode and when you click the slow motion speed (1/4 -> 1/8), the app crashes.
Is that only the case with me?


So, just for testing, I did download Google Fotos. It did not help. Still the same issue. I deleted Google Fotos immediately after that.