FP3 next morning wouldnt show/turn on, after attaching it to charger, and trying again a START screen in green with misc debug and low level stuff shows

Okay we just removed the battery and reinserted it again but its still stuck in this fastboot mode. Some specs below the red fastboot mode line are being shown, the last line is the red device state locked.

with the volume keys I can select between:

START (green)
restart bootloader (red)
recovery mode (red)
power off (white)

Thats all. Before I removed the battery I had already tried the normal START and restrat boot loader and power off.

All leading nowhere but again to this fastboot(?) state when turning it back on or rebooting it.
Any more hints?

With selecting start , it briefly vibrates and displays the fairphone and powered by android logos, and then back into this START page…

I now also tried the recovery mode selection, and it pretty much immediately briefly vibrates and then returns back to this start and selection page with specs info.

Is this phone now completely hosed? what the heck? how is this even possible??? :frowning:

If fastboot is still accessible, it is possible to reflash the OS to make it working again. However, I haven’t yet found an exact how-to for the FP3 for this. I’m hoping one of the experts reads this topic and can guide you further.


Is thi selection screen called “fastboot”?
This fastboot screen or whatever this is, currently shows:

bootloader version 8901.2.a.0105.20191217
baseband version mpss.ta.3.0.c1_00565_8953_gen_pack_1
serial number… (redacted)
internal storage size unknown
main memory size and vendor samsung
secure boot disabled
device state locked

1 Like

Connect the device to a computer and install the fastboot utility:

Then run the command
fastboot getvar all

Post the output (you may redact serial-numbers etc)


Having some windows machine around, and the fp3 turned off. Attached it to the machine via usb, and fired up the sdk platform tool, fastboot.exe command line:

Blockquotefastboot getvar all
(bootloader) version:0.5
(bootloader) hw-chip:SDM632
(bootloader) battery-soc-ok:yes
(bootloader) battery-voltage:3956775
(bootloader) variant:MTP eMMC
(bootloader) unlocked:no
(bootloader) secure:no
(bootloader) version-baseband:
(bootloader) version-bootloader:
(bootloader) logical-block-size:0x200
(bootloader) erase-block-size:0x200
(bootloader) display-panel:
(bootloader) off-mode-charge:1
(bootloader) adb-enabled:0
(bootloader) charger-screen-enabled:1
(bootloader) max-download-size: 0x1fe00000
(bootloader) slot-count:2
(bootloader) current-slot:INVALID
(bootloader) slot-retry-count:b:0
(bootloader) slot-success:b:No
(bootloader) slot-active:b:No
(bootloader) slot-unbootable:b:Yes
(bootloader) slot-retry-count:a:0
(bootloader) slot-success:a:No
(bootloader) slot-active:a:No
(bootloader) slot-unbootable:a:Yes
(bootloader) has-slot:userdata: No
(bootloader) has-slot:product: Yes
(bootloader) has-slot:frp: No
(bootloader) has-slot:logdump: No
(bootloader) has-slot:dpo: No
(bootloader) has-slot:msadp: No
(bootloader) has-slot:apdp: No
(bootloader) has-slot:keymaster: Yes
(bootloader) has-slot:cmnlib64: Yes
(bootloader) has-slot:cmnlib: Yes
(bootloader) has-slot:lksecapp: Yes
(bootloader) has-slot:mcfg: No
(bootloader) has-slot:syscfg: No
(bootloader) has-slot:mdtp: Yes
(bootloader) has-slot:dip: No
(bootloader) has-slot:mota: No
(bootloader) has-slot:limits: No
(bootloader) has-slot:oem: No
(bootloader) has-slot:config: No
(bootloader) has-slot:prodinfo: No
(bootloader) has-slot:keystore: No
(bootloader) has-slot:misc: No
(bootloader) has-slot:persist: No
(bootloader) has-slot:vendor: Yes
(bootloader) has-slot:system: Yes
(bootloader) has-slot:devinfo: No
(bootloader) has-slot:boot: Yes
(bootloader) has-slot:vbmeta: Yes
(bootloader) has-slot:dtbo: Yes
(bootloader) has-slot:aboot: Yes
(bootloader) has-slot:splash: No
(bootloader) has-slot:sec: No
(bootloader) has-slot:fsg: No
(bootloader) has-slot:DDR: No
(bootloader) has-slot:modemst2: No
(bootloader) has-slot:modemst1: No
(bootloader) has-slot:dsp: Yes
(bootloader) has-slot:devcfg: Yes
(bootloader) has-slot:tz: Yes
(bootloader) has-slot:rpm: Yes
(bootloader) has-slot:sbl1: Yes
(bootloader) has-slot:ssd: No
(bootloader) has-slot:fsc: No
(bootloader) has-slot:modem: Yes
(bootloader) partition-type:userdata:ext4
(bootloader) partition-size:userdata: 0xc2f6f9e00
(bootloader) partition-type:product_b:raw
(bootloader) partition-size:product_b: 0x8000000
(bootloader) partition-type:product_a:raw
(bootloader) partition-size:product_a: 0x8000000
(bootloader) partition-type:frp:raw
(bootloader) partition-size:frp: 0x80000
(bootloader) partition-type:logdump:raw
(bootloader) partition-size:logdump: 0x4000000
(bootloader) partition-type:dpo:raw
(bootloader) partition-size:dpo: 0x2000
(bootloader) partition-type:msadp:raw
(bootloader) partition-size:msadp: 0x40000
(bootloader) partition-type:apdp:raw
(bootloader) partition-size:apdp: 0x40000
(bootloader) partition-type:keymaster_b:raw
(bootloader) partition-size:keymaster_b: 0x100000
(bootloader) partition-type:keymaster_a:raw
(bootloader) partition-size:keymaster_a: 0x100000
(bootloader) partition-type:cmnlib64_b:raw
(bootloader) partition-size:cmnlib64_b: 0x100000
(bootloader) partition-type:cmnlib64_a:raw
(bootloader) partition-size:cmnlib64_a: 0x100000
(bootloader) partition-type:cmnlib_b:raw
(bootloader) partition-size:cmnlib_b: 0x100000
(bootloader) partition-type:cmnlib_a:raw
(bootloader) partition-size:cmnlib_a: 0x100000
(bootloader) partition-type:lksecapp_b:raw
(bootloader) partition-size:lksecapp_b: 0x20000
(bootloader) partition-type:lksecapp_a:raw
(bootloader) partition-size:lksecapp_a: 0x20000
(bootloader) partition-type:mcfg:raw
(bootloader) partition-size:mcfg: 0x400000
(bootloader) partition-type:syscfg:raw
(bootloader) partition-size:syscfg: 0x80000
(bootloader) partition-type:mdtp_b:raw
(bootloader) partition-size:mdtp_b: 0x2000000
(bootloader) partition-type:mdtp_a:raw
(bootloader) partition-size:mdtp_a: 0x2000000
(bootloader) partition-type:dip:raw
(bootloader) partition-size:dip: 0x100000
(bootloader) partition-type:mota:raw
(bootloader) partition-size:mota: 0x80000
(bootloader) partition-type:limits:raw
(bootloader) partition-size:limits: 0x8000
(bootloader) partition-type:oem:raw
(bootloader) partition-size:oem: 0x10000000
(bootloader) partition-type:config:raw
(bootloader) partition-size:config: 0x8000
(bootloader) partition-type:prodinfo:raw
(bootloader) partition-size:prodinfo: 0x200000
(bootloader) partition-type:keystore:raw
(bootloader) partition-size:keystore: 0x80000
(bootloader) partition-type:misc:raw
(bootloader) partition-size:misc: 0x100000
(bootloader) partition-type:persist:raw
(bootloader) partition-size:persist: 0x2000000
(bootloader) partition-type:vendor_b:raw
(bootloader) partition-size:vendor_b: 0x40000000
(bootloader) partition-type:vendor_a:raw
(bootloader) partition-size:vendor_a: 0x40000000
(bootloader) partition-type:system_b:raw
(bootloader) partition-size:system_b: 0xc0000000
(bootloader) partition-type:system_a:raw
(bootloader) partition-size:system_a: 0xc0000000
(bootloader) partition-type:devinfo:raw
(bootloader) partition-size:devinfo: 0x100000
(bootloader) partition-type:boot_b:raw
(bootloader) partition-size:boot_b: 0x4000000
(bootloader) partition-type:boot_a:raw
(bootloader) partition-size:boot_a: 0x4000000
(bootloader) partition-type:vbmeta_b:raw
(bootloader) partition-size:vbmeta_b: 0x10000
(bootloader) partition-type:vbmeta_a:raw
(bootloader) partition-size:vbmeta_a: 0x10000
(bootloader) partition-type:dtbo_b:raw
(bootloader) partition-size:dtbo_b: 0x800000
(bootloader) partition-type:dtbo_a:raw
(bootloader) partition-size:dtbo_a: 0x800000
(bootloader) partition-type:aboot_b:raw
(bootloader) partition-size:aboot_b: 0x300000
(bootloader) partition-type:aboot_a:raw
(bootloader) partition-size:aboot_a: 0x300000
(bootloader) partition-type:splash:raw
(bootloader) partition-size:splash: 0xb00000
(bootloader) partition-type:sec:raw
(bootloader) partition-size:sec: 0x4000
(bootloader) partition-type:fsg:raw
(bootloader) partition-size:fsg: 0x180000
(bootloader) partition-type:DDR:raw
(bootloader) partition-size:DDR: 0x8000
(bootloader) partition-type:modemst2:raw
(bootloader) partition-size:modemst2: 0x180000
(bootloader) partition-type:modemst1:raw
(bootloader) partition-size:modemst1: 0x180000
(bootloader) partition-type:dsp_b:raw
(bootloader) partition-size:dsp_b: 0x1000000
(bootloader) partition-type:dsp_a:raw
(bootloader) partition-size:dsp_a: 0x1000000
(bootloader) partition-type:devcfg_b:raw
(bootloader) partition-size:devcfg_b: 0x40000
(bootloader) partition-type:devcfg_a:raw
(bootloader) partition-size:devcfg_a: 0x40000
(bootloader) partition-type:tz_b:raw
(bootloader) partition-size:tz_b: 0x200000
(bootloader) partition-type:tz_a:raw
(bootloader) partition-size:tz_a: 0x200000
(bootloader) partition-type:rpm_b:raw
(bootloader) partition-size:rpm_b: 0x80000
(bootloader) partition-type:rpm_a:raw
(bootloader) partition-size:rpm_a: 0x80000
(bootloader) partition-type:sbl1_b:raw
(bootloader) partition-size:sbl1_b: 0x80000
(bootloader) partition-type:sbl1_a:raw
(bootloader) partition-size:sbl1_a: 0x80000
(bootloader) partition-type:ssd:raw
(bootloader) partition-size:ssd: 0x2000
(bootloader) partition-type:fsc:raw
(bootloader) partition-size:fsc: 0x400
(bootloader) partition-type:modem_b:raw
(bootloader) partition-size:modem_b: 0x5800000
(bootloader) partition-type:modem_a:raw
(bootloader) partition-size:modem_a: 0x5800000
(bootloader) hw-revision:10000
(bootloader) serialno:A01235567890
(bootloader) kernel:lk
(bootloader) product:FP3
Finished. Total time: 1.781s

1 Like

It seems that both slots are marked as unbootable.
Since current-slot is marked INVALID, it’s unclear which slot was previously active.
So first try setting slot A active:

fastboot --set-active=a
fastboot reboot

Okay having set active “a” there is now a very tiny font screen showing only a few lines about android recovery…
there it shows some date of the probably 2020 january update rom or something…

cant load android system your data may be corrupt…

then at the bottom there are two blue lines try again and factory reset…

maybe the fp3 tried to update to the januar 2020 firmware when this bug occurred?
should I set some other slot as active? any more hints? what do I do? thanks.

Okay weird… I simply tried: “try again”… and now it animates those blue dots in a circle… fairphone blue background…

why would a “try again” help? :wink: confused … :slight_smile: it shows the sim pin lock screen now… yay… maybe this helped…


You can try setting slot b active, if that doesn’t work either you’ll likely have to do the factory reset.
Get back into fastboot by shutting it down and holding “Volume Down” + “Power”, then
fastboot --set-active=b


Just to be precise, I am still with active “a”, and only selected the try again there…

Okay now having logged into the android… it shows that it is completing now an android upgrade step… something went pretty bad with this possibly januar 2020 upgrade on this phone?

this was brand new and only a few apps installed a few weeks ago, business use phone, no fancy stuff, normal android app store and no funny business or messing with it.

how this can go so wrong… weird.

1 Like

If it works now, just leave it.
Not sure how this happened, the idea of having two slots is that it should automatically switch back to the not updated slot, should the update go south.
Somehow in your case both slots got marked as unbootable and the retry count was 0.
Setting it active also resets the retry-count.


Thanks again for your explanations and your perfect hints into this situation. Thumbsup!

1 Like

I’ve got the same problem here with a completly new phone, merely older than a week.
It turned off because of low battery before the last update could be done. Stuck in fastboot mode, same story as told before.
My fastboot.exe says as following:

I tried what you said k4y0z:

But either typing by hand and copying always gets me to this message:

same goes for b

Are you using a recent version of fastboot?
(fastboot --version should print a version number, but some distributions don’t link this directly to the sdk version number)

It says
fastboot version eac51f2bb6a8-android

i think i found the error: forgot a space between - -

I don’t think there should be one.
I can find references to that fastboot version going back >4 years. The slots system is more recent than that. If you still have issues try updating (official packages are Android SDK platform tools, i.e. you don’t need the full SDK.)


Thanks for your help so far!
I now tried it with the link you provided and even did the way with the full SDK (see image for version)

I also tried several combinations of “fastboot - -set-active=a / =b” and the only way working for me is with spaces in between.
Then I will get the response:

This message wont change for at least half an hour, is this normal?
Somehow I managed to set slot A active with no further change and am now struggling to set slot B active.
I also tried Android Multitools from this website which at least made my phone vibrate.

And thats as much as I know. Hopefully I am the only one having this issue!
Best wishes so far!

EDIT: I’m running on Thinkpad Windoof 10, version 1909 If this is of matter

I think we need to get the driver and fastboot command situation into a definitively working state to proceed. Try the following …

  • Disconnect the phone from the computer.
  • In Control Panel - Programs and Features:
    Uninstall the Android SDK (it is not needed for your purpose) and everything with “MTP” or “ADB” in its name.
  • Reboot Windows.
  • In Control Panel - Device Manager:
    Enable View - Show hidden devices, and then uninstall every possible ADB, MTP and smartphone device, hidden or not.
  • Reboot Windows.
  • Connect the phone again.
  • Download the current Android SDK Platform Tools, not the complete SDK.
  • Unzip the ZIP file to e.g. C:\platform-tools (you can unzip it to wherever you like).
  • Add the path to where you unzipped the tools to the Windows “PATH” environment variable, so adb and fastboot could be run from everywhere without always having to prefix them with the path.

Then make sure the fastboot command works with your phone using fastboot devices and if so, try setting the slots again, without the space between --.

1 Like
  1. My guess is your system is still using the old fastboot version. The new one(s) may be installed, but the older one may be taking precedence. (See also the comment about PATH above).
  2. A hyphen followed by a space usually signals the end of the options to the programme. Chances are that you’re effectively running fastboot without any further command.

It means fastboot is waiting for a phone to be connected. If the phone is physically connected but fastboot cannot find it, then either the phone is not in fastboot mode or the drivers that are being used are not compatible.

Only one slot can be active at any time, as far as I’m aware (the android documentation suggests there can be more, but I don’t recall this for FP3). Apologies if this is stating the obvious and you just want to switch active slots, but this has caught out people before.

To fix the issues with fastboot, following the advice in the post above is a good idea.
Whether you need fastboot to fix this, I don’t know. If one of your slots does not boot because you switched off the device mid-update (at least, this is how I read one of your posts above), the other slot should at some point be tried automatically, as far as I know - but your mileage may vary.

Thanks Elk for this step by step instruction and thanks Johannes for further explanations, which I’m always eager to hear!

I followed your steps and am now able to run fastboot and adb directly from CMD. But there where some drivers left in the system32 directory which I did’nt want to delete before further asking.
This are:

Now I’m again able to find my phone

but the problem still remains, except:

changed to:

and if I

It will return

remarkable is that the system will recognize a space between “–” and “set-active:a”
which i never tiped in.