FP3+ is having trouble loading

Hi there,

I have a fairly new FP3+ (only a few weeks old) and now got problems to load it. Whenever it is connected to the cable the loading status flickers between “loading slowly” and something else.
I assumed a loose contact but could not find any position that would work properly. The cable itself worked until now and still works for another device so I think this should be fine.
I checked if the battery is loose because I read that somewhere else in the forum, but this is not the case.

Any ideas what else I could try before I do a factory reset and send it back?


Welcome to the Fairphone community.

Which cable and which charger are you using?

1 Like

If previously, with the same charger and cable, fast charging worked properly, this is the same problem I had a few months ago. In this forum thread you can find some possible solutions… for me, it worked cleaning the contacts with isopropyl alcohol and a cotton swab.

But, if the phone is still under warranty (which I assume is the case), you can #contactsupport and maybe they can help you.

I hope it helps, best of luck.

PD: This problem is also being discussed here.

1 Like


thanks everyone for your help and the warm welcome! It turned out it indeed was the cable that had a slight damage. Somehow the other device was a bit less picky when it came to charging with the damaged cable :smiley:
I bought a new cable which is USB certified and labeled with “quick charge” and this one works fine.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.