English

FP3+ Google Play Store does not accept password

Hi there, I am trying to buy an app via the Google Play Store, however, the store will not accept my (correct) password. It seems that many people have run into the same problem. I have tried the Google Captcha, activating the less secure apps and also changed my password. Any further tips much appreciated …

Did you try switching the phone off and back on (not only just a restart, really on off)?
Do you have last updates?

Otherwise I would suggest a #dic:factorydatareset.

Hi @alex21, many thanks for your idea. I just turned the phone on and off (not just reboot) twice, to no avail. It´s a brand new FP3+ fresh out of the box, so it should have the latest updates installed?

Although it could seem strange, a factory reset can sometimes solve some problems even when it’s out of the box. It could also be a setting you set that podes a problem. Until you try you won’t know for sure.
Normally it should be up do date, but check nevertheless. What is your build number?

It should have the latest software installed which was available at the time it left the factory, which could have been some time ago.

Since there were updates very recently it’s safe to assume an update would be available.
And that’s not a Fairphone thing, that’s the same with any phone vendor who releases updates halfway regularly.

1 Like

… thank-you for the explanation. How can I install the latest updates, is there an “Updater” app or such? (A factory reset would a very last resort as I already have apps and configurations on the phone)

… following a tip from another thread, I installed the app (DAVx5) with the amazon store, worked perfect.

1 Like