FP3 Fingerprint sensor stops working even after exchange

Okay, my aunt urgently needs a working fingerprint sensor for work, so I helped her set everything up on her FP3 and it worked (though not well) for a while.
Then it just stopped working, her account she needed the sensor for got locked, because of too many attempts and no matter what we tried the sensor didn’t work again.

I read somewhere that tape on the sensor helped, but it made no difference.

I used the ckeckup tool and it said ‘finger_result.txt’.

Then I tried taking my fingerprint sensor out of my phone and inserting it in hers. It took me a while after completely disassembling the phone, that I just needed to exchange the whole back (I didn’t try to take the sensor off the back as it looked very glued tight. So nothing could have broke there).

Behold, the sensor worked. Perfectly this time. Even though the checkup still said the txt file was missing.

Today my aunt tells me that it doesn’t work anymore, so I tried to help, but there is nothing we can do to make it work anymore again.

Strange thing: I just tested her old sensor on my phone and it seems to work perfectly.

I’ll contact support in a bit, but I’m not sure what they can do to help. To me it doesn’t seem like a hardware issue, so sending a new back module, won’t do anything.
Maybe the missing txt file can be downloaded somewhere, or is that just a file the checkup test should produce as a result?

Okay now I’m thinking, maybe reinstalling the OS might help, if it’s a software issue. In safe mode we couldn’t really test the sensor, as the app she needed it for wasn’t there of course, but the checkup test still said the file was missing.

Yeah, so I’ll try that - probably should do that before contacting support, as that’ll be among the first things they’ll ask for.

I’ll post here what happens then, but if anyone has any other ideas I’m all ears.

If you haven’t noticed this yet, you might want to read up here:

In short, Google downgraded the security rating of the FP3 fingerprint sensor in Android 13. In Austria, the most frequent failure seemed to be in the Digitales Amt app.

From the little I caught, the sensor keeps its previously higher rating in LineageOS (don’t know about /e/OS).


Oh, thanks. No I didn’t notice that yet.

Okay, so I’ll check if she is even on Android 13, but probably, because that sounds very much like that’s her issue - it’s the Digitales Amt app that she needs (though strange that it worked for a while twice).

So instead of reinstalling the OS I should install Lineage on her phone, right? At least until G%&$e decides to downgrade the rating there to, that sounds like the solution.

I guess despite the lot of cursing over there in the other topic, there’s still more expertise there as well. :wink: Let’s close this topic and you will probably get advice if you ask in the other topic.

Just in short:


Google changed this in the base for all of Android, LineageOS just decided to not follow suit.

1 Like