FP3 doesn't Show on Windows 10 after connecting to USB

I tend to use it every few months without any problems.
Today I connect my FP3 to my Windows 10 as usually with the option for data transmission.
I tried what I could: FP3 doesn’t appear as a drive on the computer. I can’t open the phone’s files.

FP3 appears as a device in the settings of Windows 10, but there I can’t change anything that would help, as far as I can see.
Could anyone help me to find out how I can reconnect them both again correctly?
It’s NOT the cable, as I’m using my usual FP3-cable.

I suppose you’ve already tried to reboot the Windows 10 machine and the phone?


Good idea! Just did. But no change. Problem remains.


On the FP2, it sometimes helped to clear the app storage of the system app “Media Storage”: Settings > Apps & Notifications > [three dots] System Apps > Media Storage > Storage > Clear Storage. After that, it takes a little while until Android has rebuilt this index. Try to connect FP3 and computer again afterwards.


Sometimes the drivers that have worked flawlessy suddenly fail.
In such a case it can help to open the device manager in the system control.

Click on the FP3. This will show the driver.
Is it ok, or is there maybe an exclamation mark on it?

With a right-click on the driver you can try to uninstall it.

Then you most likely have to reboot the computer.
After rebooting the computer, you have to install the drivers again.

Possibly you have to log in with administrator rights.

Another option could be a corrupt cable, even though it has worked up to now without any troubles. When it breaks, it breaks and fails all of a sudden. It might at least be worth testing another cable.

Hope this helps.


Thanks for the replies.
Clearing media storage did not help.
For the drivers. They don’t have any exclamation mark. But I can’t make a right-click on them for uninstallation.
I’ll try with another cable just in case!


Not just the cable ~ the usb port may have dust in it. Due to previous experiences with a Samsung that I had to clean occasionally after a few years I decided to buy a case for the FP3+ so that I could insert a small piece of plastic material inside the phone case to stop debris from entering the usb port. It means I remove the case when charging.


Any ideas on what to do, when FP3 is not showing in device manager at all?
I tried adding a new legacy device, but no luck in finding my FP3.

Oddly enough, there is some kind of interaction between the phone and windows 10: if I connect by USB and choose the connection type (midi, ptp, file transfer etc.) looking at the win10 bluetooth settings (with bluetooth turned off!) it changes the icon in front of FP3. Also I can hear the “new device connected”-jingle that windows plays when a new plug&play device is added.
However, the device manager and file explorer does not suggest that there is any portable device connected at all. :frowning_face:

I did play around with amd, installed lineageOS myself and might have messed up something in the settings (phone or cpu).
May be you got an idea, duckduckgo didn’t help… thanks for reading!

Thank you very much for your comments! It seems to have been the computer’s USB or the cable. At least I could make it work with another computer.
I apologised to my phone for having been somewhat rude to it although it wasn’t her fault :slight_smile:


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.