FP3+ does not boot after water damage

Hi, I have spilled water on a table without noticing. The phone was there for a few hours and water got inside. The marker is partially red.
I left the phone drying for 2 full days.
Now it boots, get the blue dots animation, writes Fairphone, then switches off
I have tried RECOVERY MODE (power + down volume), I get only the no command icon
I have tried to activate safe mode (power + power down during animation, but would not enter it.
Any suggestion?
Do you know if it is possible to return the phone for a deeper check?

Thanks a lot

Did you check #waterwiki for further advice?
You might try to do a #dic:factorydatareset or a manual system reinstallation.
I think you can always #contactsupport and have the device checked by the repair center. I suppose you’ll just have to pay for repair.
Or you might search for a local repair shop close to you.


Hi and welcome to the forum.

Apart from Volker’s suggestions there’s no simple solution.
You don’t say how you dried it, but even longer in a flow of air may help.
It seems you are happy to dismantle so do it again and try and clean the contacts etc.

Do you try switching on without a SIM and SD card and if your SD card was formatted as Internal ensure it is clean. The SD card and SIM slots hopefully will have dried.

Was it just clean water? and was the phone face down or face up? I would imagine the phone is more vulnerable face down.


This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.