FP3 connectivity issues

Dear FP community,

Lately I have been experiencing connectivity issues, where I sometimes can not make or receive phone calls anymore.
This has been an issue with the FP2 as well, but disappeared when I got my FP3, and now these issues are back.
I wonder;

  • could it have something to do with the recent Android update?
  • how to determine whether it’s the FP3/Android update at all or if my provider ((Vodafone) is to blame (they have (had) connectivity issues in my street before)

Thanks in advance for any help of suggestions you may have for me.

Hi there,
Is this still an issue? If you see the problem with both phones it’s likely a problem with the carrier’s network. Does it occur in other places or only in your street? Do you have two SIMs or just the one? How old is (are) the SIM(s)? Which versions of which distributions are you running on the phones?

2 Likes

Hi!

Thanks for you reply! It is still an issue.

There used to be an issue with carrier’s network indeed (which is Vodafone), as for awhile they had a little blip of an area where they didn’t have 4G coverage in the middle of my street.
But that was years ago, and has since been fine.

While I initially noticed only in my house/street, I now notice I do not have the best of coverage in other places either (am currently in the UK for example).
The reception bars show a little ‘x’ now in the bottom right corner.

I use one SIM, which I think is about 2 to 3 years old.

What do you mean by distributions?

Probably OS/Android version/Update etc.

1 Like

Sounds like mobile data is disabled by configuration. Maybe because roaming is not enabled?

2 Likes

Understood. Running Android version 11. Updated last on April 5th.

1 Like

I had the issue in my own country too.
Roaming is enabled, but mobile data wasn’t. The ‘x’ has now disappeared :slight_smile:

4 Likes

By “distributions” I indeed meant the OS or “ROM” as some people say. Are you running the operating system distributed by Fairphone (that came pre-installed on the FP3) or have you replaced it with some alternative such as LineageOS or Murena?
However I’m assuming you’re using the FPOS that came with the phone and that you have recently updated to Android 11.

Do you still use the FP2 as well?

That just means that mobile data service is turned off or unavailable for some reason.

[Edit : sorry didn’t see other posts while I was writing.]

2 Likes

Thanks again for your reply.

I did recently do the latest available update. Think the issues stem from that moment on, now that I think about it (April 2022).

I no longer have the FP2, there were a few things broken so I send it in to be recycled when I got the FP3.

1 Like

The Android 11 update came out on May 10th.
This seems a strange problem. After updating to Android 11 there have been various problems relating to calls (low volume on Bluetooth, audio going to the loudspeaker instead of the earpiece, …) but I don’t recall having seen this one before. Also it’s not systematic. Just a few ideas:

  • Is 4G Calling enabled? If so, maybe enable / disable this (might be helpful in some areas and not in others).
    Go to Settings > Network and Internet > Mobile network > 4G Calling
  • Is there a SD memory card installed? If so, you might try removing it for a while.
    Make sure it’s formatted as “Portable” / external.
  • Hardware / poor antenna connection. Has the phone been dropped or encountered some other physical shock?
  • Changes to or problems with your carrier’s infrastructure. You could ask around if other subscribers have noted similar problems.

To go any further we’ll probably need more details. Does this always happen in the same places, at specific times, calling or being called by certain numbers, etc.

It might be useful to know exactly which software version you received: 8901-4.A.0010 or 8901-4.A.0011. To find out, go to Settings > About phone > Build number.

3 Likes

When I check ‘systemupdate’, it says it’s Android version 11 and that the last update was in April 2022.
The Build number i: 8901.4.A.0010.

  • 4G is enabled. When I had the FP2 I did switch off 4G from time to time, as I did have reception on 2G (but that made it necessary to reboot my phone every time I left the house).
    I have not done this with the FP3 yet.
  • There is a SD memory card installed, and it is formatted as ‘portable/external’. I’ll try that.
  • I did drop the FP3 months ago.
  • I’ll ask around for carrier changes.

One other thing I noticed this morning is that, while I had turned on mobile-data, it automatically switched itself off again.
I heard this from one other Android user too.

Just to be sure and clear, I was talking about 4G Calling, not (directly) the mobile data “Preferred network type”.

Check with the other user, but I would recommend a network reset if all else fails.
This is less drastic than a factory reset, it will just delete all network - related settings (Wi-Fi saved passwords, APNs for mobile data and MMS, Bluetooth pairings).

To do this, go to Settings > System > Advanced > Reset options > Reset Wi-Fi, mobile & Bluetooth

Before doing this you might want to make a note of your APN settings just in case (they should get reconfigured automatically).

Indeed, I had understood this was about 4G calling. The only option I have is selected, which is ‘automatic (4G/3G/2G)’

I’ll check with the other user, and if it automatically switches of again tomorrow. If so, I’ll do the network reset.

Thanks so much for your help! :slight_smile:

1 Like

I have the same issue with my FP3. No connectivity for calling and mobile internet. Sim-card status says 0 network strength, unknown network types, broken connection, but it does say “in use” at service status.

Wifi works. I have 1 sim-card, no SD-card, software version 8901.4.A.0010. Network preference set to “Automatic (4G/3G/2G)”, network selection also automatic.

  • I tried turning mobile data and roaming off and on again, didn’t help.
  • I tried updating my OS, but it says I have the latest updates (Android 11, security-update April 5th, Google Play May 1st).
  • I replaced my sim-card, thinking it might be broken, but the issue remains.
  • I tried putting my sim-card in the second sim slot, but no change.
  • I tried resetting my network settings as you suggested, but no change.

As far as I can tell everything is fine on my provider’s end (KPN) and with my mobile subscription. I’m starting to think it might be a hardware issue? Could it be that the antenna/receiver is broken? Could it be fixed by replacing the top module, potentially?

Hi and welcome to the forum. It seems you have tried all the sensible options to assess where the problem lies.

Have you tried either a ‘Safe mode’ start which will disable any custom apps, or a ‘Factory reset’ which will wipe all your custom settings and data?

The top module, I’m not sure if that has any relevance on network transmission or reception

Same problem here. An “x” appears on the signal strength of the 2 networks of my 2 sims after the update to Android 11 a couple of days ago. So I have no mobile data nor calls.
All settings seem fine (I haven’t changed anything and before it worked), but I will now go through all options mentioned in this thread, although I don’t see any clear solution reported yet.

Seems the same problem as reported by many other users here:

Hi and welcome to the forum.

The x indicates the mobile data it turned off rather than is failing to work or negotiate etc.

Updating can upset your personal settings so hopefully it is a simple reset that is required.

I note you have found a more suitable topic

All the best

Hi StepYourMind and welcome to the community and the forum.

I’m assuming that this problem is recent. Can it be linked to any specific event such as OS update?
Would you be able to test the SIM in a different phone?
Official instructions from KPN for configuring FP3 are given here:

I would suggest that you take a look, and if necessary create a new APN as indicated.

If the problem is hardware-related, it might be a good idea to get in touch with a local #fairphoneangel who might be able to lend you parts for testing.

Keep us posted :slightly_smiling_face:

Okay, so I let this rest for a while, because frankly I was just rather annoyed with it. But, I tried your suggestions:

  • New APN did not work. All settings were as indicated on the KPN website and going through all of them, reselecting them, then saving, did not yield any results as far as I can tell.
  • I switched the sim-cards of my work phone (FP4) and my personal, faulty one. My personal sim worked perfectly fine in the FP4, and my work-sim (which works fine in the FP4) was unable to connect to the network, both for calls or mobile internet, whilst in the FP3.
  • I didn’t really pay attention at the time (I don’t always have stellar reception where I live) but the problem started around the time I updated to Android 11. Seeing how other people on the Forum report problems after they upgrade I’m inclined to think this caused the problem. But I can’t be sure.

I’m going to check the other thread to see if anyone’s found a solution but right now I’m thinking I might try to find out how to go back to Android 10.

Does anyone know if Fairphone is going to come with a patch to Android 11 anytime soon that might solve the problem?

May be more satisfying for you to contact support at fairphone to see if they are even aware of such a problem.

1 Like