FP3+ Cannot re-enable stock camera app

I disabled the stock fairphone camera app a few month ago because I use Open Camera.
Now I cannot enable the app anymore. The buttons are greyed-out. Help!

First empty the Storage and cache to see if that helps.

Did you disable using the screen you show, not via ADB etc.

and do you have the latest update A.0021

You can also try

  • Safe mode start, which disables any custom settings
1 Like

I disabled it using the screen I showed.
I’ve tried clearing storage and cache, but with no effect.
I’m also on the latest update, updated just today. But this problem has been around since 2 months ago.
I haven’t fiddled with any advanced settings on this phone, just normal usage.

OK Do you have an SD card and how is it formatted, Internal or Portable?

No. No SD card. Double checked this. :wink:

What happes if you go to settings, apps, (google) camera, “open by default”, and click on “clear defaults”?

Best wishes,

1 Like

@teezeh Can’t. Those options are grayed out too…


What OS version are you using, my screen shot shows:

Have you tried starting in safe mode ?

Further you may be able to use ADB to enable the camera.
If you are not familiar with ADB you can search this forum

This is a link to my use of ADB on a Raspebrry Pi to remove some apps.

Similar problem here:

Detailed ADB commands and set up

1 Like

I had the exact same problem, having disabled the stock Camera app long ago and not being able to enable it again.

Safe mode didn’t help.

This finally worked for me:

Used a Windows PC with the phone connected with a usb cable, and having USB Debugging enabled in Developer Options on the phone, using SDK Platform Tools release notes  |  Android Developers :

adb shell
pm enable com.android.fpcamera3

It would be nice if there were an easier way…


@anon9989719 thank you for the information.
Using adb fixed my problem.
The Camera app is now re-enabled. To add some info to this thread:
I am using stock Fairphone OS Android 11, and , at the time of my original post, I am on the latest security update.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.