FP2 wont pick up new Sim from diffent provider


I have FP2 in the UK that was on Phone Co-op in the UK and appears to be loocked in to that network as a EE sim wont work in the phone, how can I unlock the phone so any SIM would work?

I though the FP2 was SIM free, alhtough I belive this handset came from the Phone co-op origionally.

any help your thoughts?

Whilst latest Fairphone 3 from Phone Co-op is SIM unlocked, although Fairphone 2 may have been supplied by Phone Co-op on o2 network was not aware SIM locked. Presumably you have tried both SIM slots as SIM pins upon earliest versions prone to failure?

Thanks for replying, I have tried both Slots, tried the sim in a 2nd FP2 from phone co-op which alass did not also work, howvere when I move my current Phone co-op sim to the phone it works, I know the EE SIM is working beacuse it works in a old Iphone 5s I have.

Locigally they FP2 handsets must be locked by the phone Co-op which they say they know nothing about?

No doubt you have already tried resetting device to factory settings with new SIM in place?
Which of the two SIM holders do these FP2 have?
With older design on the right it is too easy to rip off concealed spring contact when removing SIM if nanoSIM used in holder to make microSIM size.

Fairphones are not locked to any network. Is the EE SIM new?

1 Like

how exactly is it not working? I mean, can you enter your PIN but you don’t get a connection thereafter?

It could have something to do with your APN-settings. You can find those under Settings -> Network & Internet -> Mobile network -> Advanced -> Access Point Names
I had similar issues with upc in switzerland: the OS didn’t recognized the provider’s apn-settings itself, so I had to enter it manually.

The Sim is new from EE, I ahve tried it in two differnt FP2’s both from the Phone Co-op, but the new SIm works in a IPhone fine.

Hi one of the phones has the new and the other has the old, did not work in either, no sim holder was used initally until after I checked the sim in the Iphone.

The top of the phone says no netwrok, when you go to the settings it says there is no Sim in the slot.

What is the best way of going about finding the APN settings I would need to try this?

Update- Not fixed yet

But I have set the person who owns the phone up with the spare Iphone so they can have a phone to use, I would be grateful if you could give me any suggestions I can try before I get the EE sim back from them to try the suggestions in bulk.

I would be inclined to re-install firmware as nothing to lose:

Just put an EE SIM into FP2 running Ubuntu Touch and no problem recognising it and similarly in another running Fairphone OS just now.

Thanks, may be my thing I attempt, How risky I am concerned as it is not my own handset?

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.