FP2 won't charge and LED lamp wont light up

Last night my phone worked fine, but it suddenly stopped responding. Now, I charge the phone with the same charger I have always used, but the LED lamp wont light up. If i take the battery halfway out the LED lamp turns red for a few seconds. And the phone wont turn on or respond at all. I have tried different chargers but nothing makes the LED lamp turn on, only if i move the battery so the angel between the battery and phone is 45 degrees, and that only works some times. So What can I do? I don’t know anyone with a fairphone, so cant try to charge their phone with my battery. does it sound like I need a new battery?

the red light on the LED lamp also appears some times when i take the battery out!

Hi, I think for this matter you’d be better off contacting the support team. Don’t forget to keep us updated !

1 Like

Hast Du den Akku mal ausgebaut?
Dann geht es bestimmt wieder

I am sorry, but I do not know what you mean by expanded battery time? If i need to buy a new battery and you think that is the problem please let me know!

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.