FP2 Update fails: "E:signature validation failed"

I’m running Fairphone OS 1.4.2 on my FP2 and I tried to install the upgrade to 1.5.1, but every time I try to install it, it fails with the following output:

Finding update package…
Opening update package…
Verifying update package…
E:footer is wrong
E:signature verification failed
Installation aborted.
E:Can’t open /dev/block/platform/msm_sdcc.1/by-name/misc
(Permission denied)

signature verification failed

Try this words in the search field above …

I tried the update again today for the fifth time and now it worked. Thank you anyway for the pointer.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.