English

FP2 reboots in certain wifi networks

Right, now we’re getting somewhere. What kind of AP do you have at home?

3 Likes

I have internet from ziggo. The AP is a ubee EVW321B

My second Fairphone also rebooted way too much. But since I really love the idea of a fair smartphone, I tried to accept it.
Luckily I needed to replace my battery and so I found out that the old battery caused the reboots. Since I inserted the new battery my Fairphone didn’t spontaneously reboot anymore.
—-
I must not forget the reason: the old battery is a fraction of a millimeter shorter than the new one.
—-
Sorry. I did not read the entire thread until now. The problem here has nothing to do with the battery. Good luck with finding the solution(s)!

4 Likes

Interesting, indeed. I ask myself if this tiny little difference is by random or intentionally due to a design change from FP…:thinking:

@yvonnee

So if you haven’t changed anything else (apps etc.) it seems to show that the cause of your troubles were probably wifi related.
This brings me back to your headline. This now is your third FP2 but I assume always the same access point and network provider.
Maybe at this point we can agree on the statement that any third party app so far and the battery can be excluded as the root cause of your problem.

You could experience at your work that the phone can operate flawless. It is becoming more obvious there must be something wrong with your home wifi setup, whether hardware wise or configuration wise.
Generally you could look out if there is a more recent firmware available for your ubee EVW321B model.
If it turns out more clearly that your AP causes this problem we can assist you with further advice.
Please keep up your informative responses.

4 Likes

I also have Ziggo plus a uBee modem, though a slightly older model which cannot do both 2.4 GHz and 5 GHz (I couldn’t find it on ubeeinteractive.com though), and AFAICT didn’t have issues with it (I am using it in bridge mode now though). My uBee modem didn’t get updated firmware anymore (so no fix for KRACK, though APs generally don’t need fixes for that).

It could be possible that someone near your house (one of the other APs) has one of those AirPort routers which apparently caused reboots at work for @StevenHachel this was fixed by @chrmhoffmann but in LOS only AFAIK (LineageOS is alternative firmware for FP2).

3 Likes

yes I agree with that.

wifi at other places works without reboots, and at home the 5G wifi works without reboots to it is only the 2,4Ghz wifi which causes reboots on my current fairphone (and probably on the first two aswell)

My family (all with Iphones) do not have this problem .

I think now that it is the combination from my AP and my fairphone using the 2,4Ghz wifi which causes the reboots

2 Likes

So far using the 5Ghz wifi option on my AP is no problem , it works well.

I think my problem is kind of solved :smiley:

1 Like

I would like to thank everyone who helped me with this very annoying problem.
And I am really happy that I can enjoy my fairphone now :smiley:

7 Likes

Very good. This again has shown a very interesting case of unpredictable reboots caused by the wifi setup. As many users here have reboots which they could not clearly track back to a specific cause this should be taken more often into consideration when new cases here come up.

Now you know - it’s the iphones disturbing the 2,4GHz network attacking your helpless FP2…:rofl:
How many are they 3:1 - that’s not fair anyway. But fairness actually is what FP is up to…smiley

3 Likes

What you’ve applied is what we call a workaround.

I’m happy you do not suffer from the reboot issue anymore, but I’d be happier if we figured out what exactly caused the problem. Because then we can -perhaps- solve it, or at least document it better. At the very least your case, as far as it is documented, adds in that sense.

#wifireboots

3 Likes

I agree with you.
If there is anything I can do that would help let me know.

Yes, there is - but it’s actually more work as usual with the remaining 5% to finish.
Since we now know it has something to do with your 2,4GHz wifi a deeper investigation
would be useful.
The more simple steps first would be followed by the more technical and complex tasks.

  1. Restart your router once (one power cycle) and wait until everything is up and running again (may take up to 5 mins.)
  2. Get a free network analyzing tool like e.g. net analyzer (lite) from the Google play store
  3. Use the (easy to use) tool and provide us with some more basic info such as:
  • Which type of network encryption are you using, tkip; ccmp or the latest wpa2 (AES) ? (recommended)

  • Which network ̶p̶̶r̶̶o̶̶t̶̶o̶̶c̶̶o̶̶l̶ band are you using (should rely to the 802.11??? wifi standard)
    (in your router config)
    802.11n (ok)
    802.11g (ok)
    802.11n+g (ok)
    802.11n+g+b (troublesome)

Read the wiki here:

Make sure this mode b is not active, change the mode if actually set in your router.
It could only affect your mobile and not the bitten fruits :wink: as there probably are
chipset/driver differences.

  • Is your network ssid hidden or publicly presented so it can be seen by others?
    I had devices having troubles to reconnect to a hidden network after being properly registered to its unhidden ssid.

  • If there was no hit yet try to take some snapshots of this net analyzer tool (power
    button+volume down).
    Here we can see the signal reception strength, channel usage and overlap with other devices, connection speed to your router, encryption mode set etc.

looks like: (clear sensitive pieces of information using an image manipulation tool e.g. m$-paint/gimp)

or

  1. Clear the (2,4GHz) registration on your FP2 + the device from the list of permitted devices in your APs wifi list.
  2. Re-register the FP2 again (2,4GHz) taking the above mentioned into account and see if things are better (maybe this guide can assist you)
  3. If not check if a firmware update for your router is available to fix an issue

Any more rigorous steps like resetting and reconfiguring your router etc. are quite extensive and would also affect other devices using the router.

  1. If nothing helps - perform a Guru meditation session and remain on 5GHz smiley
    .
    .
    .
    Any other ideas what could be done to nail this cause (without replacing the hardware)?
7 Likes

Wow, that’s a lot!
Maybe - if @yvonnee has some terminal for her router - she can check the settings for encryption and network protocoll without having to install some app on her phone via this software.
Even if it’s just to make sure, there are no troubles being imported by installing another app. :wink:

@yvonnee if you don’t have a google account, you can get the free apps from the playstore using “Yalp-store”, that can be installed from f-droid. (Ok, that’s even one or two more apps to install; so much for my first advice. :roll_eyes:)
https://f-droid.org/de/packages/com.github.yeriomin.yalpstore/
An alternative to yalp is “Aurora-store”, that - in fact - is a fork of yalp:
https://f-droid.org/de/packages/com.dragons.aurora/
(Anyone any experience with this store? I just use yalp so far.)

That’s just some minor remarks to the (as far as I can judge it) great advice by @Patrick1.

I keep my fingers crossed for you.

3 Likes

Yes, these are the last five 5% as I always could experience prior to finishing a job completely.

Yes, of course that’s a valid point too.
She may as well dig into the routers configuration which as many these days may offer some kind of web mask.
My thought was about having a view from the handset side how the connection is seen there. The apple phones are working, so the wifi may be set up correct, anyway due to unknown reasons her FP2 faces troubles.

This could be an extra benefit for our community to provide better advice for future cases suffering network related troubles. At last her phone works fine with 5GHz now.

2 Likes

I don’t have time today or tomorrow but I will try to do this investigation soon.

haha I really would not know whether I have a terminal for my router?

I have a google account so I will try the app @Patrick1 suggested

2 Likes

well I tried this but it was not easy to use and I can not provide you with the information you asked. maybe I did something wrong but I could not find the network encryption or the network protocol in the net analyzer app :disappointed:

1 Like

Well, tech savvy people regularly tend to underestimate the complexity of such things :yum:
Do you get any of the screens @Patrick1 has pictured above?
The middle one at least shows the encryption; on the right hand side (WPA2).
Information on the protocol, I don’t see in the picture above. :frowning:

Edit:
I just tried some network analysers myself.
Most need GSF (Google Services, if I got it right).
More important yet, it seems, that with Android 6, the Location Services might need to be activated. Do you have this service turned on?

1 Like

@BertG

True…

Ehm, yes sorry. This piece of information again would have to be checked in the APs configuration. My Fritzbox offers these protocols:

protocol

@yvonnee

I am sorry if this tool is not yet as self explanatory as needed. Hopefully I can lead you a bit further.

There are only two information pages needed to be selected.
I don’t know how the default setup is after being installed and started for the first time.
But on the left hand side there is the menu from which you can switch to two analysis pages providing many of the interesting pieces of information.
Should look this way:

Tapping this gets you here:

Tapping any of the marked should bring you to the upper familiar screens and you may also scroll if necessary.

I hope this will get you further.
Sorry for the inconvenience.

1 Like

thank you @Patrick1 and @BertG !

I have 1 question left:

Where can I find the above information ?

all the rest I found thanks to your clear explanations :grinning:
see the following screenshots (my wifi is ziggo DAFBC and ziggo DAFBC-5G)

I am really curious what you make of this …

2 Likes