FP2 proximity sensor not reliably turning off screen during calls - See first Post for Workarounds

Solution: Please follow the official troubleshooting tool.

archived text

Besides a badly calibrated sensor the next most common reason for this issue is dust between the proximity sensor and the screen. For more info check this post.

Cleaning tips:

  • Clean the screen of your phone, especially the part where the proximity sensor is (See here).
  • If that is not enough open up the phone and clean it from the inside.
  • Remove the screen and blow onto the sensor and also wipe the sensor window in the screen assembly from the inside (I used a Q-tip for the window!).
  • Check the functionality of the Proximity Sensor with an app like Sensor Readout.


These should not be necessary anymore. If you cleaned and recalibrated (you may have to do it more than once) your proximity sensor and that didn’t help you may want to contact support.

Use powerbutton to end call

Disable the sensor (found by @guillaume)

Disable the proximity sensor by putting a small piece of aluminium foil on it (picture). It makes the sensor feel that there is always light and the screen never turns off.

Then use the power button to switch the screen on and off.

Original Post:

I know that there are similar threads here already mentioning a too sensitive proximity sensor, but I do have the opposite problem. During phone calls the proximity sensor doesn’t reliably detect my ear being close to the phone and keeps switching between turning on and off the screen.

Which also has the annoying implication that during calls I regularly end up in all kinds of different menus, mostly somewhere in the settings menus (not sure if I already managed to modify some of them accidentally), caused by me touching the phone randomly with my ear.

I’ve tested the proximity sensor with some app which revealed that at least according to that app the sensor only differentiates between “on” and “off” (so no true distance, just jumps from 0 cm to 5 cm and back), and indeed doesn’t continuously detect being covered - a very small movement of the object covering the sensor will lead to a switch to “not covered”.

So does anyone know if this sensor can somehow be calibrated / fine tuned? I’ve seen a couple of apps in the Google Appstore that mention such functionality but it looked like they were for older / specific devices or older Android versions, and some of them seem to require “root” access.

I’ve also read in other threads that it could also be related to the display contacts causing problems, so potentially dismounting and re-mounting the display might be helpful, or it could be related to the display not being clean in the area of the sensor. I’ve tried to clean it but no difference spotted so far. I’ve not tried to dismount the display yet.



Just to be sure: You removed the screen protection foil? If you applied another screen protector, does it have a cut-out for the sensor?

Same here. I haven’t made many calls but in one 5 minute call I was distracted by seeing the screen light up / turn off in the corner of my eye, and found the phone in a weird settings menu once I was off the call. I have definitely removed the screen protector and don’t use another screen protector.

1 Like

Same for me! I removed the screen protection fail and don’t use any other screen protector. However, during calls the screen does not turn off immediately, but only after a few minutes of inactivity. Conversely, if I want to finish a long call, the screen does not light up again after I have moved the phone away from my ear.

I recomend you the app Proximity Sensor Finder. If you know where it is, it’s easier to know how to hold the phone during calls.

If it still doesn’t work well, you can switch off the screen with a short press on the power button before making the call and switch it on again afterwards.

That’s how I had to do it always with FP1. FP2 however works perfectly for me.

1 Like

I place a coin on it, so you can see where it is:

1 Like

This app asks for many permissions that it doesn’t really need for its task.

I don’t think an app which is for testing the proximity sensor needs my location, my files, my serial numbers, my phone numbers and the telephone numbers I call.

Sensor Readout is FLOSS and needs no permissions.


Hi Ben,

yes, removed the foil and don’t use any other, but thanks for asking.


Hi Irina,

yes, that was the app I used to test this. I know now where the sensor is (and thanks for the picture) but doesn’t help me much how I should hold the phone during calls, resp. I haven’t managed to find a position where the sensor works significantly better.

Switching off the screen manually after pressing the call button to initiate the call works for me, so that’s at least some workaround, thanks for the tip.


The proximity sensor is very inaccurate on my FP2 too. My ear is hitting notifications and the backlight is pretty annoying.

I’ve tried the sensor app and it does detect my ear but the phone app does seem to pick it up.

1 Like

It’s the same with me.
The real problem is that all kinds of touch actions are being initiated when the screen does not dim.

1 Like

I do have the same issue. The screen stays on.

And sometimes I end the call unintentional.


Hey there, having made some calls with my fairphone2 now, I observed that something is wrong with the approximation detection (or something similar).
Whenever I make a call with the FP2 on my ear, the screen switches off when holding the phone next to my cheek. So far, so good.
However, within a period of ca. 30 seconds, the screen lights up and the same moment, the phone recognizes all touches of my cheek. This sometimes makes the phone hang up, just dial some random numbers, or do other weird stuff (like muting the call or switching to speakerphones which is particularly funny having the thing right next to my ear :expressionless:)
The only solution is to move the phone away and slowly moving it bact to my ear, to switch the screen off again. However, sooner or later, the problem reappears. This happens very often and during some calls almost constantly.
How can I fix this? Is there a sensitivity value somewhere or is something broken? The phone is not really useable like this and after all, I want to use my phone for making calls mainly.

1 Like

That the screen got active while calling happened from time to time also for me.
I would say it is a combination of these issues

  • problem with the sensitivity of the proximity sensor
    (people complain about a too or a too low sensivity…)
  • the position of the sensor (quite far [2cm] away from the middle of the speaker) and
  • the big size of the phone
    –> so already a small tilt/move of the phone can move the sensor some mm-cm away from the skin and can cause the screen going active.

I have no idea, how to solve this issue properly, as there is no setting for the sensitivity up to now.

Furthermore I found some bad combinations of factors during making a call:

  • speaker is not very loud
  • –> needs to bring it very close to the ear
  • –> the quite hard edge of the FP2-bumper/case presses against my ear, which I find very uncomfortable (especially for longer calls, which ending up with a hot and red ear for me :frowning: )
  • plus: my headset is the wrong to work with the FP2, as it supports only the wrong standard (which the FP1 had)…

I don’t know if we should push the proximity sensor problem to the bug-list or at least to the feature request list?
Similar issues are reported here and here and [here] (FP2 proximity sensor not reliably turning off screen during calls - See first Post for Workarounds) and here and here


I seriously hope it can be resolved with a bugfix. If it’s a Design flaw, this phone won’t work for me.
Speaker volume is an issue for me as well. The Speakers are not loud enough, while my old Samsung headset is incredibly loud even on the lowest volume setting and hurts my ear when i use it.

1 Like

I don’t understand your problems.
The sensor is relatively near to the edge, but since I knew that, I didn’t have any problems at all.
In addition to that, I have to set the sound (Press volume keys while talking) to the middle, because it’s far too loud for me. :astonished:

About the question “is it a bug or feature request”: I guess the proximity sensor sensitivity could be optimized a little in general, but since real problems only happen for a few people a setting to alter sensitivity on your phone would make sense too.

So as I see now, the sensor can only detect 5cm in distance.

With this I believe tweaking is only possible very limited here…
I think it It is just in a unlucky position at this large phone near the corner…
With this it is really easy make the sensor active accedently :-/

Increasing the response time is maybe also not the best way, as people complain about a slow reacting screen after the call…as we know form FP1…

For me with FP2 it works perfectly now, but with FP1 it was a real pain in the ass. So I learned to press the on/off button before I started a call (before talking) and to press it again before ending the call. That’s no a real solution, but a quick and easy to get used to workaround…

1 Like