FP2: Problems with using MyPhoneExplorer via USB under Windows 7

I have problems to connect to my Faiphone2 with MyPhoneExplorer using the USB port.
Here is what I did so far:

  • Install MyPhoneExplorer (both the Windows exe and the Client App)

    • Handshake via WLan works
  • Trying different USB ports of my laptop:

    • Funny first issue:
      • For the power USB port the MyPhoneExplorer client says that the USB cable is not connected, but I can use this port (e.g. adb detects the device)
      • Only for “ordinary” USB ports is say that a USB kabel is connected
    • OK, continue with the oridinary port

I installed an adb for Windows:


  • enabled USB debugging

BUT (still) always when I try to connect:

  • Message: “USB Verbindung wird vorbereitet” (USB connection is prepared)
  • Message: "Verbindung zum Handy wird aufgebaut über USB-Kabel
  • Message: “Fehler: Verbindung zum Handy konnte nicht aufgebaut werden” (Error: could not connect)

I tried some things:

  • I was wondering whether MyPhoneExplorer on my laptop need adb.exe in the normal PATH, so

  • I added its directory to the system variable Path

  • and even tests it to place it in the folder C:\Windows (with the two DLLs)

  • I tried different USB connection modes:

  • with MTP

  • with “charging” mode

  • This is strangely recommended by the MyPhoneExplorer Help for the connection error

  • I am not sure that this is correct, though

Does anybody has an idea what the problem could be?
Did anybody use MyPhoneExplorer for the FP2 via USB successfully?

I don’t know anything about Windows, but is there a small chance that the Privacy Impact is giving a problem?

Try unchecking all options.

I had some problems to install the driver, because I think the old adb driver of FP1 somehow interfered. Connect the phone (FP2 in usb debugging mode, none of the usb options in the status bar checked), then go to your Windows device manager and uninstall all drivers related to Android, adb etc. (Check the option “delete driver” in the confirmation popup). Reboot your computer. Install the Universal adb driver again. Now it should work.

1 Like

It’s not working for me too!
Had no problems with previous phone, even after upgrade to Windows 10 I was able to sync via USB
But FP2 refuses to connect, even after factory restore
So I’m using WLan for the moment
I’ll give it a new try, when I have some time

unchecking all options of the USB connection modes did not help

removed all devices:

  • Four “Android” under “Other Devices”
  • And one “Android Composite ADB Interface” under “Android Device”

and rebooted
and installed the universal driver again.
Didn’t help either

Thus, currently I have the 4 + 1 devices again.
But note that the 4 Android devices under “Other Devices” have an exclamation mark

Strange. Here it looks the same and works… Try it again and reboot the PC without having the phone connected… I had to do it several times as well and can’t remember what I actually did to make it work…

OK, after uninstalling all 5 devices and reboot the following happens:

  • Without connecting the pone, I have none of these 5 Android devices.
  • After connecting the phone, I have 5 “Android” entries under “Other Devices”
  • Then (without installing anything) one of the five becomes the “Android Composite ADB Interface”

Thus, I can’t install anything with the universal Driver again, because it says
"ADB Driver already installed".
Thus, it seems uninstalling the “Android Composite ADB Interface” does not really uninstall it.

Are you sure you deleted the driver from your PC by checking this checkbox?

Another thing that might be important is that the phone has to be conected to an USB2 port and NOT to an USB3 port (See http://www.fjsoft.at/forum/viewtopic.php?t=11454).


I finally found the log file of MyPhoneExplorer (Settings -> Connections: show logfile (with log data) or so)
and read:

14:51:59.43 ADB not found (C:\Program Files (x86)\MyPhoneExplorer\DLL\adb.exe)!!

Thus MyPhoneExplorer is searching adb.exe in its DLL directory, but:
in my installation of MyPhoneExplorer, there was no adb.exe (for whatever reason).
Only the necessary DLLs AdbWinApi.dll and AdbWinUsbApi.dll were there.

I copied adb.exe from my “Minimal ADB and Fastboot” installation into C:\Program Files (x86)\MyPhoneExplorer\DLL any everything worked!!!
It works with:

  • any connection mode EXCEPT “only charging”
  • even on the power USB port (although the MyPhoneExplorer client app says no USB connection exists)

Will send reports that to the MyPhoneExplorer forum later.
Please also see some hints to enable adb under windows here: https://forum.fairphone.com/t/adb-on-the-fairphone-2-windows-driver/11529/15


You could try MyPhoneExplorer via bluetooth or WiFi. It’s slower than USB, but it works very well…

There’s a list of backup tools that have been used by forum regulars (meaning not a collection of spam links, but rather things that we can be sure of actually have been tested with the Fairphone) here:

I’m closing this topic as the original problem was resolved and subsequent replies on backup topics in general are too often off-topic, spam (usually by adding in a link ~3 days after the original post), or both.