English

🇫🇷 🇬🇧 FP2 OpenOS read-lecture documents

Hello.
I have been using FP2 OpenOS for quite a moment and upgraded recently in Android9 (21.03.0-rel2). I am using stores F-Droid, but also APKPure (or Aurora Store in anonymous mode) for some private apps as Signal for example.
To read documents, I use Librera PRO for pdf files but could you tell me about an apps that allows to read documents such as word, excel, ppt, LibreOffice (odt, ods, odp) ?
There are lots of them but they are all tagged with adds and need GSF (what does it means?).
I found this one ‘All Documents Viewer/ Visionneuse de tous les documents’ that is not indicating having adds though it makes you sign their genral conditions of use indicating they have them and besides takes your datas for G analytics…!!!
The only apps I found is ‘LibreOffice Viewer’ from F-Droid, but it is a bit slow : do you know any alternative ?
Thank you very much for your informations, if you have some:).

Bonjour
J’utilise le FP2 OpenOS depuis un bon moment et l’airécemment upgradé en Android9 (21.03.0-rel2). J’utilise les stores F-Droid, mais aussi APKPure (ou Aurora Store en mode anonyme) pour quelques applications propriétaires comme Signal par exemple.
Pour lire les documents, j’utilise Librera PRO pour les pdf, mais pourriez vous m’indiquer une appli qui permette de lire les documents éditables word, excel, ppt ou LibreOffice (odt, ods, odp) ?
Il y en a des quantités mais elles sont avec publicité et nécessite GSF (qu’est-ce?).
J’avais trouvé celle-ci ‘All Documents Viewer/ Visionneuse de tous les documents’ qui n’indiquait pas faire de la pub, mais quand on l’installe elle demande d’accepter des conditions générales où elle indique non seulement faire de la pub mais exploiter vos données personnelles, en plus pour G analytics…!!!
La seule appli que j’ai trouvé est ‘LibreOffice Viewer’ via F-Droid, mais elle est un peu lente : connaitriez-vous une alternative ?
Merci d’avance pour vos indications si vous en savez plus:).

Collabora Office! It’s the best app for such editing I have ever found, based on LibreOffice.
You’ll have to add it as an F-Droid repo. Go in F-Droid settings, repositories, +, paste the following link : https://www.collaboraoffice.com/downloads/fdroid/repo?fingerprint=573258C84E149B5F4D9299E7434B2B69A8410372921D4AE586BA91EC767892CC
Then update the repositories in F-Droid (just pull down from the main page) and you should find two new apps: Collabora Office 6.4 and Collabora Office Snapshot. The snapshot version is a nightly (updated every day from the source) and the normal one once a week.
It’s not very fast (wouldn’t expect so on a FP2), but works really well.

Google Services Framework.

1 Like

Hello Alexis : thank you very much for your help and your indications !
It did what you indicated but on my FP2, it says the apps is not compatible ‘application non compatible avec votre appareil, l’installer quand même ?’. I tried to install it all the same but it doesn’t work, so I guess I will continue to use ‘Libre Office Viewer’ that makes the job for the moment…

Hello Alexis : merci beaucoup pour vos indications.
J’ai fait ce que vous indiquiez mais sur mon FP2, à l’installation on indique ‘application non compatible avec votre appareil, l’installer quand même ?’. J’ai quand même tenté mais cela n’aboutit pas, donc je vais continuer à utiliser ‘Libre Office Viewer’ qui fonctionne malgré tout…

:uk:
Oh, yes, I’ve been having this problem as well.
In F-Droid on the app’s page, just go down, open the “Versions” tab, and then install the second one, the one compatible with armeabi-v7a, it’s the one compatible with the FP2. For some reason it isn’t selected automatically.
Then it should work.

:fr:
Ah, oui, j’ai eu ce problème aussi.
Dans F-Droid dans la page de l’appli, descends et ouvre l’onglet “Versions”, et installe la deuxième, celle compatible avec armeabi-v7a, c’est celle compatible avec le FP2. Pour une raison elle n’est pas sélectionnée automatiquement.
Ensuite tout devrait marcher.

1 Like

Thanks for this add-on Alex (sorry about the mistake on your firstname;)…)!
I have access only to 6.4.9 (or 6.4.99 for the Snapchat one…) and not to anything else, so I can’t go further. Maybe they don’t left this version on the store?
Merci pour ces précisions Alex (désolée pour la faute sur le prénom;)…)!
Je n’ai accès qu’aux applis 6.4.9 (ou 6.4.99 pour la version Snapchat…) et du coup ne peux aller plus loin. Peut-être ont-ils enlevé la version du magasin?

:uk: Okay, with images. Can you install this version? (instead of "Aktualisieren you should have “Install”
:fr: Bon, avec des images. Est-ce que tu peux installer cette version? (au lieu de “Aktualisieren” tu devrais avoir “Installer”)

1 Like

Thank you! Unfortunately, I have no access to that possibility, only to 6.4.9 version: screenshot enclosed.
Merci:) Mais je n’ai pas accès à cette possibilité: seulement à la version 6.4.9: voir


photo jointe.

:uk: And if you tap install here?
:fr: Et si tu essaies d’installer depuis ici ?

Incredible: thanks a lot, it works! Who said ‘informatics are exact science :wink:’?
Incroyable: merci vraiment beaucoup, ça marche! Qui a dit que ‘li’nformatique est une science exacte :joy:’?

1 Like