English

FP2 not recognized by Windows 10

Dear friends

I cannot connect the FP2 to my older desktop pc running win 10 (64 bit) – but I do connect it smoothly to other people’s pcs running win 7 or 10!

On my own pc I hear the well known sound both when connecting and disconnecting the FP2. In the device manager I can see some Android device – but without driver. I have installed the ADB driver (from adbdriver.com).

I have tried with another cable (and usb port), I have tried to inactivate the windows firewall and windows defender, I have even tried an FP2 factory reset.

When I uncheck all boxes in the USB connection popup (instead of MTP selected) I actually see some G drive in windows explorer (and the battery starts charging) – but when I try to access it, it says “insert a disk”. I have tried selecting USB Debugging in which case the G drive somehow changes to a (still inaccessible) F drive.

Sigh! Please, any solution…?

All the best,
Henrik

Aw, just thought the FP2 was supposed to be able to connect to my pc… ;-(

/henrik

Have you had a look at
https://forum.fairphone.com/t/pencil2-adb-on-the-fairphone-2-windows-driver/11529?source_topic_id=17548
?

Do you have an SD card? Maybe it doesn’t work well or the empty slot it somehow recognized. Because, as far as I know, the only USB option to assign a drive letter to the FP2 is “mount SD card”.
With MTP or PTP in the Windows Explorer it appears just as “FP2”.

Thanx for replies.

Volker: Yes, I had read the “ADB on the Fairphone 2 (Windows driver)” dialogue (I guess it was therefore I installed the ADB driver). Now I also installed the “Minimal ADB and fastboot” and the command “adb devices” lists “8c30b6a6 device”. But still no changes in win10’s device manager and no FP2 in win explorer.

Following “Ensure that the ADB driver is still visible in bootloader mode” I tried the command “adb reboot bootloader”. Immediately the FP2 starts rebooting BUT it froze with the screen “FAIRPHONE powered by android” and I had to force a reboot – by disconnecting the battery!

In the device manager I tried “update driver software” but win10 can’t find any drivers…

Irina: No, I have no SD card and nonetheless I see an inaccessible G: drive (“insert disk”) – no FP2. That is, in USB debugging mode and all boxes in the USB connection popup unchecked.

Aw… ;-(

This is how the phone looks in fastboot mode, so that behavior is as designed.
with the command fastboot devices you should then see a connection to your phone. you can also reboot by using the command fastboot reboot.

The problem was that nothing happened, the FP2 was “frozen”, it didn’t react to my pressing the powerbutton (and after a few minutes I opened and removed the battery – what else could I have done?).

Yes, the command “adb devices” lists “8c30b6a6 device” – but no FP2 visible in windows…

adb and fastboot are two different things.
When the phone runs in bootloader mode (or fastboot mode), the phone looks like frozen. with fastboot devices you can check connection to your phone. Note that in fastboot mode adb does not work!

But in any case, I don’t see how this will help you for your Windows machine to recognizing your FP2.
I just wanted to say that the phone most likely was not frozen but simply in fastboot mode, which is what it is supposed to be after you rebooted it into the bootloader.

I had similar problems getting my FP2 connected to Win 10. I’ll recount what I did from memory so the instructions are a bit fuzzy, but you should be able to work it out.

First, make sure you have the Windows Feature Pack for Win 10 installed (if you have Windows Media Player installed, you’ll have the feature pack).

In device manager, right click on Android Device, update driver software, browse my computer for driver software, let me pick from a list of device drivers on my computer. That should come up with a couple of local drivers (presumably they’re held on the FP2 itself), one of which is the MTP driver required to connect as a media device.

That allowed me to connect my FP2 to my laptop just like any other Android. No need to use ADB or any debugging options on your phone - as the name suggests these are for debugging, not for connecting your phone as a media device.

Thanx, if I only had known… :wink:

Selecting this I get a list of device types. If I select “portable devices” (or is it “mobile devices”, I have a danish windows), win10 just says “no drivers”. I don’t know what else to select…

But I totally agree, I have no interest whatsoever in ADB or FP2 debugging options – I just want to transfer some files back and forth!

You might also use MyPhoneExplorer for just transferring files.

Thanx a lot, Volker, now I can transfer files!

MyPhoneExplorer only works when selecting usb debugging mode and with all boxes in the usb connection popup unchecked (the program recommeded the charging option, but never mind).

So, for the time being this certainly is an acceptable workaround – after months without any pc contact with the phone at all! :smile:

Happy to hear that idea has helped! :slight_smile:
You might also use wifi with MyPhoneExplorer instead of USB if you have a wifi router. For me that works well.

You can also install the MPE app which allows you to connect through WiFi. It’s a bit slower than transferring through USB of course but I find it more comfortable :slight_smile:

Thank you, thank you.
I’ll try the wifi option later, perhaps also the MPE app…

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.