FP2 not rebooting after updating to 21 / Android 9

One important question for others … have you kept the data that was on the phone at the start even after this final manual re-installation of Android 7.1.2 (Fairphone OS 19.11.2)? Or was it like all new from the box again with all data wiped?

Success! Posting this from Android 9 on the same phone.

After the second attempt to manually install Android 7 (which worked), I removed a couple of apps just in case, and went back to the updater. It took a few tries to download (one seemed to stop, and i had to restart to make it go again), but it was applied, rebooted, and took a while with white-ring update screen.

I hit the never-ending blue dots screen after that, and restarted by holding down the power button, but it booted and logged in fine after that.

The other thing I did differently this time round was a “basic” update rather than the “advanced” route, but I think the issue is more just things being a bit intermittent maybe…

Thanks for all the help, glad we made it with a bit of persistence and luck!

4 Likes

Yes, all my data and apps are as before (as far as I know) - I didn’t have to do any factory reset, and didn’t wipe anything during the process.

7 Likes

Hi everyone,

I have the same issue as described here so I would like to reinstall the old Android OS version via computer too.

My issue is that, first, it is required to turn off the secure start up, according to the guidelines. Could someone help me to do that in the troubleshoot mode ?

Sorry for my tired English and thanks in advance, any help very much appreciated!

You are referring to a FP2 (and not FP3), right? There’s no “secure start up” for FP2. What guidelines do you mean, can you send a link?
You might also open a new topic using your native language if you preferred that (just saying).

Thank you very much for your answer! I didn’t know there was no secure startup on FP2.
I was referring to these guidelines, where they do say that you have to disable secure startup first: Manually install Fairphone OS for the Fairphone 2 – Support
But it’s great if it’s not a problem.
In the mean time, I have tried a factory reset because I was beginning to feel hopeless (I have set an automatic backup via Google I think). But it didn’t worked.
I am now in the same situation as described here: Fairphone OS 19.11.2 update. Upgrade error: Unable to find partition for path '/system' - #5 by Aitziber
The similarity with this post is that I cannot find my phone on my computer via USB… I only have old USB cables with me at the moment and they don’t seem to work. Sometimes the phone appears in the device manager, but only briefly. And in ADB it doesn’t appear at all.
I don’t know what to do now. Do you have any idea?
I think there aren’t as many fairphone users in my native language (French) as in English, and I would not have had such a fast answer, so I wil make an effort with my English.
But maybe I should open a new topic as you suggested? I wasn’t sure if it was relevant since my issue seems similar to others

I realize I haven’t finished trying the guidelines since I thought I had to disable secure startup first. So I will try that before solliciting you any longer.
I think I left my phone in TWRP mode for too long, the battery is fully decharged. So I will let it charge for a while first, before trying again with the guidelines. I hope it works…

Ok, thanks, now I know what you mean. I don’t think that should apply here. Especially now that you’ve done a factory reset and the data partition should be cleared.

Yes, you’ll need a working usb cable for the manual installation. You might check the cable by going to #dic:fastboot and typing fastboot devices which should show the code of your device if all is working.

I’ll keep my fingers crossed! :crossed_fingers:

1 Like

Great news: the manual installation eventually worked!

Thank you infinitely for your answers!
I really was on the verge of a nervous breakdown here (in full isolation ugh) so it gave me a push to stay calm and keep up with the instructions :pray:

4 Likes

Congratulations, that’s great! :+1: :slight_smile:

1 Like

Glad it worked - I had the same feeling when my phone failed to restart!

1 Like

I have the sam issue as @scribe and @Ludwina

After upgrading the Fairphone now i cannot leave from the TWRP menu. I will try again the manual update with the computer. I did it yesterday but the window kept saying there was no Fairphone connected. Hope it works now!

If the Fairphone is not detected and your PC is on Windows 10: here is a HowTo install the necessary drivers via Windows Update

3 Likes

Thanks @Ingo I have FP2 and I’m trying to connect it to a macbook.

I’ve tried following the instructions as here: Manually install Fairphone OS for the Fairphone 2 – Support

But the computer doesn’t recognise my FP2, so I’m still stuck at the TWRP menu.

For Mac you might want to watch this issue: Stuck in Recovery Project (#50) · Issues · products / Android 9 on the FP2 · GitLab

There is no solution yet but it seems like the same problem, also with Mac.

2 Likes

Yesterday I downloaded the new Fairphone II Update (directly on the phone, not via computer). After that I did the requested new start. Then “Fehler” (failure) appeared on the display for a short time. Then it changed to a black display, with “Fairphone” on it (like the start display). Nothing moves, and the phone doesnt start. I can only stop it by removing the battery. When I want to start the FP II again (with the battery inside), its the same situation.

Maybe the battery was a problem during that process. At the beginning there was enough battery. Later not. So I charged the phone completely again. If I charge it now, there is a green light. So I guess the battery is complete now.

This year I bought a new bottom module, so that should not be the problem.

I already spent lots of time at the Fairphone Forum and at different Fairphone helping sites, but I could not fix the problem yet. Do you have an idea? I really would be very grateful for that, since I dont want to lose all my stuff and numbers! Thank you very much in advance!

Hi and welcome to the community forum!

I moved your post here to the existing topic with the same problem. It seems people were able to fix the situation with a manual installation. For the details check the earlier posts.

1 Like

Hi DaG, that does sound like what I hit. If you hold down power+volume up when restarting the phone as per this post above, do you get the Recovery menu?

Hi,
I pressed volume up + power, then I was here: Android Recovery / 7.1.2/19.11.2.
Then I did the following:
“Reboot system now” (I press power + volume up, this option gets green then and the FP II trys to start again. But the black display only showing „Fairphone“ stays the same).
I press power + volume up again, then it says: “No command” (and the lying robot above). Again I press power + volume up and reboot system now, and again there is that black display with “Fairphone”.

Do you have any idea? Maybe @scribe or @urs_lesse who had that problem, too? How did you manage it finally? I am so grateful for your help - I really need the data and numbers on my phone… Thanks!!!

Other options at “Android Revovery” are the following (I really hope NOT to have ro reset everything!!!):

  • Reboot to bootloader
  • Apply update from ADB
  • Apply update from SC card
  • Wipe data / factory reset
  • Wipe cache partition
  • Mount / system
  • View recovery logs
  • Run graphic test
  • Power off

Same with me. I already tried the “Wipe cache partition” function bit it it didn’t change anything. The Phone is still stuck in the “Fairphone powered by android” screen.