English

FP2 not charging anyome, constant red light for a few minutes

solved
charging
Tags: #<Tag:0x00007f57de9a7850> #<Tag:0x00007f57de9a7648>

#1

Hello,

last week my fp2 did not start anymore after loading it on my laptop.
It pretty much just shut off and did not turn on anymore.
When trying to load it, it just shows a constant (not flashing/ blinking) red light for about 5 minutes.
I already browsed the forums, tried different cables, pressing the power butten > 4/ > 10s, as well as together with the volume button.
I also tried to take off the battery for more than an hour and plug it in again. Also i tried to load the battery with an open back, in case the contact to the bottom module would have been disturbed…

I tried different charging plugs, cables, as well as different voltages (5V,1A and 5V 2.4A)… finally I bought a new battery which did not brought any change and later on replaced the bottom module.

None of this worked…

Is there anything I could try to make it work again?

When ever I put it in to charge, it just shows a constant red light LED for about 5 minutes and then the LED turns off.
After plugging it off, waiting ~ an hour I can repeat the process, the LED shows the red light and then turns of after 5 minutes


#2

Hi @FPFP2,

did you see the Fairphone Logo on your display when you plugin the charger with the battery removed?

Regards
Christian


#3

Hi Christian,

I did not see anything.
At last saturday I opened a support ticket and today send in my phone, as it seems to be pretty much dead.
Thank you still for replying!