English

FP2: No 3G/4G – only "E" connectivity

Hi

I have bought a Fairphone 2 and installed Lineage 17 on it.
My SIM and contract support 3G respectively 4G but all I get is that lowband connectivity where the phones display an “E”.

Does anybody know how to solve it?

I already contacted the provider of the SIM and they cannot help.

Looking forward to your replies!
K

Please check your APN settings, details can be obtained from your network provider.

Thanks.

I looked at the proposed settings on two websites (one by the provider). Basically everything matches to the settings on my phone. Doesn’t seem to help…

You might consider to (temporarily) reinstall FPOS to see if it’s related to LOS or not.

I don’t know Lineage, bit if it’s similar to classic Android, have you checked in Settings > Network and Internet > mobile network (with your provider name under) > Advanced Settings > Preferred network type > if “2G only” is selected instead of “auto 2G/3G/4G” ?

Please note that these settings denominations may not be exact, as I am on classical Android 10, on FP3, and translating myself.

2 Likes

If the intersection of frequencies/bands that the phone supports and the frequencies that your network provider uses for 3G/4G is empty, you won’t get a connection. FP2 supports:

  • GSM/GPRS/EDGE Quad-band: 850, 900, 1800, 1900 MHz
  • WCDMA Band 1 (2100 MHz); Band 2 (1900 MHz); Band 8 (900 MHz)
  • 4G / LTE Advanced Band 3 (1800 MHz); Band 7 (2600 MHz); Band 20 (800 MHz)

Does your provider use any of these bands? I’d expect so in Leipzig, but doesn’t harm to double-check. :slight_smile:

So let us just focus on the last line:

I’ve had the same when using two SIM-cards. Please note the phone can only support one network at 3G or 4G and the other will be at slow speed. In your settings (I believe under ‘SIM’) turn one SIM down to 2G and permit the other to do 4G.

Please let me know if this worked.

4 Likes

Hey,

thanks for the many replies.

I tried some of the advices, but none of them worked so far.

  • setting apn manually doesn’t solve it
  • setting one of the simms to 2G doesn’t help

What I realized only now is that the automatic set up for mobile data via sms, doesn’t do anything. I just get a 4 digit pin and afterwards an info that my phone will be set up after I installed or saved the settings I just received.

I would expect a pop up by the phones OS that asks me to install the settings, but that doesn’t occur. Also sending back the PIN only creates an error message by the provider.

Any further thoughts on that?

You mean SMS to automatically set the APN settings? I think that does not work on the FP2, at least it did not when I got mine 5 years ago, so APN need to be set manually.

Did you delete all APN and set up completely new? If not I would do

However, overall as long as you can connect to internet I would think APN should not be the problem

And this happens, irrespective of where you are? Just asking because if you tried only at 1 place it might be that there is only 2g available? Can you test another SIM, probably from another provider?

Hello. I have had problems with a bad mobile data connection. Tightening the screws on the motherboard, especially those holding the antenna on the left, improved the situation.
Good luck !

2 Likes

I also had this problem when inserting a second SIM. For me it was solved by swapping the two SIM cards.

1 Like

Hello everybody,

it appears that the problem was solved without any action on my behalf. The only idea I have is that it had to do with the SIM provider chaning from 3G to 4G. I got a message from them, however I couldn’t imagine that switching to 4G was accompanied by 3G not working at all.

Thanks for your kind advice anyway! Looks like this forum is very alive!

Cheers
K

2 Likes