FP2 locked at boot screen and cannot recover

My phone (FP2, newest Fairphone Open OS / Android 7) gave up this afternoon and I’m trying to recover it, what I’ve done so far:

  • During charging my phone locked up. Green LED but would not turn on. Tried reboot and was stuck with only the boot screen.

  • Tried removing battery for a while, same issue.

  • Tried getting into TWRP (Volume+ + power on) and got the initial TWRP screen but no input working, and with USB to my computer ADB responded with:

    adb devices
    List of devices attached
    1571b6c2 unauthorized

  • Tried fastboot with volume- + power on, and it works.

    fastboot devices
    1571b6c2 fastboot

  • Tried reflashing the recovery partition using same TWRP as was already on the phone:

    fastboot flash recovery twrp-3.2.3-0-FP2.img
    target reported max download size of 536870912 bytes
    sending ‘recovery’ (10360 KB)…
    OKAY [ 0.330s]
    writing ‘recovery’…
    FAILED (remote: flash write failure)
    finished. total time: 10.365s

  • Tried going into recovery anyway (volume+ + power on) but now that just gets me into fastboot too!

  • Now I keep poking the device and I’ll keep you posted.:slight_smile:

EDIT: Formatting

This is normal.
I think the only thing you can do with ADB and TWRP is putting TWRP into ADB sideload mode (Advanced - ADB Sideload - Swipe to Start Sideload), then “unauthorized” will change to “sideload” (if you check again), and you can sideload stuff via ADB.

I see. Not sure this is as intended though (at least not as I remember it?). I got your tip from the other thread about fastboot booting TWRP from RAM and that works, but I just get a TWRP logo screen. I have no buttons or options on the phone.

Now it appears as “recovery” from adb devices instead, if I try to do adb backup it asks me to “Now unlock your device and confirm the backup operation…” but the screen remains on the TWRP logo and nothing else.

Ok, you got me searching the web, and my knowledge was old.
While not supporting the full ADB set of commands, TWRP from version 3.1 on supports adb backup and adb restore operations …

https://twrp.me/faq/openrecoveryscript.html (see “HOST SIDE” section").

This is new to me too, good that you learn something out of this as well.:slight_smile: I’m trying and will read up myself, but my issue right now is that I cannot find a way to decrypt (or unlock) my device while in this TWRP-screen. adb shell is working so something is running at least!

Messing about in my adb shell this looks like my mmc flash going down for the count. From dmesg:

<6>[ 1107.526256] mmc_blk_issue_flush: requeue flush request after timeout
<3>[ 1107.526256] mmc0: cache flush timeout
<3>[ 1107.579449] mmc0: mmc_interrupt_hpi() failed (-110)
<6>[ 1107.579588] mmc_blk_issue_flush: requeue flush request after timeout
<3>[ 1107.579588] mmc0: cache flush timeout
<3>[ 1107.632797] mmc0: mmc_interrupt_hpi() failed (-110)

And so on when I try to access any folder mounted from the MMC. I don’t expect I’ll get much data out of this even if I had the chance. Opening a support ticket with Fairphone, this phone is about 16 months old.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.