FP2 keeps rebooting after water damage

My FP2 took a swallow dive into the ocean a week or so ago. I immediately fished it up again, and disassembled the battery, and put the FP2, back cover and battery in my backpack. At home, an hour or so later, I disassembled all the modules from the core module, and rinsed them thoroughly in fresh water, and put them in my hot air stove on 50 degC for several hours.

After reassembling the FP2 again, it is no longer able to boot up completely into Fairphone OS. Sometimes it reaches the point where I can press the PIN code, other times it just reboots right after the bootloader finishes (the FAIRPHONE logo on black screen, a couple of seconds when powering up).

I tried reflashing the phone using step 4 in this article (https://support.fairphone.com/hc/en-us/articles/207914363-Manually-install-Fairphone-OS-for-the-Fairphone-2), thinking that the immersion in water had corrupted the data in some way. Flashing the FP2 worked fine. But the reboot behavior is the same.

Anybody’s got an idea to what it is that’s causing this behavior?

Thanks for any help!

Fresh water is better than sea water but still has lots of minerals that can form sediments that destroy electronic parts. You should (have) use(d) distilled water or alcohol.

Open up the phone again and see if anything needs further cleaning.
We have a guide for waterdamage called the #waterwiki.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.