FP2 incoming call screen freeze issue

Hi there,

I have a FP2 with a very annoying issue. I’ve tried different things over the last couple of months, including trying a few offered solutions for similar issue’s I’ve found on this forum.

The issue I’m experiencing is a total screen / phone freeze in +/-50% of the cases at the moment of an incoming call. Most of the times it rings 1-2 times and then freezes. The only way out is a reboot by pressing the power button >30sec. The issue is independent of sim-cards, I have two installed and it happens on both.

A few things I already tried to do.

First a few solutions for similar issue’s I found on this forum:

  • Checking the phone app permissions
  • Checking if the ringtone was changed to an alternative ringtone
  • Proximity sensor calibration

As none of these didn’t help, I also tried a few other things:

  • Cleaning the Sim-cards
  • Factory reset
  • Upgrading to the latest FOS
  • I’ve now installed a whole other OS.

And to be clear: all without any success whatsoever.

Hopefully someone here can guide me in the right direction to fix this unworkable issue.

When you say “the screen freezes” do you mean you are called while the screen is black and you can’t unlock it in this situation or the screen is on as you are called and the screen freezes at whatever it displays at that time? Or both?

Did you check the notification settings for the app?
Though factory reset and (re)installing OS or even switching OS should really fix any such settings issues - any software issues really.

Do you know someone else near you with a Fairphone so you can try your SIM cards in their phone and vice versa and maybe also switch screen for testing? If not maybe there are #fairphoneangels close by?

It’s the last one: the screen is on showing the phone app answer screen. Sometimes it freezes before reaching the screen and sometimes it freezes the moment the phone icon is slid down to answer the call. But the screen is never black and always stays on until I do a reboot.

Checked notification settings; all switched on, except that the last line of the notification is a information icon with the text ‘1 category removed’. I can’t click on that.

And no #fairphoneangels nearby unfortunately, also not with a FP2. But I will do some troubleshooting with the SIM cards.

@Marx Do you still have this issue?
I’ve had it myself for a while now.
I exchanged screens now for testing and so far I can’t reproduce the issue.
I also haven’t experienced the “Strange screen issue” since I exchanged the screen.
I’ll do some more testing as neither issue was reproducible all the time with the old screen either.

Yes, and it even got worse and happens almost every phone call, but I also found that I can prevent it by picking up very quickly.

But your message is very helpful, and I’m very interested if the issue is solved for you now.

1 Like

Well I haven’t had the issue since I changed the screen. I now switched back and can’t reproduce it atm either, but the other issue I mentioned came back immediately when switching back to my original screen.
I’ll try calling myself after the phone has been a sleep for a while longer. Whenever it did happen I remember I hadn’t used it for a while.
Do you think it could be to who calls you. So far for testing I used my grandmothers phone to call me and couldn’t reproduce the issue once that way.

PS: Okay, that didn’t take long. To quote the giant from Twin Peaks season 2: “It is happening again. It is happening again.”.
So yeah, pretty sure it’s a hardware issue of the display.

1 Like

I’m not familiar with Twin Peaks, but I get the point. :smiley:

Great troubleshooting. I’m going to order a new display and I will report back after swapping the screen. As the problem occurs very often, it’s quite easy to say if it’s solved or not.

1 Like

I’m so sorry. It seems the other display didn’t fix the issue after all. It just happened again. :frowning:

Ah, unfortunate. Thanks for letting me know. I just cancelled my order. Not sure yet if I give up or continue troubleshooting…the phone is really unusable right now.

Have you tried a #dic:hardreset yet? If it’s not a hardware issue that’s the most likely way to fix it.
I haven’t tried yet as I currently can’t find my external SD card to back up my data on.

Yes, I did, even more than once. No luck however.

Today I found that if I wait a minute or two, I get the message that the phone app is not responding and I was then able to end the process. Thereafter, I got the same message for system UI. After choosing end process again, the phone was working again. Still, the caller already got the voicemail, so it makes no major difference. And I have to try if this works every time or not.

Meanwhile, I feel like I’m running out of options and thinking of switching phones.

Having experienced similar problems lately. Running Open OS 18.10(?). And in addition to that suffering from lack of access to the left “margin” of my touchscreen. People calling me often being redirected to voicemail, though no signal appears on my FP2, until a voicemail message appears. Outbound takes forever to reach the Telephone operator network…

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.