FP2 GPS not working

Which version of OS do you have on your phone?
The ‘normal’ OS or the Open OS?
Did you apply the update to either 1.3.6 or 16.05 (OpenOS).

Now there are questions I haven’t the faintest idea how to answer! I had an updated a few days ago… How do I find out which version I have?

Got it! I have OS 1.3.6

1 Like

Sometimes I experienced the same in if I use my FP2 in narrow streets or public transport, where there is a poor GPS signal. Sometimes it takes a while to localize your position.
What happens if you use your phone on open places?

Your can improve your positioning if you allow to use WiFi and GPS data as well.

I seem not to get gps unless in central London… I travelled for two hours in the country and all the time the message said “searching for gps”. I’m sure the Fairphone people will sort it in time.

This may be a stupid question but could it be you don’t actually have GPS enabled but only Location via Wifi and Cell Towers? That would explain why you’d get a position in the city center but not in the countryside.
Go to Settings > Location and set it to “High Accuracy”. Does that change anything?

I checked this and High Accuracy is already on. I am in London for the next few days so can’t test again until Tuesday when I go to the country again… will check more closely to see what happens. Thanks all for your helpful suggestions so far.

I’ve just driven from Devizes in Wiltshire to London. Most of the way it had a notice saying “Searching for GPS”. At odd times it showed me somewhere near where I was, but didn’t track me at all, and sometimes was miles out. I don’t see anyone else having difficulty with this so think I must have something wrong on my particular phone. Any suggestions gratefully received.

That means that your GPS is not working at all and you only get a location via Wifi and Cell Towers.

You could download an app like SatStat, go somewhere where you have an unblocked all around view of the sky and see if you can get any GPS signal at all.
If you don’t I guess it could be a hardware issue, if you do you could try some tips from the #gpsguide (Ignore everything about A-GPS and EPO as that’s only for FP1) to see if you can improve your GPS connection.

Thanks I will do that. If its a hardware issue I guess I have to get on to the Fairphone people. I’ll try your suggestion first. Thanks.

OK for those interested here is where I’m up to: I recalibrated the phone… Several times and it does now generally point in the right direction, but I’m in London now, and it works sort of. It never seems to be quite sure where I actually am. There is always the larger pale blue circle around the location dot. I certainly don’t feel I can rely in it. I hope sometime something will sort it out.

Yeah, that’s still just location via wifi and cell towers, so your GPS seems to be totally defunct. I guess a replacement/repair is the only option in your case.

So that is contact with Fairphone people. Thanks.

1 Like

Hi @Vivian_Broughton,

could you solve your GPS problems meanwhile?
Since your last post Fairphone released new versions of the operating system. Did you try to install them?

Dear Werner, No I haven’t solved it. If I am not connected to wifi I always
get the message ‘searching for GPS’. I think I have all the updates

Hi Vivian,

there are some GPS testing apps in the Play Store available. I’m currently testing which one could help to analyze your GPS problem.

EDIT: I tried this one:

and it was quite useful and did require only the rights for “location services”.
If it does not find any satelites (outdoor) you should definitely contact the Fairphone support to check your phone.

I will post it also here and add some further information:

1 Like

Thanks Werner… I had already downloaded this ap. It says ‘NO FIX’ in the top left box. It says 17 satellites in view but none connected. I have emailed the Fairphone people on 15th June, and have been given a ticket request number… but nothing further yet. I will try again.

Creating another ticket won’t speed up getting a response. Unfortunately the support is overworked, so getting a reply takes a while. However, you can make them aware that you have already been waiting very long for your request by posting your ticket no. here.

Dear all,

I have the same problem as described in this thread but not on the OpenOS, but on the regular Fairphone OS 1.8.1. Sometimes the GPS location fix takes 10 or even 15 minutes for an actual location. When checking the fixed satellites with “GPS Status” I have 5 to 10 of them within seconds. In this situation, restarting the app, restarting the phone, switching on and off the mobile data or the WiFi has no effect on it. Also, downloading fresh A-GPS data from the internet doesn’t help.

It looks pretty much like this for 15 minutes:

Strangely enough, Google Maps is able to give me a location. But the icon is a bit different (no circle for accuracy around my location.) Maybe it’s determining the location with Wifi and cell tower information?

If someone is able to help me with this issue I’d highly appreciate it. Please keep in mind, I’m running FairphoneOS and cannot tweak any config-files.

Thanks for your help!

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.